;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lean)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages multiprecision)
  #:use-module (guix build-system cmake)
  #:use-module (guix build-system python)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix download)
  #:use-module (gnu packages graphviz)
  #:use-module (gnu packages version-control)
  #:use-module (gnu packages python-build)
  #:use-module (gnu packages python-crypto)
  #:use-module (gnu packages python-web)
  #:use-module (gnu packages python-xyz))

(define-public lean
  (package
    (name "lean")
    (version "3.51.1")
    (home-page "https://lean-lang.org" )
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/leanprover-community/lean")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "17g4d3lqnbl1yfy2pjannf73v8qhc5003d2jkmrqiy05zkqs8d9n"))))
    (build-system cmake-build-system)
    (inputs
     (list gmp))
    (arguments
     (list
      #:build-type "Release"            ; default upstream build type
      ;; XXX: Test phases currently fail on 32-bit sytems.
      ;; Tests for those architectures have been temporarily
      ;; disabled, pending further investigation.
      #:tests? (and (not (%current-target-system))
                    (let ((arch (%current-system)))
                      (not (or (string-prefix? "i686" arch)
                               (string-prefix? "armhf" arch)))))
      #:phases
      #~(modify-phases %standard-phases
          (add-before 'configure 'chdir-to-src
            (lambda _ (chdir "src"))))))
    (synopsis "Theorem prover and programming language")
    (description
     "Lean is a theorem prover and programming language with a small trusted
core based on dependent typed theory, aiming to bridge the gap between
interactive and automated theorem proving.")
    (license license:asl2.0)))

(define-public python-mathlibtools
  (package
    (name "python-mathlibtools")
    (version "1.1.1")
    (source (origin
              (method url-fetch)
              (uri (pypi-uri "mathlibtools" version))
              (sha256
               (base32
                "089pql105imx8z7ar1wiz9fn000jp6xqdfixw4jf2vric94vn9fj"))))
    (build-system python-build-system)
    (arguments
     '(#:phases (modify-phases %standard-phases
                  (add-before 'check 'fix-home-directory
                    (lambda _
                      (setenv "HOME" "/tmp"))))))
    (inputs (list python-toml
                  python-pygithub
                  python-certifi
                  python-gitpython
                  python-requests
                  python-click
                  python-tqdm
                  python-networkx
                  python-pydot
                  python-pyyaml
                  python-atomicwrites))
    (home-page "https://github.com/leanprover-community/mathlib-tools")
    (synopsis "Development tools for Lean mathlib")
    (description
     "This package contains @command{leanproject}, a supporting tool for Lean
mathlib, a mathematical library for the Lean theorem prover.")
    (license license:asl2.0)))
a4aab7192afb'>gnu: go-github-com-olekukonko-tablewriter: Fix grammar....Vagrant Cascadian 2020-10-30gnu: emacs-org-generate: Fix grammar....Vagrant Cascadian 2020-10-30gnu: python-django-url-filter: Fix grammar....Vagrant Cascadian 2020-10-30gnu: r-vim: Fix grammar....Vagrant Cascadian 2020-10-30gnu: r-adamethods: Fix grammar....Vagrant Cascadian 2020-10-30gnu: resample: Fix grammar....Vagrant Cascadian 2020-10-30gnu: po4a: Update to 0.61....Julien Lepiller 2020-10-30system: Fix dependency for grub.cfg generation....Miguel Ángel Arruga Vivas 2020-10-30system: Fix grub keymap with store in btrfs subvolume....Miguel Ángel Arruga Vivas 2020-10-30gnu: Add r-perfmeas....Ricardo Wurmus 2020-10-30gnu: Add python-pydub....Tanguy Le Carrour 2020-10-30gnu: java-fasterxml-jackson-core: Add synopsis and description....Julien Lepiller 2020-10-30gnu: linux-libre 4.4: Update to 4.4.241....Leo Famulari 2020-10-30gnu: linux-libre 4.9: Update to 4.9.241....Leo Famulari 2020-10-30gnu: linux-libre 4.14: Update to 4.14.203....Leo Famulari 2020-10-30gnu: linux-libre 4.19: Update to 4.19.154....Leo Famulari 2020-10-30gnu: linux-libre 5.4: Update to 5.4.73....Leo Famulari 2020-10-30gnu: linux-libre: Update to 5.9.2....Leo Famulari 2020-10-30gnu: dune-configurator: Add synopsis and description....Julien Lepiller 2020-10-30gnu: ccls: Update to 0.20201025....Brett Gilio 2020-10-30guix: pack: Fix offset calculation for store directory mount point....Eric Bavier 2020-10-30gnu: Add lcdf-typetools....Julien Lepiller 2020-10-30services: guix-publish: Add 'cache-bypass-threshold' field....Ludovic Courtès 2020-10-30gnu: guix: Update to 1c6d985....Ludovic Courtès 2020-10-30gnu: php: Update to 7.4.12 [security fixes]....Tobias Geerinckx-Rice 2020-10-30gnu: cloud-utils: Update to 0.32....Christopher Baines 2020-10-30installer: Use UUIDs in the 'swap-devices' field....Ludovic Courtès 2020-10-30services: swap: Allow for UUIDs and file system labels....Ludovic Courtès 2020-10-30file-systems: Allow swap space lookup by UUID/label....Ludovic Courtès 2020-10-30gnu: r-calculus: Fix typo in home-page....zimoun 2020-10-30gnu: tome4: Update to 1.7.0....Oleg Pykhalov 2020-10-29gnu: emacs-tramp: Update to 2.4.4.3....Nicolas Goaziou