aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages kawa)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages java))

(define-public kawa
  (package
    (name "kawa")
    (version "3.1.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://gnu/kawa/kawa-" version ".tar.gz"))
       (sha256
        (base32 "06g015zjlfgsx0n4lb326czkbf1grlx0n6dx074m808hdg6m16lc"))))
    (build-system gnu-build-system)
    (arguments
     `(#:parallel-build? #f
       #:parallel-tests? #f
       #:phases
       (modify-phases %standard-phases
         (add-after 'install 'wrap-kawa
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (wrap-program (string-append out "/share/kawa/bin/kawa")
                 `("JAVA_HOME" ":" = (,(assoc-ref inputs "icedtea"))))))))))
    (inputs
     (list bash-minimal `(,icedtea-8 "jdk")))
    (home-page "https://www.gnu.org/software/kawa/")
    (synopsis "Java framework and implementation of Scheme, Elisp, and more")
    (description
     "GNU Kawa is an implementation of the Scheme programming language that
is built on top of the Java platform.  It is thus conveniently integrated
with Java and benefits from this by having a compiler, optional static
typing, and so on.  Kawa also serves as a framework for implementing other
programming languages on the Java platform.  Included in Kawa is qexo, a
partial implementation of XQuery in Java.")
    (license license:expat)))
-avail'>...* gnu/packages/python-check.scm (python-re-assert): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego 2020-10-30gnu: python-pyux: Fix grammar....* gnu/packages/python-check (python-pyux)[description]: Remove gratuitous use of "allows to". Vagrant Cascadian 2020-10-02gnu: Add python-pyux....* gnu/packages/python-check.scm (python-pyux): New variable. Maxim Cournoyer 2020-09-24gnu: Add python-robber....* gnu/packages/python-xyz.scm (python-robber): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Tanguy Le Carrour 2020-09-07gnu: Add python-pytest-toolbox....* gnu/packages/python-check.scm (python-pytest-toolbox): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Vinicius Monego 2020-08-31gnu: python-nbval: Update to 0.9.6....* gnu/packages/python-check.scm (python-nbval): Update to 0.9.6. Tobias Geerinckx-Rice 2020-08-09gnu: Add python-pytest-trio....* gnu/packages/python-check.scm (python-pytest-trio): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Vinicius Monego 2020-08-01gnu: Add python-pytest-ordering....* gnu/packages/python-check.scm (python-pytest-ordering): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Vinicius Monego 2020-07-30gnu: Add python-mypy....* gnu/packages/python-check.scm (python-mypy): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Tanguy Le Carrour 2020-07-30gnu: Add python-mypy-extensions....* gnu/packages/python-check.scm (python-mypy-extensions): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Tanguy Le Carrour 2020-07-29gnu: Add python-nbval....* gnu/packages/python-check.scm (python-nbval): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com> Vinicius Monego 2020-07-25gnu: Add python-pytest-env....* gnu/packages/python-check.scm (python-pytest-env): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego 2020-07-25gnu: Add python-covdefaults....* gnu/packages/python-check.scm (python-covdefaults): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego 2020-07-25gnu: Add python-pytest-mpl....* gnu/packages/python-check.scm (python-pytest-mpl): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego 2020-07-25gnu: Add python-pytest-remotedata....* gnu/packages/python-check.scm (python-pytest-remotedata): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego 2020-07-25gnu: Add python-pytest-openfiles....* gnu/packages/python-check.scm (python-pytest-openfiles): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego 2020-07-25gnu: Add python-pytest-filter-subpackage....* gnu/packages/python-check.scm (python-pytest-filter-subpackage): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego 2020-07-25gnu: Add python-pytest-doctestplus....* gnu/packages/python-check.scm (python-pytest-doctestplus): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego 2020-07-25gnu: Add python-pytest-arraydiff....* gnu/packages/python-check.scm (python-pytest-arraydiff): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego 2020-07-21gnu: Add python-pytest-aiohttp....* gnu/packages/python-check.scm (python-pytest-aiohttp): New variable. Efraim Flashner 2020-07-21gnu: Add python-pytest-services....* gnu/packages/python-check.scm (python-pytest-services): New variable. Efraim Flashner 2020-07-21gnu: Add python-atpublic....* gnu/packages/python-check.scm (python-atpublic): New variable. Efraim Flashner 2020-07-20gnu: python-pytest-vcr: Fix integration with pytest-5....* gnu/packages/python-check.scm (python-pytest-vcr): Update to 1.0.2-1.4d6c7b3. Efraim Flashner 2020-06-29gnu: python-pytest-flake8: Update to 1.0.6....* gnu/packages/python-check.scm (python-pytest-flake8): Update to 1.0.6. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Matthew Kraai 2020-06-22gnu: Add python-pytest-flask....* gnu/packages/python-check.scm (python-pytest-flask): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Edouard Klein 2020-06-22gnu: Add python-pytest-benchmark....* gnu/packages/python-check.scm (python-pytest-benchmark): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Edouard Klein 2020-05-26gnu: Add python-pytest-pycodestyle....* gnu/packages/python-check.scm (python-pytest-pycodestyle): New variable. Signed-off-by: Marius Bakke <marius@gnu.org> Edouard Klein 2020-04-07gnu: python-coveralls: Update to 1.11.1....* gnu/packages/python-check.scm (python-coveralls): Update to 1.11.1. [source]: Change to GIT-FETCH. [arguments]: New field. [propagated-inputs]: Remove PYTHON-SH and PYTHON-URLLIB3. Marius Bakke 2020-03-15gnu: Add python-pytest-vcr....* gnu/packages/python-check.scm (python-pytest-vcr): New variable. Efraim Flashner 2020-01-26gnu: add python-httmock....* gnu/packages/python-check.scm (python-httmock): New variable. Julien Lepiller 2020-01-26gnu: Add python-codacy-coverage....* gnu/packages/python-check.scm (python-codacy-coverage): New variable. Julien Lepiller 2020-01-15gnu: python-pytest-checkdocs: Add missing input....* gnu/packages/python-check.scm (python-pytest-checkdocs)[propagated-inputs]: Add PYTHON-DOCUTILS. Marius Bakke 2019-10-22gnu: Add python-pytest-isort....* gnu/packages/python-check.scm (python-pytest-isort): New variable. Hartmut Goebel 2019-10-05gnu: python-pytest-checkdocs: Update to 1.2.2....* gnu/packages/python-check.scm (python-pytest-checkdocs): Update to 1.2.2. [propagated-inputs]: Add python-more-itertools. Tobias Geerinckx-Rice 2019-09-13gnu: python-pytest-virtualenv: Enable tests....* gnu/packages/python-check.scm (python-pytest-virtualenv) [phases]{patch-virtualenv-executable}: New phase. [propagated-inputs]: Move python-virtualenv from here... [inputs]: ...to here. Maxim Cournoyer 2019-06-26gnu: Add python-pytest-virtualenv....* gnu/packages/python-check.scm (python-pytest-virtualenv): New variable. Ricardo Wurmus 2019-06-26gnu: Add python-pytest-fixture-config....* gnu/packages/python-check.scm (python-pytest-fixture-config): New variable. Ricardo Wurmus 2019-06-26gnu: Add python-pytest-shutil....* gnu/packages/python-check.scm (python-pytest-shutil): New variable. Ricardo Wurmus 2019-06-26gnu: Add python-pytest-flake8....* gnu/packages/python-check.scm (python-pytest-flake8): New variable. Ricardo Wurmus 2019-06-26gnu: Add python-pytest-checkdocs....* gnu/packages/python-check.scm (python-pytest-checkdocs): New variable. Ricardo Wurmus 2019-03-19gnu: Add python-vcrpy....* gnu/packages/python-check.scm (python-vcrpy): New variable. Efraim Flashner 2019-02-21gnu: python-coveralls: Update to 1.6.0....* gnu/packages/python-check.scm (python-coveralls): Update to 1.6.0. Tobias Geerinckx-Rice 2019-01-23gnu: Add python-coveralls....* gnu/packages/python-check.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Ricardo Wurmus