aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages jose)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (guix build-system meson)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages web)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages tls))

(define-public jose
  (package
    (name "jose")
    (version "11")
    (source (origin
              (method url-fetch)
              (uri
               (string-append "https://github.com/latchset/jose/releases/"
                              "download/v" version "/jose-" version ".tar.xz"))
              (sha256
               (base32
                "09c2kn9cjqkgx4g0rf6c2k3ng9970r468c9z7067j8kyf7ksywp2"))))
    (build-system meson-build-system)
    (native-inputs (list pkg-config))
    (inputs (list jansson zlib openssl))
    (home-page "https://github.com/latchset/jose")
    (synopsis "Object Signing and Encryption")
    (description "C-language implementation of Javascript Object Signing and
Encryption")
    (license license:asl2.0)))
packages?id=fe74e6ac6b0027ae1a0b918643f66bd1a61c3346'>gnu/packages parent7f221c0e0d412110cfc1c0057dca1123415987ec (diff)downloadguix-fe74e6ac6b0027ae1a0b918643f66bd1a61c3346.tar.gz
guix-fe74e6ac6b0027ae1a0b918643f66bd1a61c3346.zip
gnu: memcached: Update to 1.5.13.
* gnu/packages/databases.scm (memcached): Update to 1.5.13.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/databases.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index da2a193a1a..13312dff4a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -265,14 +265,14 @@ mapping from string keys to string values.")
(define-public memcached
(package
(name "memcached")
- (version "1.5.12")
+ (version "1.5.13")
(source
(origin
(method url-fetch)
(uri (string-append
"https://memcached.org/files/memcached-" version ".tar.gz"))
(sha256
- (base32 "0aav15f0lh8k4i62aza2bdv4s8vv65j38pz2zc4v45snd3arfby0"))))
+ (base32 "0qsdkjrns4f02lmabq8c7mzl5n4382q2p6a0dvmsjdcpjisagqb1"))))
(build-system gnu-build-system)
(inputs
`(("libevent" ,libevent)