aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages jose)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (guix build-system meson)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages web)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages tls))

(define-public jose
  (package
    (name "jose")
    (version "11")
    (source (origin
              (method url-fetch)
              (uri
               (string-append "https://github.com/latchset/jose/releases/"
                              "download/v" version "/jose-" version ".tar.xz"))
              (sha256
               (base32
                "09c2kn9cjqkgx4g0rf6c2k3ng9970r468c9z7067j8kyf7ksywp2"))))
    (build-system meson-build-system)
    (native-inputs (list pkg-config))
    (inputs (list jansson zlib openssl))
    (home-page "https://github.com/latchset/jose")
    (synopsis "Object Signing and Encryption")
    (description "C-language implementation of Javascript Object Signing and
Encryption")
    (license license:asl2.0)))
Add ghc-hedgehog....Jacob MacDonald 2019-05-22gnu: ghc-test-framework-quickcheck2: Fix typo "This package"....Vagrant Cascadian 2019-03-31gnu: Fix descriptions to not use quotes....Efraim Flashner 2019-03-18Correct name and email address for ng0....ng0 2018-10-01gnu: ghc-tasty-golden: Update to 2.3.2....Timothy Sample 2018-10-01gnu: ghc-tasty-rerun: Update to 1.1.12....Timothy Sample 2018-10-01gnu: ghc-tasty-th: Update to 0.1.7....Timothy Sample 2018-10-01gnu: ghc-quickcheck-instances: Update Cabal file to r1....Timothy Sample 2018-10-01gnu: ghc-tasty-quickcheck: Update to 0.10....Timothy Sample 2018-10-01gnu: ghc-tasty-hunit: Update to 0.10.0.1....Timothy Sample 2018-10-01gnu: ghc-tasty-expected-failure: Update to 0.11.1.1....Timothy Sample 2018-10-01gnu: ghc-tasty: Update to 1.1.0.3....Timothy Sample 2018-10-01gnu: ghc-test-framework-quickcheck2: Update Cabal file to r1....Timothy Sample 2018-10-01gnu: ghc-test-framework-hunit: Update Cabal file to r3....Timothy Sample 2018-10-01gnu: ghc-test-framework: Update to 0.8.2.0....Timothy Sample 2018-10-01gnu: ghc-quickcheck: Update to 2.11.3....Timothy Sample 2018-10-01gnu: ghc-mtl: Remove built-in Haskell package....Timothy Sample 2018-09-05Revert "gnu: ghc-tasty: Update to 1.1.0.3."...Ricardo Wurmus 2018-09-04gnu: ghc-tasty-ant-xml: Update to 1.1.4....Arun Isaac 2018-09-04gnu: ghc-tasty: Update to 1.1.0.3....Arun Isaac 2018-08-23gnu: ghc-quickcheck-instances: Update to 0.3.18....Arun Isaac 2018-08-16gnu: ghc-test-framework-hunit: Fix build with new HUnit....Ricardo Wurmus 2018-08-16gnu: ghc-hunit: Update to 1.6.0.0....Ricardo Wurmus 2018-08-16gnu: ghc-hspec: Update to 2.5.5....Ricardo Wurmus 2018-08-16gnu: ghc-hspec-expectations: Update to 0.8.2....Ricardo Wurmus 2018-08-16gnu: ghc-hspec-contrib: Update to 0.5.0....Ricardo Wurmus 2018-08-16gnu: ghc-hspec-meta: Update to 2.4.6....Ricardo Wurmus 2018-08-16gnu: ghc-hspec-core: Update to 2.5.5....Ricardo Wurmus 2018-08-16gnu: hspec-discover: Update to 2.5.5....Ricardo Wurmus