aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2021 Ryan Sundberg <ryan@arctype.co>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages jemalloc)
  #:use-module (srfi srfi-1)
  #:use-module (srfi srfi-26)
  #:use-module (ice-9 match)
  #:use-module ((guix licenses) #:select (bsd-2))
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages perl)
  #:use-module (guix build-system gnu))

(define-public jemalloc
  (package
    (name "jemalloc")
    (version "5.3.0")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/jemalloc/jemalloc/releases/download/"
                    version "/jemalloc-" version ".tar.bz2"))
              (sha256
               (base32
                "1apyxjd1ixy4g8xkr61p0ny8jiz8vyv1j0k4nxqkxpqrf4g2vf1d"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'delete-thp-test
            ;; This test does not check if transparent huge pages are supported
            ;; on the system before running the test.
            (lambda _
              (substitute* "Makefile.in"
                (("\\$\\(srcroot\\)test/unit/pages.c \\\\") "\\")))))
      #:configure-flags
      ;; Disable the thread local storage model in jemalloc 5 to prevent
      ;; shared libraries linked to libjemalloc from crashing on dlopen()
      ;; https://github.com/jemalloc/jemalloc/issues/937
      #~'("--disable-initial-exec-tls"
          #$@(match (%current-system)
               ("aarch64-linux"
                (list "--with-lg-page=14"))
               ("powerpc-linux"
                (list "CPPFLAGS=-maltivec"))
               (_
                '())))))
    (inputs (list perl))
    ;; Install the scripts to a separate output to avoid referencing Perl and
    ;; Bash in the default output, saving ~75 MiB on the closure.
    (outputs '("out" "bin"))
    (home-page "https://jemalloc.net/")
    (synopsis "General-purpose scalable concurrent malloc implementation")
    (description
     "This library providing a malloc(3) implementation that emphasizes
fragmentation avoidance and scalable concurrency support.")
    (license bsd-2)))
ges/algebra.scm (xtensor)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2019-09-28gnu: xtensor: Update to 0.20.9....* gnu/packages/algebra.scm (xtensor): Update to 0.20.9. Tobias Geerinckx-Rice 2019-09-10gnu: eclib: Update to 20190909....* gnu/packages/algebra.scm (eclib): Update to 20190909. Tobias Geerinckx-Rice 2019-08-06Merge remote-tracking branch 'origin/master' into wip-texliveRicardo Wurmus 2019-08-02gnu: giac: Update to 1.5.0-63....* gnu/packages/algebra.scm (giac): Update to 1.5.0-63. Nicolas Goaziou 2019-07-24gnu: Replace uses of texlive-*-amsfonts....* gnu/packages/algebra.scm (pari-gp)[native-inputs]: Replace texlive-fonts-amsfonts and texlive-latex-amsfonts with texlive-amsfonts in texlive-union. * gnu/packages/docbook.scm (dblatex)[inputs]: Same. * gnu/packages/plotutils.scm (asymptote)[native-inputs]: Same. * gnu/packages/python-xyz.scm (python-numpy-documentation, python-matplotlib-documentation, python-ipython-documentation) [native-inputs]: Same. * gnu/packages/statistics.scm (r-with-tests)[native-inputs]: Same. * gnu/packages/tex.scm (teximpatient)[native-inputs]: Same. Ricardo Wurmus 2019-07-16gnu: gap: Update to 4.10.2....* gnu/packages/algebra.scm (gap): Update to 4.10.2. Tobias Geerinckx-Rice 2019-07-16gnu: pari-gp: Update to 2.11.2....* gnu/packages/algebra.scm (pari-gp): Update to 2.11.2. Tobias Geerinckx-Rice 2019-07-16gnu: gp2c: Update to 0.0.11pl2....* gnu/packages/algebra.scm (gp2c): Update to 0.0.11pl2. Tobias Geerinckx-Rice 2019-07-08gnu: cmh: Fix build....This follows up on commit 1de48e8f8afec23847458c533d2fae0d69d8942a. * gnu/packages/algebra.scm (fplll-4-cmh): New variable. (cmh)[inputs]: Use it. Tobias Geerinckx-Rice 2019-07-02gnu: giac: Update to 1.5.0-61....* gnu/packages/algebra.scm (giac): Update to 1.5.0-61. Nicolas Goaziou 2019-06-21gnu: Move ratpoints into "sagemath.scm"...* gnu/packages/algebra.scm (ratpoints): Move package from here... * gnu/packages/sagemath.scm (ratpoints): ... to here. Nicolas Goaziou 2019-06-21gnu: ratpoints: Generate position-independent code....* gnu/packages/algebra.scm (ratpoints): Add "CCFLAGS=-fPIC" to make flags. Andreas Enge 2019-06-21gnu: symmetrica: Generate position-independent code....* gnu/packages/algebra.scm (symmetrica): Add -fPIC compiler flag. Andreas Enge 2019-06-21gnu: iml: Enable shared library....* gnu/packages/algebra.scm (iml): Add configure flag --enable-shared. Andreas Enge 2019-06-21gnu: lrcalc: Add a patch for identifying include files....* gnu/packages/patches/lrcalc-includes.patch: New file. * gnu/packages/algebra.scm (lrcalc): Use patch. * gnu/local.mk (dist_patch_DATA): Register patch. Andreas Enge 2019-06-20gnu: Add iml....* gnu/packages/algebra.scm (iml): New variable. Andreas Enge 2019-06-20gnu: Add lrcalc....* gnu/packages/algebra.scm (lrcalc): New variable. Andreas Enge 2019-06-20gnu: Add eclib....* gnu/packages/algebra.scm (eclib): New variable. Andreas Enge 2019-06-20gnu: Add m4rie....* gnu/packages/algebra.scm (m4rie): New variable. Andreas Enge 2019-06-20gnu: Add python-fpylll....* gnu/packages/algebra.scm (python-fpylll): New variable. Nicolas Goaziou 2019-06-20gnu: fplll: Update to 5.2.1....* gnu/packages/algebra.scm (fplll): Update to 5.2.1. [source]: Use Github tagged release: the original tarball no longer exists. [native-inputs]: Add Autoconf and al. [homepage]: Update it, the previous one no longer exists. [description]: Expound description. Nicolas Goaziou 2019-06-20gnu: Add symmetrica....* gnu/packages/algebra.scm (symmetrica): New variable. * gnu/packages/patches/symmetrica-bruch.patch: * gnu/packages/patches/symmetrica-int32.patch: * gnu/packages/patches/symmetrica-return_values.patch: * gnu/packages/patches/symmetrica-sort_sum_rename.patch: New files. * gnu/local.mk (dist_patch_DATA): Add patches. Nicolas Goaziou 2019-06-20gnu: Move ratpoints into a different module....* gnu/packages/maths.scm (ratpoints): Move... * gnu/packages/algebra.scm: ...here. Nicolas Goaziou 2019-06-19gnu: Add m4ri....* gnu/packages/algebra.scm (m4ri): New variable. Andreas Enge 2019-06-19gnu: Add gf2x....* gnu/packages/algebra.scm (gf2x): New variable. Andreas Enge 2019-06-18gnu: Add linbox....* gnu/packages/algebra.scm (linbox): New variable. Andreas Enge 2019-06-18gnu: Add fflas-ffpack....* gnu/packages/algebra.scm (fflas-ffpack): New variable. Andreas Enge 2019-06-18gnu: Add givaro....* gnu/packages/algebra.scm (givaro): New variable. Andreas Enge 2019-06-17gnu: gap: Update to 4.10.1....* gnu/packages/algebra.scm (gap): Update to 4.10.1. Install headers and library files by hand, since the make targets have disappeared. Delete the special check phase, since the "make check" target has appeared. Remove a package that is no longer recommended, and enable two recommended packages with clarified licenses. Andreas Enge 2019-06-02gnu: giac: Update to 1.5.0-57....* gnu/packages/algebra.scm (giac): Update to 1.5.0-57. Nicolas Goaziou 2019-05-11gnu: xtensor: Update to 0.20.5....* gnu/packages/algebra.scm (xtensor): Update to 0.20.5. Tobias Geerinckx-Rice 2019-04-28gnu: Fix missing bison package in (gnu packages algebra)....This fixes a regression introduced in 6d3896b9fc115b03046860a9aa12966926bccf53. * gnu/packages/algebra.scm: Use the (gnu packages bison) module. Christopher Baines 2019-04-28gnu: Fix typo....* gnu/packages/algebra.scm (giac-xcas): Fix typo. Nicolas Goaziou 2019-04-28gnu: giac-xcas: Rename to "giac" to match upstream name....* gnu/packages/algebra.scm (giac): New variable. (giac-xcas): Deprecate. Nicolas Goaziou 2019-04-28gnu: giac-xcas: Add inputs....* gnu/packages/algebra.scm (giac-xcas)[inputs]: Add glpk, libsamplerate, bison and flex. Nicolas Goaziou 2019-04-28gnu: giac-xcas: Fix documentation....* gnu/packages/algebra.scm (giac-xcas): Use a single output. Fix licensing issues in documentation. Xcas expects documentation to be located at a fixed location, not compatible with a "doc" output. Nicolas Goaziou 2019-04-16gnu: singular: Update to 4.1.2p1....* gnu/packages/algebra.scm (singular): Update to 4.1.2p1. Tobias Geerinckx-Rice 2019-04-08gnu: Add eigen-for-tensorflow....* gnu/packages/algebra.scm (eigen-for-tensorflow): New variable. Ricardo Wurmus 2019-04-04gnu: giac-xcas: Update to 1.5.0-49....* gnu/packages/algebra.scm (giac-xcas): Update to 1.5.0-49. Nicolas Goaziou