aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2021 Ryan Sundberg <ryan@arctype.co>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages jemalloc)
  #:use-module (srfi srfi-1)
  #:use-module (srfi srfi-26)
  #:use-module (ice-9 match)
  #:use-module ((guix licenses) #:select (bsd-2))
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages perl)
  #:use-module (guix build-system gnu))

(define-public jemalloc
  (package
    (name "jemalloc")
    (version "5.3.0")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/jemalloc/jemalloc/releases/download/"
                    version "/jemalloc-" version ".tar.bz2"))
              (sha256
               (base32
                "1apyxjd1ixy4g8xkr61p0ny8jiz8vyv1j0k4nxqkxpqrf4g2vf1d"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'delete-thp-test
            ;; This test does not check if transparent huge pages are supported
            ;; on the system before running the test.
            (lambda _
              (substitute* "Makefile.in"
                (("\\$\\(srcroot\\)test/unit/pages.c \\\\") "\\")))))
      #:configure-flags
      ;; Disable the thread local storage model in jemalloc 5 to prevent
      ;; shared libraries linked to libjemalloc from crashing on dlopen()
      ;; https://github.com/jemalloc/jemalloc/issues/937
      #~'("--disable-initial-exec-tls"
          #$@(match (%current-system)
               ("aarch64-linux"
                (list "--with-lg-page=14"))
               ("powerpc-linux"
                (list "CPPFLAGS=-maltivec"))
               (_
                '())))))
    (inputs (list perl))
    ;; Install the scripts to a separate output to avoid referencing Perl and
    ;; Bash in the default output, saving ~75 MiB on the closure.
    (outputs '("out" "bin"))
    (home-page "https://jemalloc.net/")
    (synopsis "General-purpose scalable concurrent malloc implementation")
    (description
     "This library providing a malloc(3) implementation that emphasizes
fragmentation avoidance and scalable concurrency support.")
    (license bsd-2)))
d: Iba50d2f832a42876fc4e4418593c3c2feacdb3f8 Efraim Flashner 2024-01-26gnu: Add d-demangler....* gnu/packages/dlang.scm (d-demangler): New variable. Change-Id: Ic1dc8fb8adc1b4be859552e4add074a35bdfc6d0 Maxim Cournoyer 2024-01-26gnu: Add dmd....* gnu/packages/dlang.scm (dmd-bootstrap, dmd): New variables. Change-Id: I53e00a429e2084a392341ef1bc7ea63f0fcaaab4 Maxim Cournoyer 2024-01-26gnu: gdmd: Replace gdc-11 with gdc alias....* gnu/packages/dlang.scm (gdmd) [inputs]: Replace gdc-11 with gdc. Change-Id: Ie035bb79c128c266cee85cf11bf79216f4f8b454 Maxim Cournoyer 2024-01-25gnu: ldc: Build with llvm-15....* gnu/packages/dlang.scm (ldc-bootstrap)[native-inputs]: Replace llvm-14 with llvm-15, lld-wrapper-14 with lld-wrapper-15. (ldc)[native-inputs]: Replace clang-14 with clang-15. Change-Id: Iaa2023c7fb8a515c50a141d0157d9023cfb5c623 Efraim Flashner 2023-12-07gnu: dub: update to 1.33.0....* gnu/packages/dlang.scm (dub): Update to 1.33.0. Change-Id: Ie09f43329fa4a8d79f201f4b617e498d39adec6f Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Hugo Nobrega 2023-12-02gnu: ldc: Update to 1.35.0....* gnu/packages/dlang.scm (ldc-bootstrap): Update to 1.35.0. [arguments]: Adjust configure-flags to not build shared libraries. (ldc)[arguments]: Adjust configure-flags to remove defaults. Adjust 'patch-paths-in-tests phase for another hardcoded /bin/bash. Delete another test. Change-Id: Ie284a97ecda2689e6ed84a902eff990cfae8c195 Efraim Flashner 2023-12-02gnu: ldc: Enable building on more architectures....* gnu/packages/dlang.scm (ldc)[arguments]: In the custom phase 'fix-compiler-rt-library-discovery rewrite gnu-triplet->clang-arch to pass-through unmatched architectures. Efraim Flashner 2023-12-02gnu: d-tools: Update to 2.105.3....The previous version 2.100 was failing in `check` due to changes to the Phobos stdlib * gnu/packages/dlang.scm (d-tools): Update to 2.105.3. Change-Id: Id9e4580d555c735fb0eebe880928ef2f558f959e Signed-off-by: Ludovic Courtès <ludo@gnu.org> Hugo Nobrega