aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018, 2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020, 2021, 2022, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Boris A. Dekshteyn <boris.dekshteyn@gmail.com>
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages inkscape)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (guix build-system cmake)
  #:use-module (gnu packages)
  #:use-module (gnu packages algebra)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages bdw-gc)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages check)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages graphics)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages imagemagick)
  #:use-module (gnu packages libreoffice)
  #:use-module (gnu packages maths)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pdf)
  #:use-module (gnu packages popt)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-web)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages ghostscript)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages image)
  #:use-module (gnu packages pkg-config)
  #:use-module (srfi srfi-1))

;;; A variant of Inkscape intended to be bumped only on core-updates, to avoid
;;; rebuilding 2k+ packages through dblatex.  It should only be used as a
;;; native-input since it might not receive timely security updates.
(define-public inkscape/stable
  (hidden-package
   (package
     (name "inkscape")
     (version "1.3.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://media.inkscape.org/dl/"
                            "resources/file/"
                            "inkscape-" version ".tar.xz"))
        (sha256
         (base32 "0sq81smxwypgnp7r3wgza8w25dsz9qa8ga79sc85xzj3qi6q9lfv"))
        (modules '((guix build utils)
                   (ice-9 format)))
        (snippet
         '(begin
            (let-syntax
                ;; XXX: The build system doesn't currently support using
                ;; system libraries over bundled ones (see:
                ;; https://gitlab.com/inkscape/inkscape/issues/876).
                ((unbundle
                  (syntax-rules ()
                    ((_ (name source-dir use-pkg-config?) ...)
                     (begin
                       ;; Delete bundled source directories.
                       (delete-file-recursively source-dir) ...
                       (substitute* '("src/CMakeLists.txt"
                                      "src/3rdparty/CMakeLists.txt")
                         (((string-append ".*add_subdirectory\\("
                                          (basename source-dir) "\\).*"))
                          "") ...)
                       ;; Remove bundled entries from INKSCAPE_TARGET_LIBS.
                       (substitute* "src/CMakeLists.txt"
                         (((string-append name "_LIB.*")) "") ...)
                       ;; Register the external libraries, so that their
                       ;; headers are added to INKSCAPE_INCS_SYS and their
                       ;; shared libraries added to INKSCAPE_LIBS.
                       (if use-pkg-config?
                           (let* ((width (string-length "pkg_check_modules("))
                                  (indent (string-join (make-list width " ") "")))
                             (substitute* "CMakeScripts/DefineDependsandFlags.cmake"
                               (("^pkg_check_modules\\(INKSCAPE_DEP REQUIRED.*" start)
                                (string-append start
                                               (format #f "~a~a~%" indent name)))))
                           (substitute* "CMakeScripts/DefineDependsandFlags.cmake"
                             (("^find_package\\(Iconv REQUIRED\\).*" start)
                              (string-append (format #f "
find_path(~a_INCLUDE_DIR NAMES ~:*~a/~:*~a.h ~:*~a.h)
if(NOT ~:*~a_INCLUDE_DIR)
  message(FATAL_ERROR \"~:*~a headers not found\")
else()
  list(APPEND INKSCAPE_INCS_SYS ${~:*~a_INCLUDE_DIR})
endif()

find_library(~:*~a_LIB NAMES ~:*~a)
if(NOT ~:*~a_LIB)
  message(FATAL_ERROR \"~:*~a library not found\")
else()
  list(APPEND INKSCAPE_LIBS ~:*~a_LIB)
endif()~%~%"
                                                     name)
                                             start)))) ...
                                             ;; Fix the references to the headers of the
                                             ;; unbundled libraries.
                                             (substitute* (find-files "." "\\.h$|\\.cpp$")
                                               (((string-append "#include (\"|<)3rdparty/"
                                                                (basename source-dir)) _ quote)
                                                (string-append "#include " quote
                                                               (basename source-dir)))
                                               ...))))))
              (unbundle ("2geom" "src/3rdparty/2geom" #t)
                        ;; libcroco cannot be unbundled as it is heavily
                        ;; modified (see:
                        ;; https://gitlab.com/inkscape/inkscape/issues/876#note_276114904).
                        ;; ("croco" "src/3rdparty/libcroco" #t)
                        ;; FIXME: Unbundle the following libraries once they
                        ;; have been packaged.
                        ;; ("cola" "src/3rdparty/adaptagrams/libcola")
                        ;; ("avoid" "src/3rdparty/adaptagrams/libavoid")
                        ;; ("vpsc" "src/3rdparty/adaptagrams/libvpsc")
                        ;; libuemf cannot be unbundled as it slightly modified
                        ;; from upstream (see:
                        ;; https://gitlab.com/inkscape/inkscape/issues/973).
                        ;; ("uemf" "src/3rdparty/libuemf" #f)
                        ;; FIXME: libdepixelize upstream is ancient and doesn't
                        ;; build with a recent lib2geom
                        ;; (see: https://bugs.launchpad.net/libdepixelize/+bug/1862458).
                        ;;("depixelize" "src/3rdparty/libdepixelize")
                        ("autotrace" "src/3rdparty/autotrace" #t)))
            ;; Lift the requirement on the double-conversion library, as
            ;; it is only needed by lib2geom, which is now unbundled.
            (substitute* "CMakeScripts/DefineDependsandFlags.cmake"
              ((".*find_package\\(DoubleConversion.*") ""))))))
     (build-system cmake-build-system)
     (arguments
      (list
       #:test-target "check"         ;otherwise some test binaries are missing
       #:disallowed-references (list imagemagick/stable)
       #:imported-modules `(,@%cmake-build-system-modules
                            (guix build glib-or-gtk-build-system))
       #:modules '((guix build cmake-build-system)
                   ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
                   (guix build utils))
       ;; Disable imagemagick support in the stable variant, to reduce the
       ;; number of dependents of the 'imagemagick' package.
       #:configure-flags
       #~(list "-DWITH_IMAGE_MAGICK=OFF"
               ;; TODO: Remove after next release, since the problematic
               ;; libsoup/soup.h include is no longer used.
               (string-append "-DCMAKE_CXX_FLAGS=-I"
                              (search-input-directory %build-inputs
                                                      "/include/libsoup-2.4")))
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
             (assoc-ref glib-or-gtk:%standard-phases
                        'generate-gdk-pixbuf-loaders-cache-file))
           #$@(if (or (target-aarch64?)
                      (target-ppc64le?)
                      (target-riscv64?))
                  '((add-after 'unpack 'disable-more-tests
                      (lambda _
                        ;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035680690
                        (substitute* "testfiles/CMakeLists.txt"
                          (("lpe64-test") "#lpe64-test")
                          (("    lpe-test") "    #lpe-test")
                          (("add_subdirectory\\(lpe_tests\\)") ""))
                        ;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035539888
                        ;; According to upstream, this is a false positive.
                        (substitute* "testfiles/rendering_tests/CMakeLists.txt"
                          (("add_rendering_test\\(test-use" all)
                           (string-append "#" all)))
                        ;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035539888
                        ;; Allegedly a precision error in the gamma.
                        (substitute* "testfiles/cli_tests/CMakeLists.txt"
                          (("add_cli_test\\(export-png-color-mode-gray-8_png" all)
                           (string-append "#" all))
                          ;; These also seem to be failing due to precision errors.
                          (("add_pdfinput_test\\(font-(spacing|style) 1 draw-all" all)
                           (string-append "#" all))))))
                  '())
           #$@(if (or (target-x86-32?)
                      (target-arm32?))
                  '((add-after 'unpack 'fix-32bit-size_t-format
                      (lambda _
                        ;; Fix an error due to format type mismatch with 32-bit size_t.
                        (substitute* "testfiles/src/visual-bounds-test.cpp"
                          (("%lu") "%u")))))
                  '())
           (add-after 'unpack 'set-home
             ;; Mute Inkscape warnings during tests.
             (lambda _
               (setenv "HOME" (getcwd))))
           ;; Move the check phase after the install phase, as when run in the
           ;; tests, Inkscape relies on files that are not yet installed, such
           ;; as the "share/inkscape/ui/units.xml" file.
           (delete 'check)
           (add-after 'install 'check
             ;; Use ctest directly so that we can easily exclude problematic
             ;; tests.
             (lambda* (#:key parallel-tests? tests? #:allow-other-keys)
               (when tests?
                 ;; The following tests fails, perhaps due to building without
                 ;; ImageMagick (see:
                 ;; https://gitlab.com/inkscape/inbox/-/issues/10005).
                 (let ((job-count (if parallel-tests?
                                      (number->string (parallel-job-count))
                                      "1"))
                       (skipped-tests
                        (list "cli_export-type-caseinsensitive_check_output"
                              "cli_export-type_xaml_check_output"
                              "cli_export-height_export-use-hints_check_output"
                              "cli_export-plain-svg_check_output"
                              "cli_export-use-hints_export-id_check_output"
                              "cli_export-extension_svg_check_output"
                              "cli_export-extension_ps_check_output"
                              "cli_export-extension_eps_check_output"
                              "cli_export-extension_pdf_check_output"
                              "cli_export-plain-extension-svg_check_output"
                              ;; These fail non-deterministically (see:
                              ;; https://gitlab.com/inkscape/inbox/-/issues/10005).
                              "cli_export-ps-level_3_check_output"
                              "cli_export-ps-level_3_content_check_output"
                              "cli_export-ps-level_2_content_check_output"
                              "cli_export-ps-level_2_check_output"
                          ;; These fail on i686 but not x86-64
                          #$@(if (target-x86-32?)
                                 '("cli_pdfinput-font-spacing_check_output"
                                   "cli_pdfinput-font-style_check_output"
                                   "cli_pdfinput-latex_check_output"
                                   "cli_pdfinput-multi-page-sample_check_output"
                                   "test_lpe")
                                 '()))))
                   (invoke "make" "-j" job-count "tests")
                   (invoke "ctest" "-j" job-count
                           "--output-on-error"
                           "-E" (string-append
                                 "(" (string-join skipped-tests "|") ")"))))))
           (add-after 'install 'glib-or-gtk-compile-schemas
             (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
           (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
             (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
           (add-after 'install 'wrap-program
             ;; Ensure Python is available at runtime.
             (lambda* (#:key inputs #:allow-other-keys)
               (wrap-program (string-append #$output "/bin/inkscape")
                 `("PATH" prefix
                   (,(dirname (search-input-file inputs "bin/python"))))
                 `("GUIX_PYTHONPATH" prefix
                   (,(getenv "GUIX_PYTHONPATH")))
                 ;; Wrapping GDK_PIXBUF_MODULE_FILE allows Inkscape to load
                 ;; its own icons in pure environments.
                 `("GDK_PIXBUF_MODULE_FILE" =
                   (,(getenv "GDK_PIXBUF_MODULE_FILE")))
                 ;; Ensure GObject Introspection typelibs are found.
                 `("GI_TYPELIB_PATH" ":" prefix
                   (,(getenv "GI_TYPELIB_PATH")))))))))
     (inputs
      (list (librsvg-for-system)        ;for the pixbuf loader
            autotrace
            bash-minimal
            boost
            freetype
            gdl-minimal
            gsl
            gspell
            gtk+
            gtkmm-3
            lcms
            lib2geom
            libcdr
            libgc
            libjpeg-turbo
            libpng
            libsoup-minimal-2
            libvisio
            libwpd
            libwpg
            libxml2
            libxslt
            poppler
            popt
            potrace
            ;; These Python dependencies are used by the Inkscape extension
            ;; management system.  To verify that it is working, visit the
            ;; Extensions -> Manage Extensions... menu.
            python-appdirs
            python-cssselect
            python-lxml
            python-numpy
            python-pygobject
            python-pyserial
            python-requests
            python-scour
            python-wrapper
            readline))
     (native-inputs
      (list `(,glib "bin")
            bc
            gettext-minimal
            googletest
            imagemagick/stable          ;for tests
            perl
            pkg-config))
     (home-page "https://inkscape.org/")
     (synopsis "Vector graphics editor")
     (description "Inkscape is a vector graphics editor.  What sets Inkscape
apart is its use of Scalable Vector Graphics (SVG), an XML-based W3C standard,
as the native format.")
     (license license:gpl3+))))           ;see the file COPYING

(define-public inkscape
  (package
    (inherit inkscape/stable)
    (name "inkscape")
    (version "1.3.2")
    (source
     (origin
       (inherit (package-source inkscape/stable))
       (method url-fetch)
       (uri (string-append "https://media.inkscape.org/dl/"
                           "resources/file/"
                           "inkscape-" version ".tar.xz"))
       (sha256
        (base32 "0sq81smxwypgnp7r3wgza8w25dsz9qa8ga79sc85xzj3qi6q9lfv"))))
    (build-system cmake-build-system)
    (arguments
     (substitute-keyword-arguments (package-arguments inkscape/stable)
       ((#:configure-flags flags ''())
        ;; Enable ImageMagick support.
        #~(delete "-DWITH_IMAGE_MAGICK=OFF" #$flags))
       ((#:phases phases)
        #~(modify-phases #$phases
            #$@(if (target-x86-32?)
                   #~()            ;XXX: there are remaining failures on i686
                   #~((replace 'check
                        ;; Re-instate the tests disabled in inkscape/stable, now that
                        ;; their ImageMagick requirement is satisfied.
                        (assoc-ref %standard-phases 'check))))

            (replace 'wrap-program
              ;; Ensure Python is available at runtime.
              (lambda _
                (wrap-program (string-append #$output "/bin/inkscape")
                  `("GUIX_PYTHONPATH" prefix
                    (,(getenv "GUIX_PYTHONPATH")))
                  ;; Wrapping GDK_PIXBUF_MODULE_FILE allows Inkscape to load
                  ;; its own icons in pure environments.
                  `("GDK_PIXBUF_MODULE_FILE" =
                    (,(getenv "GDK_PIXBUF_MODULE_FILE"))))))))))
    (inputs (modify-inputs (package-inputs inkscape/stable)
              (append imagemagick)))    ;for libMagickCore and libMagickWand
    (native-inputs
     (modify-inputs (package-native-inputs inkscape/stable)
                    ;; Only use 1 imagemagick across the package build.
                    (replace "imagemagick" imagemagick)))
    (properties (alist-delete 'hidden? (package-properties inkscape/stable)))))
;; script to reference Python in its shebang, which is ;; unnecessary. (substitute* (string-append #$output "/libexec/gstreamer-1.0/" "gst-plugins-doc-cache-generator") (((which "python3")) "/usr/bin/env python3"))))))) (propagated-inputs ;; In gstreamer-1.0.pc: ;; Requires: glib-2.0, gobject-2.0 ;; Requires.private: gmodule-no-export-2.0 libunwind libdw (list elfutils ;libdw glib libunwind)) (native-inputs (list bash-completion bison flex gettext-minimal `(,glib "bin") gobject-introspection perl pkg-config python)) (inputs (list gmp libcap ;; For tests. gsl)) (native-search-paths (list (search-path-specification (variable "GST_PLUGIN_SYSTEM_PATH") (files '("lib/gstreamer-1.0"))))) (home-page "https://gstreamer.freedesktop.org/") (synopsis "Multimedia framework") (description "GStreamer is a library for constructing graphs of media-handling components. The applications it supports range from simple Ogg/Vorbis playback, audio/video streaming to complex audio mixing and video non-linear editing. Applications can take advantage of advances in codec and filter technology transparently. Developers can add new codecs and filters by writing a simple plugin with a clean, generic interface. This package provides the core library and elements.") (license license:lgpl2.0+))) (define-public gst-plugins-base (package (name "gst-plugins-base") (version "1.22.3") (source (origin (method url-fetch) (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/" name "-" version ".tar.xz")) (sha256 (base32 "1ww9xx6c4mwvgn9k56d1xfnd3i1jm4v8rfiy4f07686ll24n4n8w")))) (build-system meson-build-system) (propagated-inputs (list glib ;required by gstreamer-sdp-1.0.pc gstreamer ;required by gstreamer-plugins-base-1.0.pc libgudev ;required by gstreamer-gl-1.0.pc ;; wayland-client.h is referred to in ;; include/gstreamer-1.0/gst/gl/wayland/gstgldisplay_wayland.h wayland orc)) ;required by gstreamer-audio-1.0.pc (inputs ;; TODO: Add libvorbisidec (list alsa-lib cdparanoia graphene iso-codes/pinned libjpeg-turbo libogg libpng libtheora libvisual libvorbis libx11 libxext libxv mesa opus pango wayland-protocols zlib)) (native-inputs (list pkg-config `(,glib "bin") gobject-introspection python-wrapper gettext-minimal xorg-server-for-tests)) (arguments (list #:phases #~(modify-phases %standard-phases #$@%common-gstreamer-phases (add-after 'unpack 'disable-problematic-tests (lambda _ (substitute* "tests/check/meson.build" ;; This test causes nondeterministic failures (see: ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues/950). ((".*'elements/appsrc.c'.*") "")) ;; Some other tests fail on other architectures. #$@(cond ((target-x86-32?) #~((substitute* "tests/check/meson.build" ((".*'libs/libsabi\\.c'.*") "")))) ((target-arm32?) #~((substitute* "tests/check/meson.build" ((".*'orc_adder.*") "")))) ((target-riscv64?) #~((substitute* "tests/check/meson.build" ((".*'libs/gstglcolorconvert\\.c'.*") "") ((".*'libs/gstglcontext\\.c'.*") "") ((".*'libs/gstglmemory\\.c'.*") "") ((".*'libs/gstglupload\\.c'.*") "") ((".*'elements/glimagesink\\.c'.*") "") ((".*'pipelines/gl-launch-lines\\.c'.*") "") ((".*'elements/glstereo\\.c'.*") "") ((".*'elements/glmixer\\.c'.*") "")))) (else #~())))) (add-before 'configure 'patch (lambda _ (substitute* "tests/check/libs/pbutils.c" (("/bin/sh") (which "sh"))))) (add-before 'check 'pre-check (lambda _ ;; Tests require a running X server. (system "Xvfb :1 +extension GLX &") (setenv "DISPLAY" ":1") ;; Tests write to $HOME. (setenv "HOME" (getcwd)) ;; Tests look for $XDG_RUNTIME_DIR. (setenv "XDG_RUNTIME_DIR" (getcwd)) ;; For missing '/etc/machine-id'. (setenv "DBUS_FATAL_WARNINGS" "0")))))) (home-page "https://gstreamer.freedesktop.org/") (synopsis "Plugins for the GStreamer multimedia library") (description "This package provides an essential exemplary set of plug-ins for the GStreamer multimedia library.") (license license:lgpl2.0+))) (define-public gst-plugins-good (package (name "gst-plugins-good") (version "1.22.3") (source (origin (method url-fetch) (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/" name "-" version ".tar.xz")) (sha256 (base32 "0wq2f5q395vs7hnwjqpc2gysdvkgd4jmyfdszv9g9wrf795ib0dg")))) (build-system meson-build-system) (arguments (list #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas #:phases #~(modify-phases %standard-phases #$@%common-gstreamer-phases (add-after 'unpack 'absolutize-libsoup-library (lambda* (#:key inputs #:allow-other-keys) (define libsoup (search-input-file inputs "lib/libsoup-3.0.so")) (substitute* "ext/soup/gstsouploader.c" (("(#define LIBSOUP_3_SONAME ).+$" _ prefix) (string-append prefix "\"" libsoup "\"\n"))))) (add-after 'unpack 'skip-failing-tests (lambda _ (substitute* "tests/check/elements/flvmux.c" ;; This test randomly times out (see: ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/786). ((".*tcase_add_test.*test_video_caps_late.*") "")) (substitute* "tests/check/meson.build" ;; Reported as shaky upstream, see ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/785> (("\\[ 'elements/flvmux' \\]") "[ 'elements/flvmux', true ]")))) (add-before 'check 'pre-check (lambda _ ;; Tests require a running X server. (system "Xvfb :1 +extension GLX &") (setenv "DISPLAY" ":1") ;; Tests write to $HOME. (setenv "HOME" (getcwd)) ;; Tests look for $XDG_RUNTIME_DIR. (setenv "XDG_RUNTIME_DIR" (getcwd)) ;; For missing '/etc/machine-id'. (setenv "DBUS_FATAL_WARNINGS" "0")))))) (native-inputs (list gettext-minimal `(,glib "bin") gobject-introspection gsettings-desktop-schemas libxml2 perl pkg-config python-wrapper xorg-server-for-tests)) (inputs (list aalib bzip2 cairo flac (librsvg-for-system) glib glib-networking glu gtk+ jack-2 lame libavc1394 libcaca libdv libgudev libiec61883 libjpeg-turbo libpng libshout libsoup libvpx libx11 libxdamage libxfixes libxext libxshmfence mesa mpg123 orc pulseaudio speex taglib twolame v4l-utils wavpack zlib)) (propagated-inputs (list gstreamer gst-plugins-base)) (synopsis "GStreamer plugins and helper libraries") (description "GStreamer-Plugins-Good is a collection of plug-ins you'd want to have right next to you on the battlefield. Shooting sharp and making no mistakes, these plug-ins have it all: good looks, good code, and good licensing. Documented and dressed up in tests. If you're looking for a role model to base your own plug-in on, here it is.") (home-page "https://gstreamer.freedesktop.org/") (license license:lgpl2.0+))) (define-public gst-plugins-good-qt (package (inherit gst-plugins-good) (name "gst-plugins-good-qt") (inputs (modify-inputs (package-inputs gst-plugins-good) (prepend qtbase-5 qtdeclarative-5 qtwayland-5 qtx11extras))))) (define-public gst-plugins-bad (package (name "gst-plugins-bad") (version "1.22.3") (source (origin (method url-fetch) (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/" name "-" version ".tar.xz")) (sha256 (base32 "1n116sphawmlqyjp1b8sv07vz4rjk1zn07286w37y4l65pp8yyg1")) (modules '((guix build utils))) (snippet '(begin ;; Delete bundled copy of usrsctp. (delete-file-recursively "ext/sctp/usrsctp"))))) (build-system meson-build-system) (arguments (list #:configure-flags #~(list "-Dsctp-internal-usrsctp=disabled") #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas #:phases #~(modify-phases %standard-phases #$@%common-gstreamer-phases (add-after 'unpack 'adjust-tests (lambda* (#:key native-inputs inputs #:allow-other-keys) (let ((gst-plugins-good (assoc-ref (or native-inputs inputs) "gst-plugins-good"))) (substitute* "tests/check/meson.build" ;; Make gst-plugin-good available for tests, see ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1426 (("'GST_PLUGIN_SYSTEM_PATH_1_0', ''") (string-append "'GST_PLUGIN_SYSTEM_PATH_1_0', '" gst-plugins-good "/lib/gstreamer-1.0'")) ;; The 'elements_shm.test_shm_live' test sometimes times out ;; (see: ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/790). ((".*'elements/shm\\.c'.*") "") ;; The 'elements_curlhttpsrc' test sometimes times out. ((".*'elements/curlhttpsrc\\.c'.*") "") ;; Unexpected critical/warning, see ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/3000> ((".*'elements/netsim\\.c'.*") "") ;; TODO: Figure out why this test fails on riscv64-linux. #$@(if (target-riscv64?) `((("'elements/viewfinderbin\\.c'\\].*],") "'elements/viewfinderbin.c'], true, ],")) '()) ;; This test is flaky on at least some architectures. ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244 #$@(if (member (%current-system) '("aarch64-linux" "riscv64-linux")) `((("'elements/camerabin\\.c'\\].*],") "'elements/camerabin.c'], true, ],")) '()) ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1412 ((".*elements/dtls\\.c.*") "")) (substitute* "tests/check/elements/zxing.c" ;; zxing 1.2.0 seemingly changed the type representation of ;; the EAN_13 structure; disable it. ((".*\"EAN_13\".*") ""))))) (add-before 'check 'pre-check (lambda _ ;; Tests require a running X server. (system "Xvfb :1 +extension GLX &") (setenv "DISPLAY" ":1") ;; Tests write to $HOME. (setenv "HOME" (getcwd)) ;; Tests look for $XDG_RUNTIME_DIR. (setenv "XDG_RUNTIME_DIR" (getcwd)) ;; For missing '/etc/machine-id'. (setenv "DBUS_FATAL_WARNINGS" "0")))))) (propagated-inputs (list gstreamer gst-plugins-base)) (native-inputs (list gettext-minimal `(,glib "bin") ; for glib-mkenums, etc. gobject-introspection gsettings-desktop-schemas gst-plugins-good ;for tests perl pkg-config python-wrapper xorg-server-for-tests)) (inputs (append (if (target-x86?) (list mediasdk) '()) ;; Note: svt-hevc cannot be used, as it would break the package for ;; older x86_64 CPUs that lack AVX2, such as the Core 2 Duo (see: ;; https://github.com/OpenVisualCloud/SVT-HEVC/issues/573#issuecomment-680678144). (list bluez bzip2 cairo ;; ccextractor chromaprint curl directfb ;; dssim faad2 flite fluidsynth glib glib-networking glu gsm gtk+ iqa ladspa lcms libaom libass libbs2b libdc1394 libdca libde265 libdrm libdvdnav libdvdread libexif libfdk libgcrypt libgme libgudev libkate libmms libmodplug libmpcdec libnice libofa libopenmpt (librsvg-for-system) libsndfile libsrtp libssh2 libtiff libusb libva libvdpau libwebp libx11 libxcb libxext libxkbcommon libxml2 libxshmfence lilv lrdf lv2 mesa mjpegtools neon nettle openal ;; opencv openexr openh264 openjpeg ;; openni2 opensles openssl-1.1 opus orc pango rtmpdump sbc lksctp-tools soundtouch spandsp srt tinyalsa transcode usrsctp v4l-utils vo-aacenc vo-amrwbenc vulkan-headers vulkan-loader x265 wayland webrtc-audio-processing wildmidi wpebackend-fdo zbar zxing-cpp-1.2))) (home-page "https://gstreamer.freedesktop.org/") (synopsis "Plugins for the GStreamer multimedia library") (description "GStreamer Bad Plug-ins is a set of plug-ins whose quality aren't up to par compared to the rest.") (license license:lgpl2.0+))) (define-public gst-plugins-ugly (package (name "gst-plugins-ugly") (version "1.22.3") (source (origin (method url-fetch) (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/" name "-" version ".tar.xz")) (sha256 (base32 "0q53snvh7kr8g7qqxy4v5ska0d78kgc5bkp6qjrnhcr9qbaqxj9x")))) (build-system meson-build-system) (arguments (list #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas #:phases #~(modify-phases %standard-phases #$@%common-gstreamer-phases (add-before 'check 'pre-check (lambda _ ;; Tests require a running X server. (system "Xvfb :1 +extension GLX &") (setenv "DISPLAY" ":1") ;; Tests write to $HOME. (setenv "HOME" (getcwd)) ;; Tests look for $XDG_RUNTIME_DIR. (setenv "XDG_RUNTIME_DIR" (getcwd)) ;; For missing '/etc/machine-id'. (setenv "DBUS_FATAL_WARNINGS" "0")))))) (native-inputs (list gettext-minimal `(,glib "bin") gobject-introspection gsettings-desktop-schemas perl pkg-config python-wrapper xorg-server-for-tests)) (inputs (list glib glib-networking liba52 libcdio libdvdread libmpeg2 libx264 opencore-amr orc)) (propagated-inputs (list gstreamer gst-plugins-base)) (synopsis "GStreamer plugins and helper libraries") (description "Gst-Plugins-Ugly are the ones that might have a patent noose around their neck, or a lock-up license, or any other problem that makes you think twice about shipping them.") (home-page "https://gstreamer.freedesktop.org/") (license license:lgpl2.0+))) (define-public gst-libav (package (name "gst-libav") (version "1.22.3") (source (origin (method url-fetch) (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/" name "-" version ".tar.xz")) (sha256 (base32 "08x929yhjd2wpy05146fnqv6p2hw58ha079bwfkp2hwbh02wii9f")))) (build-system meson-build-system) (native-inputs (list perl pkg-config python-wrapper ruby)) (inputs (list ffmpeg)) (propagated-inputs (list gstreamer gst-plugins-base)) (synopsis "GStreamer plugins and helper libraries") (description "Gst-Libav contains a GStreamer plugin for using the encoders, decoders, muxers, and demuxers provided by FFmpeg.") (home-page "https://gstreamer.freedesktop.org/") (license license:lgpl2.0+))) (define-public gst-editing-services (package (name "gst-editing-services") (version "1.22.3") (source (origin (method url-fetch) (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/" "gst-editing-services-" version ".tar.xz")) (sha256 (base32 "18nfq3av5ksz17048l2b4r4zbh11yd0yq2asx0jy3c894pkbr98m")))) (build-system meson-build-system) (arguments (list #:tests? #f ; FIXME: 16/23 failing tests. #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas #:phases #~(modify-phases %standard-phases #$@%common-gstreamer-phases))) (propagated-inputs (list gstreamer gst-plugins-base)) (inputs (list glib glib-networking gtk+ libxml2)) (native-inputs (list flex gobject-introspection `(,glib "bin") gst-plugins-bad gst-plugins-good perl pkg-config python-wrapper)) (home-page "https://gstreamer.freedesktop.org/") (synopsis "GStreamer library for non-linear editors") (description "This is a high-level library for facilitating the creation of audio/video non-linear editors.") (license license:gpl2+))) (define-public gst-plugins/selection (lambda* (pkg #:key plugins configure-flags) "Build PKG with only PLUGINS enabled. Optionally, if CONFIGURE-FLAGS are given, also pass them to the build system instead of the ones used by PKG." (package/inherit pkg (arguments (substitute-keyword-arguments (package-arguments pkg) ((#:configure-flags flags #~'()) #~(append (list #$@(map (lambda (plugin) (string-append "-D" plugin "=enabled")) plugins)) #$(or configure-flags flags))) ((#:phases phases) #~(modify-phases #$phases (add-after 'unpack 'disable-auto-plugins (lambda _ (substitute* "meson_options.txt" (("'auto'") "'disabled'"))))))))))) (define-public gst-plugins-bad-minimal (package (inherit (gst-plugins/selection gst-plugins-bad #:plugins '())) (name "gst-plugins-bad-minimal") (description "This package provides the smallest selection of GStreamer's \"bad\" plugin set, essentially containing libraries and the gst-transcoder binary, but none of the actual plugins."))) (define-public python-gst (package (name "python-gst") (version "1.22.3") (source (origin (method url-fetch) (uri (string-append "https://gstreamer.freedesktop.org/src/gst-python/" "gst-python-" version ".tar.xz")) (sha256 (base32 "073kii36ncgsyq0b5njbsvprrg1k3kmydr3dxwiccjv3pvxd7gkh")))) (build-system meson-build-system) (arguments (list #:modules `((guix build meson-build-system) (guix build utils) ((guix build python-build-system) #:prefix python:)) #:imported-modules `(,@%meson-build-system-modules (guix build python-build-system)) #:configure-flags #~(list (string-append "-Dpygi-overrides-dir=" (python:site-packages %build-inputs %outputs) "/gi/overrides")))) (native-inputs (list pkg-config python)) (propagated-inputs (list gst-plugins-base python-pygobject-3.48)) (home-page "https://gstreamer.freedesktop.org/") (synopsis "GStreamer GObject Introspection overrides for Python") (description "This package contains GObject Introspection overrides for Python that can be used by Python applications using GStreamer.") (license license:lgpl2.1+) (properties `((upstream-name . "gst-python"))))) (define-public gst123 (package (name "gst123") (version "0.3.5") (source (origin (method url-fetch) (uri (string-append "http://space.twc.de/~stefan/gst123/gst123-" version ".tar.bz2")) (sha256 (base32 "0zaa117n4wkya9p903vkj8hj58lmdb66pxsdx5wwcv7nffbp5d67")))) (build-system gnu-build-system) (inputs (list gtk+-2 ncurses gstreamer gst-plugins-base)) (native-inputs (list pkg-config)) (home-page "https://space.twc.de/~stefan/gst123.php") (synopsis "Flexible command line media player based on gstreamer") (description "The program gst123 is designed to be a more flexible command line player in the spirit of ogg123 and mpg123, based on the gstreamer media framework. It plays all file formats gstreamer supports, so if you have a music collection which contains different file formats, like flac, ogg and mp3, you can use gst123 to play all your music files.") (license license:lgpl2.0+))) (define-public gst-plugins-espeak (let ((commit "7f6e41274fb833a487a7ee8ac0c236f0821330cc") (revision "1")) (package (name "gst-plugins-espeak") (version (git-version "0.5.0" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/sugarlabs/gst-plugins-espeak") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "0va4ghcdda8cbqzv376hgmv1ay79va4kyazibfj8m5n52bhxxqgz")))) (build-system gnu-build-system) (inputs (list espeak-ng gstreamer gst-plugins-base)) (native-inputs (list autoconf automake libtool pkg-config)) (home-page "http://wiki.sugarlabs.org/go/Activity_Team/gst-plugins-espeak") (synopsis "Use espeak") (description "This is a Gstreamer @code{src} plugin to use the espeak speech synthesizer as a sound source.") (license license:lgpl2.0+))))