aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages inklingreader)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages pkg-config))

(define-public inklingreader
  (package
    (name "inklingreader")
    (version "0.8")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "ftp://alpha.gnu.org/gnu/inklingreader/inklingreader-"
                    version ".tar.gz"))
              (sha256
               (base32
                "0ikg95mgwfqh0bq4dzvkfmdiycacqvv27g91hl6adwk5y3gzl96g"))))
    (build-system gnu-build-system)
    (inputs
     (list glib cairo gtk+ (librsvg-for-system) libusb))
    (native-inputs
     (list pkg-config))
    (home-page "https://www.gnu.org/software/inklingreader/")
    (synopsis "Wacom Inkling sketch format conversion and manipulation")
    (description
     "GNU InklingReader is a package to support the Wacom Inkling device,
including data conversion to various free formats, basic editing features,
and an Inkscape plugin.")
    (license license:gpl3+)))
28gnu: Add liquidctl....* gnu/packages/hardware.scm (liquidctl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jean-Pierre De Jesus DIAZ 2023-09-01gnu: Add usbrelay....* gnu/packages/hardware.scm (usbrelay): New variable. Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Evgeny Pisemsky 2023-07-29gnu: h-client: Update URL....* gnu/packages/hardware.scm (h-client) [source]: Add trailing '/' to URL. Maxim Cournoyer 2023-07-29gnu: h-client: Fix build....* gnu/packages/hardware.scm (h-client) [phases]: Replace sbin/lspci by bin/lspci in wrap-more phase. Maxim Cournoyer 2023-07-16gnu: hwinfo: Remove input labels....* gnu/packages/hardware.scm (hwinfo)[inputs]: Remove input labels. Tobias Geerinckx-Rice 2023-07-16gnu: hwinfo: Update to 23.2....* gnu/packages/hardware.scm (hwinfo): Update to 23.2. Tobias Geerinckx-Rice 2023-07-16gnu: hwinfo: Make with flags....* gnu/packages/hardware.scm (hwinfo)[arguments]: Move CC, LIBDIR, and VERSION from hacky substitutions to superior #:make-flags. Honour them in the 'build phase. Tobias Geerinckx-Rice 2023-07-16gnu: hwinfo: Factorise 'install-man-pages....* gnu/packages/hardware.scm (hwinfo)[arguments]: Get section numbers from the man page file names rather than hard-coding 2. Tobias Geerinckx-Rice 2023-07-16gnu: hwinfo: Use G-expressions....* gnu/packages/hardware.scm (hwinfo)[source, arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-07-16gnu: hwinfo: Update to 23.1....* gnu/packages/hardware.scm (hwinfo): Update to 23.1. Tobias Geerinckx-Rice 2023-07-16gnu: liblxi: Edit description....* gnu/packages/hardware.scm (liblxi)[synopsis]: Use @acronym{}. [description]: Likewise. Expand. Tobias Geerinckx-Rice 2023-07-16gnu: liblxi: Update to 1.20....* gnu/packages/hardware.scm (liblxi): Update to 1.20. Tobias Geerinckx-Rice 2023-07-16gnu: hw-probe: Fix build....* gnu/packages/hardware.scm (hw-probe)[arguments]: ‘lspci’ has moved to /bin. Tobias Geerinckx-Rice 2023-07-16gnu: ddcutil: Update to 1.4.2....* gnu/packages/hardware.scm (ddcutil): Update to 1.4.2. Tobias Geerinckx-Rice