aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages inklingreader)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages pkg-config))

(define-public inklingreader
  (package
    (name "inklingreader")
    (version "0.8")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "ftp://alpha.gnu.org/gnu/inklingreader/inklingreader-"
                    version ".tar.gz"))
              (sha256
               (base32
                "0ikg95mgwfqh0bq4dzvkfmdiycacqvv27g91hl6adwk5y3gzl96g"))))
    (build-system gnu-build-system)
    (inputs
     (list glib cairo gtk+ (librsvg-for-system) libusb))
    (native-inputs
     (list pkg-config))
    (home-page "https://www.gnu.org/software/inklingreader/")
    (synopsis "Wacom Inkling sketch format conversion and manipulation")
    (description
     "GNU InklingReader is a package to support the Wacom Inkling device,
including data conversion to various free formats, basic editing features,
and an Inkscape plugin.")
    (license license:gpl3+)))
200'>2020-05-16services: shepherd: Silence Guile warnings....Ludovic Courtès 2020-05-08Merge branch 'core-updates'Marius Bakke 2020-05-08services: Add descriptions....Ludovic Courtès 2020-04-25services: shepherd: Cross-compilation fix....Jan (janneke) Nieuwenhuizen 2020-04-21gnu: shepherd: Update to 0.8.0....Ludovic Courtès 2020-04-17services: Move 'user-processes' to (gnu services shepherd)....Ludovic Courtès 2020-04-15services: shepherd: Increase the PID file timeout to 30s....Ludovic Courtès 2020-03-29services: shepherd: Mark '.go' derivations as non-substitutable....Ludovic Courtès 2020-02-16services: shepherd: Spawn services with nothing but the PATH variable....Ludovic Courtès 2019-10-06services: shepherd: Compile service files....Ludovic Courtès 2019-04-23linux-container: Remove '%containerized-shepherd-service' hack....Ludovic Courtès 2019-04-23services: shepherd: Support one-shot services....Ludovic Courtès 2018-12-18file-systems: Spawn a REPL only when interaction is possible....Ludovic Courtès 2018-09-26services: shepherd: Add workaround for 0.5.0 in containers....Ludovic Courtès 2018-09-26guix system: Load all services on reconfigure, not just stopped ones....Carlo Zancanaro 2018-07-13services: shepherd: Support custom actions....Ludovic Courtès 2018-06-20services: boot: Take gexps instead of monadic gexps....Ludovic Courtès 2018-03-15services: 'shepherd-service-type' now accepts a default value....Ludovic Courtès 2018-01-21services: shepherd: Make 'shepherd-configuration-file' non-monadic....Ludovic Courtès 2017-05-03ui: Rename '_' to 'G_'....Ludovic Courtès 2017-02-08services: shepherd: Replace spaces with hyphens in file names....Clément Lassieur 2016-12-19services: Use 'file-append' in more places....Ludovic Courtès