aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages inklingreader)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages pkg-config))

(define-public inklingreader
  (package
    (name "inklingreader")
    (version "0.8")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "ftp://alpha.gnu.org/gnu/inklingreader/inklingreader-"
                    version ".tar.gz"))
              (sha256
               (base32
                "0ikg95mgwfqh0bq4dzvkfmdiycacqvv27g91hl6adwk5y3gzl96g"))))
    (build-system gnu-build-system)
    (inputs
     (list glib cairo gtk+ (librsvg-for-system) libusb))
    (native-inputs
     (list pkg-config))
    (home-page "https://www.gnu.org/software/inklingreader/")
    (synopsis "Wacom Inkling sketch format conversion and manipulation")
    (description
     "GNU InklingReader is a package to support the Wacom Inkling device,
including data conversion to various free formats, basic editing features,
and an Inkscape plugin.")
    (license license:gpl3+)))
gnu/packages/chromium.scm?id=4cf1acc7f3033b50b0bf19e02c9f522d522d338c'>Merge remote-tracking branch 'origin/master' into core-updates...Efraim Flashner 2023-01-26gnu: ungoogled-chromium: Update to 109.0.5414.119-1....Marius Bakke 2023-01-13gnu: ungoogled-chromium: Update to 109.0.5414.74-1....Marius Bakke 2023-01-08gnu: pipewire: Switch default to 0.3....Brendan Tildesley 2022-12-17gnu: ungoogled-chromium: Update to 108.0.5359.124-1....Marius Bakke 2022-12-12gnu: ungoogled-chromium: Build with ffmpeg@4....Marius Bakke 2022-12-08gnu: ungoogled-chromium: Remove obsolete workaround....Marius Bakke 2022-12-08gnu: ungoogled-chromium: Update to 108.0.5359.98-1....Marius Bakke 2022-12-03gnu: ungoogled-chromium: Update to 108.0.5359.94-1....Marius Bakke 2022-12-02gnu: ungoogled-chromium: Use git tag in ungoogled origin....Marius Bakke 2022-12-02gnu: ungoogled-chromium: Update to 108.0.5359.71-1....Marius Bakke 2022-12-02gnu: ungoogled-chromium: Generalize OpenJPEG substitution....Marius Bakke 2022-11-27gnu: ungoogled-chromium: Update to 107.0.5304.121-1....Marius Bakke 2022-11-17gnu: ungoogled-chromium: Build with Clang 15....Marius Bakke 2022-11-17gnu: ungoogled-chromium-wayland: Use PipeWire by default....Andrew Tropin 2022-11-11gnu: ungoogled-chromium: Update to 107.0.5304.110-1....Marius Bakke 2022-11-03gnu: ungoogled-chromium: Update to 107.0.5304.87-1....Marius Bakke 2022-10-27gnu: ungoogled-chromium: Update to 107.0.5304.68-1....Marius Bakke 2022-10-13gnu: ungoogled-chromium: Update to 106.0.5249.119-1....Marius Bakke 2022-10-12gnu: ungoogled-chromium: Update to 106.0.5249.103-1....Marius Bakke 2022-10-01gnu: ungoogled-chromium: Update to 106.0.5249.91-1....Marius Bakke 2022-09-28gnu: ungoogled-chromium: Update to 106.0.5249.61-1....Marius Bakke