aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages inklingreader)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages pkg-config))

(define-public inklingreader
  (package
    (name "inklingreader")
    (version "0.8")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "ftp://alpha.gnu.org/gnu/inklingreader/inklingreader-"
                    version ".tar.gz"))
              (sha256
               (base32
                "0ikg95mgwfqh0bq4dzvkfmdiycacqvv27g91hl6adwk5y3gzl96g"))))
    (build-system gnu-build-system)
    (inputs
     (list glib cairo gtk+ (librsvg-for-system) libusb))
    (native-inputs
     (list pkg-config))
    (home-page "https://www.gnu.org/software/inklingreader/")
    (synopsis "Wacom Inkling sketch format conversion and manipulation")
    (description
     "GNU InklingReader is a package to support the Wacom Inkling device,
including data conversion to various free formats, basic editing features,
and an Inkscape plugin.")
    (license license:gpl3+)))
.is@lostca.se> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I4011e97962b23bab10c516c7d4d2b25f92330f9d Paul A. Patience 2024-07-22gnu: vale: Update to 3.4.2....* gnu/packages/textutils.scm (vale): Update to 3.4.2. [source]: Change snippets removing vendored modules as they are not provided any more, to one adjusting module import path. [arguments]: <#:phases>: Add 'disable-failing-tests, 'copy-input-to-vendor-directory and 'remove-vendor-directory phases. Use custom 'check phase. [native-inputs]: Remove go-github-com-fatih-color, go-github-com-mitchellh-go-homedir, go-github-com-spf13-afero, go-github-com-urfave-cli, and go-gopkg-in-ini-v1; add go-github-com-masterminds-sprig-v3, go-github-com-adrg-strutil, go-github-com-adrg-xdg, go-github-com-bmatcuk-doublestar-v4, go-github-com-d5-tengo-v2, go-github-com-errata-ai-ini, go-github-com-errata-ai-regexp2, go-github-com-expr-lang-expr, go-github-com-jdkato-twine, go-github-com-karrick-godirwalk, go-github-com-mholt-archiver-v3, go-github-com-niklasfasching-go-org, go-github-com-otiai10-copy, go-github-com-pterm-pterm, go-github-com-remeh-sizedwaitgroup, go-github-com-spf13-pflag, go-golang-org-x-exp, and go-golang-org-x-sys. Change-Id: Ie378b419e34a924a5f1c8b383b029706d9846216 Sharlatan Hellseher 2024-07-15gnu: Remove go-github-com-errata-ai-vale....* gnu/packages/textutils.scm (go-github-com-errata-ai-vale): Delete variable. Change-Id: I457b50a280481792804e1a45703ac55b482e5029 Sharlatan Hellseher 2024-07-15gnu: Remove go-github-com-aswinkarthik-csvdiff....* gnu/packages/textutils.scm (go-github-com-aswinkarthik-csvdiff): Delete variable. Change-Id: I582399e8decbe82445b82d3e69dceeb743829ee4 Sharlatan Hellseher 2024-07-15gnu: packages/golang: Set default go version to 1.21....Golang versions 1.17 (02 Aug 2022), 1.18 (01 Feb 2023), 1.19 (06 Sep 2023) and 1.20 (06 Feb 2024) are EOL <https://endoflife.date/go>. These changes set preferable default version to the minimal currently maintained one e.g. 1.21 * gnu/packages/golang.scm (go): Set default to go-1.21, add annotation for the future maintenance. Remove field <#:go> setting Golang version to go-1.18, go-1.19, 1.20 and 1.21: * gnu/packages/admin.scm * gnu/packages/configuration-management.scm * gnu/packages/databases.scm * gnu/packages/disk.scm * gnu/packages/education.scm * gnu/packages/file-systems.scm * gnu/packages/finance.scm * gnu/packages/golang-check.scm * gnu/packages/golang-crypto.scm * gnu/packages/golang-web.scm * gnu/packages/golang-xyz.scm * gnu/packages/golang.scm * gnu/packages/high-availability.scm * gnu/packages/ipfs.scm * gnu/packages/irc.scm * gnu/packages/messaging.scm * gnu/packages/networking.scm * gnu/packages/syncthing.scm * gnu/packages/textutils.scm * gnu/packages/time.scm * gnu/packages/version-control.scm * gnu/packages/video.scm Change-Id: Ieba6a5d7a18423f838d14c02ad55a2ba9c8559eb Sharlatan Hellseher 2024-06-29gnu: Remove go-golang-org-x-net-html....golang.org/x/net is distributed as a single module according to provided go.mod file. This changes remove the last reference to golang.org/x/net/html. * gnu/packages/golang-build.scm (go-golang-org-x-net) [propagated-inputs]: Add go-golang-org-x-sys, go-golang-org-x-term and go-golang-org-x-text. (go-golang-org-x-net-html): Remove variable. * gnu/packages/version-control.scm (ghq) [inputs]: Remove go-golang-org-x-net-html. Add go-golang-org-x-net. * gnu/packages/textutils.scm (vale) [inputs]: Remove go-golang-org-x-net-html. Add go-golang-org-x-net. Change-Id: Ic275f2f7ccd145edfd376d65bd24599a550e849a Sharlatan Hellseher 2024-05-14gnu: utf8proc: fix cross-compilation....* gnu/packages/textutils.scm (utf8proc): fix cross-compilation. [arguments]<#:make-flags>: Use CC-FOR-TARGET. <#:phases>: When cross-compilation, Get test data from native-inputs. Change-Id: I42699e62f28585cc215a8843b5daad9c52af44c9 Zheng Junjie 2024-04-12gnu: go-github-com-gobwas-glob: Move to golang-xyz....* gnu/packages/syncthing.scm (go-github-com-gobwas-glob): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/textutils.scm: Remove (gnu packages syncthing) module. Change-Id: I131830e6edcdb666aeb3cd9bbdf6982df938ccd4 Sharlatan Hellseher 2024-04-09gnu: vale: Unbundle more packages....* gnu/packages/textutils.scm (vale): [source]: Remove more vendored modules. [native-inputs]: Add go-github-com-fatih-color, go-github-com-gobwas-glob, go-github-com-mitchellh-go-homedir, go-github-com-yuin-goldmark, go-golang-org-x-net-html, go-gopkg-in-ini-v1, and go-gopkg-in-yaml-v2. Change-Id: Ia7e87888fd286b54157382d01c8a3ca8475e3cb0 Sharlatan Hellseher 2024-04-09gnu: vale: Refresh package style....* gnu/packages/textutils.scm (vale): [source]: Remove some packaged module from vendor. [arguments]: Move above native-inputs. Swap to list style, do not install source. [description]: Fix indentation. Change-Id: I3efbffc74e76ba2c88467bfc7e79b06d4d05ee18 Sharlatan Hellseher 2024-04-09gnu: csvdiff: Adjust inputs....* gnu/packages/textutils.scm (csvdiff): Adjust inputs. [arguments]: Swap to list style, do not install sources. [native-inputs]: Swap from propagated-inputs to native-inputs. Remove indirect Golang modules: go-github-com-mattn-go-colorable, go-github-com-oneofone-xxhash, go-github-com-spaolacci-murmur3, and go-golang-org-x-sys. Change-Id: I903d8869b8c468c15a2e78a565bcaaf34594e34b Sharlatan Hellseher 2024-04-09gnu: Add miller....* gnu/packages/textutils.scm (miller): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ic381b5e28e561382c49f843aa1baadf2d2d6f294 Wilko Meyer 2024-04-06gnu: go-github-com-mattn-go-colorable: Move to golang-xyz....* gnu/packages/golang.scm (go-github-com-mattn-go-colorable): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/textutils.scm: Add (gnu packages golang-xyz) module. Change-Id: I7a9763ebd498e071b17abbde838a7cbf8fc891de Sharlatan Hellseher 2024-04-05gnu: Add java-autocomplete....* gnu/packages/textutils.scm (java-autocomplete): New variable. Change-Id: Ied62d45ab53fca84d448652cce5e82d971f41703 Ricardo Wurmus 2024-04-05gnu: java-rsyntaxtextarea: Update to 3.4.0....* gnu/packages/textutils.scm (java-rsyntaxtextarea): Update to 3.4.0. [arguments]: Disable tests; provide source-dir and test-dir; disable 'start-xorg-server phase. [native-inputs]: Remove java-junit. Change-Id: I5fbf635bc4f0a6a13ed2db4f42080ea5640f4781 Ricardo Wurmus 2024-04-01gnu: java-rsyntaxtextarea: Install resources....* gnu/packages/textutils.scm (java-rsyntaxtextarea)[arguments]: Enable tests; install resources. [native-inputs]: Add xorg-server-for-tests. Change-Id: If7c89bc6a38058b9cccd74012fa9b5ba14d560d6 Ricardo Wurmus