;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2015 Andreas Enge ;;; Copyright © 2015 Andy Wingo ;;; Copyright © 2015, 2016 Ricardo Wurmus ;;; Copyright © 2016 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see
aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages inklingreader)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages pkg-config))

(define-public inklingreader
  (package
    (name "inklingreader")
    (version "0.8")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "ftp://alpha.gnu.org/gnu/inklingreader/inklingreader-"
                    version ".tar.gz"))
              (sha256
               (base32
                "0ikg95mgwfqh0bq4dzvkfmdiycacqvv27g91hl6adwk5y3gzl96g"))))
    (build-system gnu-build-system)
    (inputs
     (list glib cairo gtk+ (librsvg-for-system) libusb))
    (native-inputs
     (list pkg-config))
    (home-page "https://www.gnu.org/software/inklingreader/")
    (synopsis "Wacom Inkling sketch format conversion and manipulation")
    (description
     "GNU InklingReader is a package to support the Wacom Inkling device,
including data conversion to various free formats, basic editing features,
and an Inkscape plugin.")
    (license license:gpl3+)))
"Python bindings to the libusb library") (description "PyUSB aims to be an easy to use Python module to access USB devices.") (license bsd-3))) (define-public python2-pyusb (package-with-python2 python-pyusb)) (define-public libmtp (package (name "libmtp") (version "1.1.11") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/libmtp/libmtp/" version "/libmtp-" version ".tar.gz")) (sha256 (base32 "1sc768q2cixwanlwrz95mp389iaadl4s95486caavxx4g7znvn8m")))) (build-system gnu-build-system) (native-inputs `(("pkg-config" ,pkg-config))) (propagated-inputs ;; libmtp.pc refers to all these. `(("libgcrypt" ,libgcrypt) ("libusb" ,libusb))) (arguments `(#:configure-flags (list (string-append "--with-udev=" (assoc-ref %outputs "out") "/lib/udev")))) (home-page "http://libmtp.sourceforge.net/") (synopsis "Library implementing the Media Transfer Protocol") (description "Libmtp implements an MTP (Media Transfer Protocol) initiator, which means that it initiates MTP sessions with devices. The devices responding are known as MTP responders. Libmtp runs on devices with a USB host controller interface. It implements MTP Basic, which was proposed for standardization.") ;; COPYING contains lgpl2.1, while files headers give ;; "GNU Lesser General Public License as published by the Free Software ;; Foundation; either version 2 of the License, or (at your option) any ;; later version." (license lgpl2.1+))) (define-public gmtp (package (name "gmtp") (version "1.3.10") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/gmtp/gMTP-" version "/gmtp-" version ".tar.gz")) (sha256 (base32 "0fyi3pdl2g57vr0p46ip2wwzyap3l0by7iqaqygv0yxfcs79l6xj")))) (build-system glib-or-gtk-build-system) (arguments '(#:configure-flags (let ((libid3tag (assoc-ref %build-inputs "libid3tag"))) (list ;; libid3tag provides no .pc file, so pkg-config fails to find them. (string-append "ID3TAG_CFLAGS=-I" libid3tag "/include") (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz"))))) (inputs `(("gtk+" ,gtk+) ("flac" ,flac) ("libvorbis" ,libvorbis) ("libid3tag" ,libid3tag) ("libmtp" ,libmtp))) (native-inputs `(("pkg-config" ,pkg-config))) (home-page "http://gmtp.sourceforge.net/") (synopsis "Simple graphical MTP client") (description "gMTP is a simple graphical client for the Media Transfer Protocol (MTP), which allows media files to be transferred to and from many portable devices.") (license bsd-3)))