aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages inklingreader)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages pkg-config))

(define-public inklingreader
  (package
    (name "inklingreader")
    (version "0.8")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "ftp://alpha.gnu.org/gnu/inklingreader/inklingreader-"
                    version ".tar.gz"))
              (sha256
               (base32
                "0ikg95mgwfqh0bq4dzvkfmdiycacqvv27g91hl6adwk5y3gzl96g"))))
    (build-system gnu-build-system)
    (inputs
     (list glib cairo gtk+ (librsvg-for-system) libusb))
    (native-inputs
     (list pkg-config))
    (home-page "https://www.gnu.org/software/inklingreader/")
    (synopsis "Wacom Inkling sketch format conversion and manipulation")
    (description
     "GNU InklingReader is a package to support the Wacom Inkling device,
including data conversion to various free formats, basic editing features,
and an Inkscape plugin.")
    (license license:gpl3+)))
861'>gnu: xfce4-datetime-plugin: Update to 0.8.2....* gnu/packages/xfce.scm (xfce4-datetime-plugin): Update to 0.8.2. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Michael Rohleder 2022-09-22gnu: xfce4-pulseaudio-plugin: Update to 0.4.5....* gnu/packages/xfce.scm (xfce4-pulseaudio-plugin): Update to 0.4.5. [arguments]: Remove unnecessary phase 'augment-cflags. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Michael Rohleder 2022-09-14gnu: mousepad: Fix build....* gnu/packages/xfce.scm (mousepad)[inputs]: Replace gtksourceview with gtksourceview-4.. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Michael Rohleder 2022-09-04gnu: xfce4-notifyd: Update to 0.6.4....* gnu/packages/xfce.scm (xfce4-notifyd): Update to 0.6.4. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Michael Rohleder 2022-08-22gnu: xfce4-equake-plugin: Update to 1.3.8.1....* gnu/packages/xfce.scm (xfce4-equake-plugin): Update to 1.3.8.1. 宋文武 2022-08-22gnu: xfce4-terminal: Update to 1.0.4....* gnu/packages/xfce.scm (xfce4-terminal): Update to 1.0.4. 宋文武 2022-08-22gnu: thunar: Update to 4.16.11....* gnu/packages/xfce.scm (thunar): Update to 4.16.11. 宋文武 2022-08-22gnu: elementary-xfce-icon-theme: Update to 0.17....* gnu/packages/xfce.scm (elementary-xfce-icon-theme): Update to 0.17. 宋文武 2022-08-22gnu: xfdesktop: Update to 4.16.1....* gnu/packages/xfce.scm (xfdesktop): Update to 4.16.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Michael Rohleder 2022-08-22gnu: xfce4-panel: Update to 4.16.5....* gnu/packages/xfce.scm (xfce4-panel): Update to 4.16.5. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Michael Rohleder 2022-08-14gnu: catfish: Update to 4.16.4....* gnu/packages/xfce.scm (catfish): Update to 4.16.4. Tobias Geerinckx-Rice 2022-08-15gnu: tumbler: Update to 4.16.1....* gnu/packages/xfce.scm (tumbler): Update to 4.16.1. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Michael Rohleder 2022-08-15gnu: xfce4-screenshooter: Update to 1.9.11....* gnu/packages/xfce.scm (xfce4-screenshooter): Update to 1.9.11. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Michael Rohleder 2022-08-10gnu: xfce: Replace 'gnome-icon-theme' with 'adwaita-icon-theme'....This fixes <https://issues.guix.gnu.org/57067>. * gnu/packages/xfce.scm (xfce)[inputs]: Replace gnome-icon-theme with adwaita-icon-theme. 宋文武 2022-08-05gnu: xfce: Replace 'gtk-xfce-engine' with 'greybird-gtk-theme'....Suggested in <https://issues.guix.gnu.org/54719>. * gnu/packages/xfce.scm (xfce)[inputs]: Replace 'gtk-xfce-engine' with 'greybird-gtk-theme'. 宋文武 2022-07-15gnu: xfce4-xkb-plugin: Update to 0.8.3....* gnu/packages/xfce.scm (xfce4-xkb-plugin): Update to 0.8.3. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Michael Rohleder 2022-07-15gnu: ristretto: Update to 0.12.3....* gnu/packages/xfce.scm (ristretto): Update to 0.12.3. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Michael Rohleder 2022-07-15gnu: exo: Update to 4.16.4....* gnu/packages/xfce.scm (exo): Update to 4.16.4. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Michael Rohleder 2022-07-15gnu: mousepad: Update to 0.5.10....* gnu/packages/xfce.scm (mousepad): Update to 0.5.10. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Michael Rohleder 2022-07-15gnu: xfce4-settings: Update to 4.16.3....* gnu/packages/xfce.scm (xfce4-settings): Update to 4.16.3. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Michael Rohleder 2022-07-15gnu: xfce4-wavelan-plugin: Update to 0.6.3....* gnu/packages/xfce.scm (xfce4-wavelan-plugin): Update to 0.6.3. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Michael Rohleder 2022-07-12gnu: inkscape: Rename variable to inkscape/stable and hide package....This will allow introducing a new 'inkscape' package that can be more freely upgraded on the main branch. * gnu/packages/inkscape.scm (inkscape): Rename to... (inkscape/stable): ... this, and make it a hidden package. * gnu/packages/admin.scm (wpa-supplicant-gui)[native-inputs]: Rename inkscape input accordingly. * gnu/packages/docbook.scm (dblatex): Likewise. * gnu/packages/gnome-xyz.scm (arc-theme): Likewise. * gnu/packages/python-xyz.scm (python-matplotlib-documentation): Likewise. (python-nbconvert): Likewise. * gnu/packages/xfce.scm (xfdesktop): Likewise. * gnu/packages/xorg.scm (hackneyed-x11-cursors): Likewise. Maxim Cournoyer