aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages inklingreader)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages pkg-config))

(define-public inklingreader
  (package
    (name "inklingreader")
    (version "0.8")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "ftp://alpha.gnu.org/gnu/inklingreader/inklingreader-"
                    version ".tar.gz"))
              (sha256
               (base32
                "0ikg95mgwfqh0bq4dzvkfmdiycacqvv27g91hl6adwk5y3gzl96g"))))
    (build-system gnu-build-system)
    (inputs
     (list glib cairo gtk+ (librsvg-for-system) libusb))
    (native-inputs
     (list pkg-config))
    (home-page "https://www.gnu.org/software/inklingreader/")
    (synopsis "Wacom Inkling sketch format conversion and manipulation")
    (description
     "GNU InklingReader is a package to support the Wacom Inkling device,
including data conversion to various free formats, basic editing features,
and an Inkscape plugin.")
    (license license:gpl3+)))
tle='2020-05-03 23:04:57 +0200'>2020-05-03file-systems: Fix UTF-16 handling in initrd....Danny Milosavljevic 2020-05-03file-systems: Fix F2FS volume name accessor....Danny Milosavljevic 2020-05-02Merge branch 'master' into core-updatesMarius Bakke 2020-05-02linux-boot: Allow the root file system to be mounted via NFS....Stefan 2020-05-02file-systems: Add support for F2FS....raingloom 2020-04-11vm: Make the device node procedure a parameter....Ludovic Courtès 2020-04-11linux-boot: Add 'make-hurd-device-nodes'....Ludovic Courtès 2020-04-11linux-boot: 'make-essential-device-nodes' root parameter is optional....Ludovic Courtès 2020-04-11vm: Preserve file permissions on /dev....Ludovic Courtès 2020-04-11vm: 'qemu-image' can pass options to the 'mkfs' command....Ludovic Courtès 2020-04-11vm: 'qemu-image' accepts a list of extra populate directives....Ludovic Courtès 2020-04-11install: 'populate-root-file-system' can be passed extra directives....Ludovic Courtès 2020-04-11Merge branch 'master' into core-updatesMarius Bakke 2020-04-10vm: Transparently compress iso9660 images....Tobias Geerinckx-Rice 2020-03-30Merge branch 'master' into core-updates...Marius Bakke 2020-03-27Merge branch 'master' into core-updates...Marius Bakke 2020-03-26vm: Distinguish between success and failure of the guest code....Ludovic Courtès 2020-03-22system: Add kernel-loadable-modules to operating-system....Danny Milosavljevic 2020-03-04Merge branch 'master' into core-updatesMarius Bakke 2020-03-02build: file-systems: Do not warn about file system check for NFS....Maxim Cournoyer 2020-03-02linux-boot: Ensure volatile root is mounted read-only....Maxim Cournoyer 2020-02-22marionette: Provide portable US-layout keystrokes for "<" and ">"....Ludovic Courtès 2020-02-22marionette: 'wait-for' procedures no longer leak a port....Ludovic Courtès