aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2015, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages idutils)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages emacs)
  #:use-module (gnu packages))

(define-public idutils
  (package
    (name "idutils")
    (version "4.6")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/idutils/idutils-"
                                 version ".tar.xz"))
             (sha256
              (base32
               "1hmai3422iaqnp34kkzxdnywl7n7pvlxp11vrw66ybxn9wxg90c1"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 (substitute* (find-files "lib" "\\.c$")
                   (("#if defined _IO_ftrylockfile")
                    "#if defined _IO_EOF_SEEN"))
                 (substitute* "lib/stdio-impl.h"
                   (("^/\\* BSD stdio derived implementations")
                    (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
                                   "# define _IO_IN_BACKUP 0x100\n"
                                   "#endif\n\n"
                                   "/* BSD stdio derived implementations")))

                 ;; 'gets' is deprecated in glibc 2.33 and its declaration is
                 ;; no longer visible by default from <stdio.h>.
                 (substitute* "lib/stdio.in.h"
                   (("_GL_WARN_ON_USE \\(gets.*") ""))))))
    (build-system gnu-build-system)
    (arguments
     ;; XXX: These Gnulib tests fail with GCC 10 and glibc 2.33; skip them.
     '(#:make-flags '("XFAIL_TESTS=test-sprintf-posix test-isnanl-nolibm")))
    (native-inputs `(("emacs" ,emacs-minimal)))
    (home-page "https://www.gnu.org/software/idutils/")
    (synopsis "Identifier database utilities")
    (description
     "The GNU idutils package includes tools to create an index of textual
tokens used in a list of file names and then to query that index.  Thus, it
allows the user to, for example, find all the uses of a particular function
in a large programming project.  In addition to handling textual tokens, it
can also handle numeric constants and the contents of character strings.")
    (license gpl3+)))
a8d25ef9d333c714a32e5e5ecfd'>gnu: bcachefs-tools: Use G-expressions....* gnu/packages/file-systems.scm (bcachefs-tools)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2021-12-20gnu: libeatmydata: Update to 130....* gnu/packages/file-systems.scm (libeatmydata): Update to 130. Tobias Geerinckx-Rice 2021-12-20gnu: libeatmydata: Fix Texinfo typo in description....* gnu/packages/file-systems.scm (libeatmydata)[description]: Remove stray ‘}’ and use @file{} over @code{}. Tobias Geerinckx-Rice 2021-12-20gnu: bcachefs-tools-static: Remove input labels....* gnu/packages/file-systems.scm (bcachefs-tools/static)[inputs]: Remove input labels. Tobias Geerinckx-Rice 2021-12-20gnu: bcachefs-tools-static: Fix build....* gnu/packages/crypto.scm (keyutils)[arguments]: Do build the static library, but move it to the :static output in a new 'install:static phase. * gnu/packages/file-systems.scm (bcachefs-tools/static)[inputs]: Add this keyutils:static. Tobias Geerinckx-Rice 2021-12-20gnu: bcachefs-tools: Update to 0.1-13.b19d9f9....* gnu/packages/file-systems.scm (bcachefs-tools): Update to 0.1-13.b19d9f9. Tobias Geerinckx-Rice 2021-12-20gnu: bcachefs-tools: Remove input labels....* gnu/packages/file-systems.scm (bcachefs-tools)[inputs]: Remove input labels. Tobias Geerinckx-Rice 2021-12-13gnu: Further simplify package inputs....This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.) Ludovic Courtès 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-12-10Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-12-08gnu: python-dropbox: Update to 11.25.0....* gnu/packages/file-systems.scm (python-dropbox): Update to 11.25.0. [propagated-inputs]: Remove python-certifi, python-chardet, and python-urllib3. Efraim Flashner 2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus 2021-11-27gnu: davfs2: Update to 1.6.1....* gnu/packages/file-systems.scm (davfs2): Update to 1.6.1. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2021-11-27gnu: exfatprogs: Update to 1.1.3....* gnu/packages/file-systems.scm (exfatprogs): Update to 1.1.3. Tobias Geerinckx-Rice 2021-11-08Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-11-07gnu: xfstests: Update to 1.1.0-1.bae1d15....* gnu/packages/file-systems.scm (xfstests): Update to 1.1.0-1.bae1d15. Tobias Geerinckx-Rice 2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-23gnu: bcachefs-tools-static: Fix build....This follows up on commit 196e3f52355ee7d086e67eb769d714dd040d61c2: bcachefs-tools now unconditionally builds and installs libbcachefs.so. * gnu/packages/file-systems.scm (bcachefs-tools-static)[arguments]: Add a new 'skip-shared-library phase. Tobias Geerinckx-Rice 2021-10-23gnu: bcachefs-tools: Update to 0.1-12.f9f5778....* gnu/packages/file-systems.scm (bcachefs-tools): Update to 0.1-12.f9f5778. Tobias Geerinckx-Rice 2021-10-21gnu: autofs: Update to 5.1.8....* gnu/packages/file-systems.scm (autofs): Update to 5.1.8. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2021-10-18Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-10-15gnu: dbxfs: Download using git-fetch....* gnu/packages/file-systems.scm (dbxfs)[source]: Download using git-fetch. Efraim Flashner 2021-10-14Merge branch 'master' into core-updates-frozenMarius Bakke 2021-10-12gnu: dbxfs: Update home-page....* gnu/packages/file-systems.scm (dbxfs)[home-page]: Update to new upstream homepage. Efraim Flashner 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-03gnu: bcachefs-tools: Update to 0.1-11.3785043....* gnu/packages/file-systems.scm (bcachefs-tools): Update to 0.1-11.3785043. Tobias Geerinckx-Rice 2021-10-02gnu: zfs: Update to 2.1.1....* gnu/packages/file-systems.scm (zfs): Update to 2.1.1. [arguments]: Do not return #t from custom phases. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net> Kaelyn Takata 2021-09-27gnu: bcachefs-tools: Update to 0.1-10.d214908....* gnu/packages/file-systems.scm (bcachefs-tools): Update to 0.1-10.d214908. Tobias Geerinckx-Rice 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-09-03gnu: bcachefs-tools: Update to 0.1-9.6c42566....* gnu/packages/file-systems.scm (bcachefs-tools): Update to 0.1-9.6c42566. [native-inputs]: Add python and python-docutils. Tobias Geerinckx-Rice 2021-08-12Merge branch 'master' into core-updates-frozen... Conflicts: gnu/packages/algebra.scm gnu/packages/games.scm gnu/packages/golang.scm gnu/packages/kerberos.scm gnu/packages/mail.scm gnu/packages/python.scm gnu/packages/ruby.scm gnu/packages/scheme.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm Marius Bakke 2021-08-02gnu: zfs: Update source URI....* gnu/packages/file-systems.scm (zfs)[source]: Update to new upstream URI. Efraim Flashner 2021-08-02gnu: zfs: Update 2.1.0....* gnu/packages/file-systems.scm (zfs): Update to 2.1.0. [arguments]: Adjust 'patch-source phase to add support for new compatibility feature. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> raid5atemyhomework via Bug reports for GNU Guix 2021-07-24gnu: Use 'search-input-file' when looking for executables....* gnu/packages/admin.scm (isc-dhcp): Use 'search-input-file' when looking for executables. * gnu/packages/audio.scm (ableton-link): Likewise. * gnu/packages/benchmark.scm (fio): Likewise. * gnu/packages/bioinformatics.scm (roary): Likewise. (ngless): Likewise. * gnu/packages/boost.scm (boost-for-irods): Likewise. * gnu/packages/bootloaders.scm (grub): Likewise. (grub-efi): Likewise. * gnu/packages/chemistry.scm (inchi): Likewise. * gnu/packages/dictionaries.scm (ding): Likewise. * gnu/packages/dlang.scm (ldc): Likewise. * gnu/packages/education.scm (childsplay): Likewise. * gnu/packages/emacs-xyz.scm (emacs-hyperbole): Likewise. (emacs-haskell-mode): Likewise. (emacs-auctex): Likewise. (emacs-ggtags): Likewise. (emacs-graphviz-dot-mode): Likewise. (emacs-flycheck-grammalecte): Likewise. (emacs-counsel-notmuch): Likewise. (emacspeak): Likewise. (emacs-exwm): Likewise. (emacs-exwm-x): Likewise. (emacs-treemacs): Likewise. (emacs-telega): Likewise. (emacs-exiftool): Likewise. * gnu/packages/emulators.scm (higan): Likewise. * gnu/packages/engineering.scm (freehdl): Likewise. (librepcb): Likewise. * gnu/packages/entr.scm (entr): Likewise. * gnu/packages/file-systems.scm (libeatmydata): Likewise. (xfstests): Likewise. (mergerfs): Likewise. (mergerfs-tools): Likewise. * gnu/packages/finance.scm (monero-gui): Likewise. * gnu/packages/flashing-tools.scm (flashrom): Likewise. * gnu/packages/fontutils.scm (fontforge): Likewise. * gnu/packages/game-development.scm (python2-renpy): Likewise. * gnu/packages/games.scm (opensurge): Likewise. (xboard): Likewise. (hyperrogue): Likewise. (flare-game): Likewise. (chessx): Likewise. * gnu/packages/geo.scm (grass): Likewise. * gnu/packages/glib.scm (glib): Likewise. * gnu/packages/gnome.scm (mm-common): Likewise. (network-manager-openvpn): Likewise. (network-manager-vpnc): Likewise. (network-manager-openconnect): Likewise. (apostrophe): Likewise. * gnu/packages/gnupg.scm (pius): Likewise. (jetring): Likewise. * gnu/packages/gnuzilla.scm (icedove): Likewise. * gnu/packages/golang.scm (go-1.4): Likewise. * gnu/packages/graphviz.scm (xdot): Likewise. * gnu/packages/guile-xyz.scm (jupyter-guile-kernel): Likewise. * gnu/packages/haskell-xyz.scm (ghc-hindent): Likewise. * gnu/packages/ibus.scm (ibus): Likewise. * gnu/packages/image.scm (phockup): Likewise. * gnu/packages/irc.scm (quassel): Likewise. * gnu/packages/java.scm (drip): Likewise. (ant-bootstrap): Likewise. (tla2tools): Likewise. * gnu/packages/julia.scm (julia): Likewise. * gnu/packages/less.scm (lesspipe): Likewise. * gnu/packages/libreoffice.scm (libreoffice): Likewise. * gnu/packages/linux.scm (fuse): Likewise. (lm-sensors): Likewise. (bluez): Likewise. (fakeroot): Likewise. (inputattach): Likewise. * gnu/packages/lisp-xyz.scm (sbcl-cl-diskspace): Likewise. * gnu/packages/lisp.scm (lisp-repl-core-dumper): Likewise. * gnu/packages/lua.scm (fennel): Likewise. * gnu/packages/lxde.scm (spacefm): Likewise. * gnu/packages/mail.scm (public-inbox): Likewise. * gnu/packages/maths.scm (hdf-java): Likewise. (maxima): Likewise. (frama-c): Likewise. * gnu/packages/messaging.scm (libgadu): Likewise. * gnu/packages/music.scm (denemo): Likewise. (curseradio): Likewise. * gnu/packages/netpbm.scm (netpbm): Likewise. * gnu/packages/networking.scm (blueman): Likewise. (squid): Likewise. (aircrack-ng): Likewise. * gnu/packages/node.scm (node): Likewise. (node-llparse-frontend-bootstrap): Likewise. (node-llparse-bootstrap): Likewise. (llhttp-bootstrap): Likewise. (node-lts): Likewise. * gnu/packages/ocaml.scm (ocaml-4.11): Likewise. (opam): Likewise. (ocaml-graph): Likewise. * gnu/packages/orpheus.scm (orpheus): Likewise. * gnu/packages/password-utils.scm (password-store): Likewise. * gnu/packages/python.scm (pypy3): Likewise. * gnu/packages/qt.scm (qt5ct): Likewise. * gnu/packages/radio.scm (libosmo-dsp): Likewise. * gnu/packages/ruby.scm (ruby-pandoc-ruby): Likewise. * gnu/packages/rust.scm (rust-1.30): Likewise. * gnu/packages/screen.scm (byobu): Likewise. * gnu/packages/statistics.scm (r-with-tests): Likewise. * gnu/packages/suckless.scm (surf): Likewise. * gnu/packages/syndication.scm (gfeeds): Likewise. * gnu/packages/telephony.scm (mumble): Likewise. * gnu/packages/terminals.scm (alacritty): Likewise. * gnu/packages/tex.scm (texlive-bin): Likewise. * gnu/packages/uml.scm (plantuml): Likewise. * gnu/packages/version-control.scm (python-git-multimail): Likewise. (gitolite): Likewise. (hg-commitsigs): Likewise. (git-when-merged): Likewise. (git-imerge): Likewise. (gita): Likewise. * gnu/packages/video.scm (you-get): Likewise. * gnu/packages/vim.scm (eovim): Likewise. * gnu/packages/virtualization.scm (qemu): Likewise. (virt-manager): Likewise. (criu): Likewise. * gnu/packages/vpn.scm (strongswan): Likewise. (xl2tpd): Likewise. * gnu/packages/wm.scm (i3lock-fancy): Likewise. * gnu/packages/wxwidgets.scm (python-wxpython): Likewise. (python2-wxpython): Likewise. * gnu/packages/xdisorg.scm (autorandr): Likewise. * gnu/packages/xorg.scm (hackneyed-x11-cursors): Likewise. (v86d): Likewise. (mkfontdir): Likewise. (xpra): Likewise. Ludovic Courtès