aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages i2p)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages check)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages upnp)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module ((guix licenses) #:prefix license:))

(define-public i2pd
  (package
    (name "i2pd")
    (version "2.50.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/PurpleI2P/i2pd")
             (commit version)))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1vr251mgffawi3rj51dzlnv3fs1ssz6gl17qbsyhfr5fcd7s0hc5"))))
    (build-system cmake-build-system)
    (native-inputs (list check pkg-config))
    (inputs
     (list boost miniupnpc openssl zlib))
    (arguments
     (list
      #:configure-flags
      #~(list (string-append "-S" #$source "/build")
              "-DWITH_UPNP=ON"
              "-DBUILD_SHARED_LIBS=ON"
              "-DBUILD_TESTING=ON")))
    (home-page "https://i2pd.website/")
    (synopsis "Router for an end-to-end encrypted and anonymous internet")
    (description "i2pd is a client for the anonymous I2P network, upon which
applications for file sharing, web browsing, instant messaging, and more are
built. i2pd allows people from all around the world to communicate and share
information securely without restrictions.")
    (license license:bsd-3)))
king.scm (blueman): Likewise. * gnu/packages/patchutils.scm (patchwork): Likewise. * gnu/packages/photo.scm (rapid-photo-downloader, entangle): Likewise. * gnu/packages/plotutils.scm (asymptote): Likewise. * gnu/packages/presentation.scm (presentty): Likewise. * gnu/packages/screen.scm (byobu): Likewise. * gnu/packages/storage.scm (ceph): Likewise. * gnu/packages/syndication.scm (liferea): Likewise. * gnu/packages/task-management.scm (blanket): Likewise. * gnu/packages/text-editors.scm (manuskript): Likewise. * gnu/packages/version-control.scm (gitless, cgit, git-when-merged) (git-imerge): Likewise. * gnu/packages/video.scm (pitivi): Likewise. * gnu/packages/virtualization.scm (criu): Likewise. * gnu/packages/xfce.scm (catfish): Likewise. Maxim Cournoyer 2021-01-17gnu: gama: Update to 2.13....* gnu/packages/gps.scm (gama): Update to 2.13. Efraim Flashner 2021-01-06gnu: gpsbabel: Enable tests....* gnu/packages/patches/gps.scm (gpsbabel)[source]: Add patch. [arguments]: Enable tests. * gnu/packages/patches/gpsbabel-fix-i686-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Efraim Flashner 2021-01-06gnu: gpsbabel: Unbundle zlib....* gnu/packages/gps.scm (gpsbabel)[source]: Adjust snippet to remove bundled zlib and references from the Makefile. Efraim Flashner 2021-01-06gnu: gpsbabel: Update to 1.7.0....* gnu/packages/gps.scm (gpsbabel): Update to 1.7.0. [source]: Use git-fetch, remove obsolete patches. [inputs]: Add libusb. * gnu/packages/patches/gpsbabel-minizip.patch: Remove file. * gnu/packages/patches/gpsbabel-qstring.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove entries. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Björn Höfling 2020-11-30gnu: gpxsee: Update to 7.37....* gnu/packages/gps.scm (gpxsee): Update to 7.37. Tobias Geerinckx-Rice 2020-11-29gnu: gama: Update to 2.12....* gnu/packages/gps.scm (gama): Update to 2.12. Efraim Flashner 2020-11-13gnu: gpxsee: Update to 7.36....* gnu/packages/gps.scm (gpxsee): Update to 7.36. Tobias Geerinckx-Rice 2020-11-05gnu: gpxsee: Update to 7.35....* gnu/packages/gps.scm (gpxsee): Update to 7.35. Tobias Geerinckx-Rice 2020-10-28gnu: gama: Remove bundled library....* gnu/packages/gps.scm (gama)[source]: Add snippet to remove bundled expat-1.1 library. Efraim Flashner 2020-10-28gnu: gama: Update to 2.11....* gnu/packages/gps.scm (gama): Update to 2.11. Efraim Flashner 2020-10-16gnu: gpxsee: Update to 7.34....* gnu/packages/gps.scm (gpxsee): Update to 7.34. Tobias Geerinckx-Rice 2020-09-27gnu: gama: Update to 2.10....* gnu/packages/gps.scm (gama): Update to 2.10. Efraim Flashner 2020-08-16gnu: gpsd: Update to 3.21....* gnu/packages/gps.scm (gpsd): Update to 3.21. Tobias Geerinckx-Rice 2020-07-24gnu: gpscorrelate: Update to 2.0....* gnu/packages/gps.scm (gpscorrelate): Update to 2.0. [arguments]: Remove #:tests?. [inputs]: Remove GTK+-2. Add GTK+. Marius Bakke 2020-07-01gnu: gama: Update to 2.09....* gnu/packages/gps.scm (gama): Update to 2.09. Efraim Flashner 2020-06-06gnu: gpxsee: Update to 7.30....* gnu/packages/gps.scm (gpxsee): Update to 7.30. Tobias Geerinckx-Rice 2020-04-22gnu: gama: Update to 2.08....* gnu/packages/gps.scm (gama): Update to 2.08. Efraim Flashner 2020-04-05gnu: gpsbabel: Make some inputs native....* gnu/packages/gps.scm (gpsbabel)[inputs]: Move qttools from here... [native-inputs]: ...to here. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Vincent Legoll 2020-04-03gnu: gpsd: Update to 3.20....* gnu/packages/gps.scm (gpsd): Update to 3.20. [inputs]: Add gtk+. Guillaume Le Vaillant 2020-03-17gnu: gpsd: Install python modules and scripts....* gnu/packages/gps.scm (gpsd)[native-inputs]: Remove python and add bc. [inputs]: Add python, python-pycairo, python-pygobject, python-pyserial, python-wrapper and qtbase. [arguments]: Update scons-flags, remove fix-paths phase, improve fix-build phase and add wrap-python-scripts phase. Guillaume Le Vaillant 2020-03-11gnu: gpxsee: Extend description....* gnu/packages/gps.scm (gpxsee)[description]: Extend. Tobias Geerinckx-Rice 2020-03-11gnu: gpxsee: Update to 7.25....* gnu/packages/gps.scm (gpxsee): Update to 7.25. Tobias Geerinckx-Rice