aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages i2p)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages check)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages upnp)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module ((guix licenses) #:prefix license:))

(define-public i2pd
  (package
    (name "i2pd")
    (version "2.50.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/PurpleI2P/i2pd")
             (commit version)))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1vr251mgffawi3rj51dzlnv3fs1ssz6gl17qbsyhfr5fcd7s0hc5"))))
    (build-system cmake-build-system)
    (native-inputs (list check pkg-config))
    (inputs
     (list boost miniupnpc openssl zlib))
    (arguments
     (list
      #:configure-flags
      #~(list (string-append "-S" #$source "/build")
              "-DWITH_UPNP=ON"
              "-DBUILD_SHARED_LIBS=ON"
              "-DBUILD_TESTING=ON")))
    (home-page "https://i2pd.website/")
    (synopsis "Router for an end-to-end encrypted and anonymous internet")
    (description "i2pd is a client for the anonymous I2P network, upon which
applications for file sharing, web browsing, instant messaging, and more are
built. i2pd allows people from all around the world to communicate and share
information securely without restrictions.")
    (license license:bsd-3)))
u/packages/version-control.scm (git): Update to 2.31.1. Tobias Geerinckx-Rice 2021-03-24Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2021-03-19gnu: Add git2cl....* gnu/packages/version-control.scm (git2cl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Xinglu Chen 2021-03-17gnu: tig: Update to 2.5.3....* gnu/packages/version-control.scm (tig): Update to 2.5.3. Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: donotshake <donotshake:matrix.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org> LibreMiami 2021-03-16gnu: b4: Fix setup.py version incompatibility....* gnu/packages/version-control.scm (b4)[source]: Add snippet to not require too specific of a version. Reported-by: Kyle Meyer <kyle@kyleam.com> Efraim Flashner 2021-03-16gnu: git: Fix git-manpages native input's hash....This is a follow-up to commit ab9629b7c91ff7d6392a03512cfe442823267777. * gnu/packages/version-control.scm (git)[native-inputs]: Fix git-manpages's hash. Léo Le Bouter 2021-03-16gnu: git: Update to 2.31.0....* gnu/packages/version-control.scm (git): Update to 2.31.0. Léo Le Bouter 2021-03-10gnu: git: Update to 2.30.2 [fixes CVE-2021-21300]....* gnu/packages/version-control.scm (git): Update to 2.30.2. Léo Le Bouter 2021-03-06Merge branch 'master' into core-updatesChristopher Baines 2021-03-02gnu: stgit: Update to 1.0....* gnu/packages/version-control.scm (stgit): Update to 1.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Stefan Reichör 2021-02-22gnu: gita: Update to 0.12.9....* gnu/packages/version-control.scm (gita): Update to 0.12.9. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net> Stefan Reichör 2021-02-21gnu: git: Add credential-libsecret output....* gnu/packages/version-control.scm (git)[native-inputs]: Add pkg-config. [inputs]: Add glib and libsecret. [outputs]: Add "credential-libsecret". [arguments]: Add 'install-credential-libsecret phase to #:phases to build and install "git-credential-libsecret" to "credential-libsecret" output. (git-minimal)[arguments]: Delete the 'install-credential-libsecret phase. Signed-off-by: Chris Marusich <cmmarusich@gmail.com> Léo Le Bouter 2021-02-20gnu: fossil: Update to 2.14....* gnu/packages/version-control.scm (fossil): Update to 2.14. Signed-off-by: Leo Famulari <leo@famulari.name> Vincent Legoll 2021-02-12gnu: Git: Update to 2.30.1....* gnu/packages/version-control.scm (git): Update to 2.30.1 [native-inputs]: Update git-manpages to 2.30.1. Leo Famulari 2021-02-11Merge branch 'master' into core-updatesDanny Milosavljevic 2021-02-10gnu: subversion: Update to 1.14.1 [fixes CVE-2020-17525]....* gnu/packages/version-control.scm (subversion): Update to 1.14.1. Leo Famulari 2021-02-07gnu: git-lfs: Update to 2.13.2....* gnu/packages/version-control.scm (git-lfs): Update to 2.13.2. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Vincent Legoll 2021-02-03Merge branch 'master' into core-updatesChristopher Baines 2021-02-01gnu: Adjust package collection to Wrap using GUIX_PYTHONPATH....This change was automated using: $ git ls-files | grep .scm | \ xargs sed 's/(getenv "PYTHONPATH")/(getenv "GUIX_PYTHONPATH")/' -i $ git ls-files | grep .scm | \ xargs sed 's/`("PYTHONPATH"/`("GUIX_PYTHONPATH"/' -i * gnu/packages/admin.scm (nmap): (dstat): Wrap using GUIX_PYTHONPATH. * gnu/packages/audio.scm (jack-2): (carla): Likewise. * gnu/packages/benchmark.scm (fio): Likewise. * gnu/packages/bioinformatics.scm (couger): Likewise. (gess, find-circ, filtlong, nanopolish): Likewise. * gnu/packages/cdrom.scm (cdemu-client): Likewise. * gnu/packages/chemistry.scm (avogadro): Likewise. * gnu/packages/connman.scm (econnman): Likewise. * gnu/packages/cups.scm (hplip): Likewise. * gnu/packages/debug.scm (scanmem): Likewise. * gnu/packages/display-managers.scm (lightdm): Likewise. * gnu/packages/ebook.scm (cozy): Likewise. * gnu/packages/education.scm (anki): Likewise. * gnu/packages/engineering.scm (kicad, volk, freecad): Likewise. * gnu/packages/game-development.scm (renpy): Likewise. * gnu/packages/games.scm (roguebox-adventures) (seahorse-adventures, kajongg): Likewise. * gnu/packages/gimp.scm (gimp, glimpse): Likewise. * gnu/packages/glib.scm (itstool): Likewise. * gnu/packages/gnome.scm (gnome-music, gtg, rhythmbox): Likewise. (eolie, d-feet, gedit, caribou, gnome-shell, authenticator) (gnome-todo, orca, passwordsafe, terminator, setzer) (libratbag, komikku): Likewise. * gnu/packages/gps.scm (gpsd): Likewise. * gnu/packages/gtk.scm (gtk-doc): Likewise. * gnu/packages/ibus.scm (ibus, ibus-libpinyin, ibus-anthy) (ibus-libhangul): Likewise. * gnu/packages/inkscape.scm (inkscape-1.0): Likewise. * gnu/packages/linux.scm (bcc): Likewise. * gnu/packages/mail.scm (notifymuch): Likewise. * gnu/packages/maths.scm (units): Likewise. * gnu/packages/music.scm (solfege): Likewise. * gnu/packages/networking.scm (blueman): Likewise. * gnu/packages/patchutils.scm (patchwork): Likewise. * gnu/packages/photo.scm (rapid-photo-downloader, entangle): Likewise. * gnu/packages/plotutils.scm (asymptote): Likewise. * gnu/packages/presentation.scm (presentty): Likewise. * gnu/packages/screen.scm (byobu): Likewise. * gnu/packages/storage.scm (ceph): Likewise. * gnu/packages/syndication.scm (liferea): Likewise. * gnu/packages/task-management.scm (blanket): Likewise. * gnu/packages/text-editors.scm (manuskript): Likewise. * gnu/packages/version-control.scm (gitless, cgit, git-when-merged) (git-imerge): Likewise. * gnu/packages/video.scm (pitivi): Likewise. * gnu/packages/virtualization.scm (criu): Likewise. * gnu/packages/xfce.scm (catfish): Likewise. Maxim Cournoyer 2021-01-27gnu: python-xyz: Move a few modules to (gnu packages python-build)....* gnu/packages/python-xyz.scm (python-pep517): Inherit from python-pep517-bootstrap. Remove the inherited common fields. (python-poetry-core, python-wheel) (python-toml): Move to ... * gnu/packages/python-build.scm: ... here, a new module. (python-pep517-bootstrap): New package. * gnu/local.mk (GNU_SYSTEM_MODULES): Register the new module. Maxim Cournoyer 2021-01-26gnu: mercurial: Update to 5.6.1....This fixes the build on Python 3.9. * gnu/packages/version-control.scm (mercurial): Update to 5.6.1. Delete trailing #t. [phases]{check}: Remove the "test-transaction-rollback-on-sigpipe.t" test file and add a comment. Maxim Cournoyer 2021-01-26gnu: mercurial: Update to 5.6.1....This fixes the build on Python 3.9. * gnu/packages/version-control.scm (mercurial): Update to 5.6.1. Delete trailing #t. [phases]{check}: Remove the "test-transaction-rollback-on-sigpipe.t" test file and add a comment. Maxim Cournoyer 2021-01-15gnu: python-xyz: Move a few modules to (gnu packages python-build)....* gnu/packages/python-xyz.scm (python-pep517): Inherit from python-pep517-bootstrap. Remove the inherited common fields. (python-poetry-core, python-wheel) (python-toml): Move to ... * gnu/packages/python-build.scm: ... here, a new module. (python-pep517-bootstrap): New package. * gnu/local.mk (GNU_SYSTEM_MODULES): Register the new module. Maxim Cournoyer 2021-01-14gnu: diffstat: Update to 1.64....* gnu/packages/version-control.scm (diffstat): Update to 1.64. Tobias Geerinckx-Rice 2021-01-12gnu: neon: Don't build static library....* gnu/packages/version-controls.scm (neon)[arguments]: Add configure-flag to skip static library. Efraim Flashner 2021-01-12gnu: neon: Update to 0.31.2....* gnu/packages/version-control.scm (neon): Update to 0.31.2. [source]: Use new upstream URI. [home-page]: Update to new home-page. Efraim Flashner 2021-01-03gnu: Add ghq....* gnu/packages/version-control.scm (ghq): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Joseph LaFreniere 2021-01-02gnu: b4: Update to 0.6.2....* gnu/packages/version-control.scm (b4): Update to 0.6.2. Tobias Geerinckx-Rice 2021-01-01gnu: git: Update to 2.30.0....* gnu/packages/version-control.scm (git): Update to 2.30.0. (native-inputs)[git-manpages]: Update hash. Signed-off-by: Leo Famulari <leo@famulari.name> Greg Hogan 2020-12-23Revert "gnu: gita: Update to 0.11.9."...This reverts commit 5540159f3e34ac8f6b3ab31f773f6e286028f309 which updates gita to v0.11.9 tag, which doesn't contain freeze and clone sub-commands. Oleg Pykhalov 2020-12-23gnu: gita: Update to 0.11.9....* gnu/packages/version-control.scm (gita): Update to 0.11.9. Oleg Pykhalov 2020-12-14gnu: b4: Update to 0.6.1....* gnu/packages/version-control.scm (b4): Update to 0.6.1. [source]: Download from pypi, which now includes the manpage. [arguments]: Remove now unnecessary install-manpages phase. [inputs]: Add python-dkimpy and python-dnspython. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Kyle Meyer 2020-12-08gnu: gita: Install shell completions....* gnu/packages/version-control.scm (gita)[arguments]: Add phase install-shell-completions. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com> Michael Rohleder 2020-12-08gnu: Add gita....* gnu/packages/version-control.scm (gita): New variable. Oleg Pykhalov 2020-12-05gnu: Add diff-so-fancy....* gnu/packages/version-control.scm (diff-so-fancy): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> EuAndreh 2020-12-04gnu: git-open: Remove unnecessary propagated input....* gnu/packages/version-control.scm (git-open)[arguments]: Wrap the git-open executable with the path to xdg-utils. [propagated-inputs]: Replace with ... [inputs]: New field. [build-system]: Use copy-build-system. Signed-off-by: Leo Famulari <leo@famulari.name> EuAndreh 2020-12-03gnu: libgit2: Update to 1.1.0...* gnu/packages/version-control.scm (libgit2): Update to 1.1.0. Signed-off-by: Leo Famulari <leo@famulari.name> Holger Peters 2020-11-29gnu: stgit: Update to 0.23....* gnu/packages/version-control.scm (stgit): Update to 0.23. Tobias Geerinckx-Rice 2020-11-29gnu: stgit: Update home page....* packages/version-control.scm (stgit)[home-page]: Follow HTML redirection. Tobias Geerinckx-Rice 2020-11-29gnu: b4: Update to 0.5.3....* gnu/packages/version-control.scm (b4): Update to 0.5.3. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Kyle Meyer 2020-11-29gnu: grokmirror: Update to 2.0.5....* gnu/packages/version-control.scm (grokmirror): Update to 2.0.5. [propagated-inputs]: Add python-packaging. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Kyle Meyer 2020-11-25gnu: Add git-open....* gnu/packages/version-control.scm (git-open): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> EuAndreh 2020-11-16gnu: git: Add phase to restore hooks shebang....Fixes <https://bugs.gnu.org/25508>. * gnu/packages/version-control.scm (git)[arguments]: New phase restore-sample-hooks-shebang. Miguel Ángel Arruga Vivas 2020-11-15gnu: Add b4....* gnu/packages/version-control.scm (b4): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Kyle Meyer 2020-11-10gnu: pre-commit: Update to 2.8.1....* gnu/packages/version-control.scm (pre-commit): Update to 2.8.1. [arguments]: Skip new dotnet and nodejs tests. [native-inputs]: Add python-re-assert. [inputs]: Propagate. Signed-off-by: Marius Bakke <marius@gnu.org> Vinicius Monego