aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages hugs)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gcc))

(define-public hugs
  (package
    (name "hugs")
    (version "Sep2006")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "https://www.haskell.org/hugs/downloads/2006-09/"
                          name "98-plus-" version ".tar.gz"))
      (sha256
       (base32
        "1mdy4aq4campgmnpc2qwq7bsbfhaxfsqdghbyyz2wms4lnfcmyma"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-before 'configure 'fix-sh-n-cp
           (lambda _
             (substitute*
                 '("configure"
                   "libraries/configure"
                   "packages/time/configure"
                   "packages/base/configure"
                   "packages/X11/configure"
                   "packages/HGL/configure"
                   "packages/OpenAL/configure"
                   "packages/OpenGL/configure"
                   "packages/network/configure"
                   "packages/unix/configure"
                   "packages/Cabal/tests/HSQL/configure"
                   "packages/ALUT/configure"
                   "packages/GLUT/configure"
                   "packages/base/cbits/execvpe.c"
                   "packages/base/System/Process/Internals.hs"
                   "packages/Cabal/Distribution/attic"
                   "packages/Cabal/Distribution/Simple/Register.hs"
                   "packages/Cabal/Distribution/Simple/Hugs.hs"
                   "tools/hugs-hc"
                   "src/machdep.c"
                   "libraries/Makefile.in")
               (("/bin/sh") (which "sh")))
             (substitute* '("demos/Makefile.in"
                            "libraries/Makefile.in")
               (("/bin/cp") (which "cp")))
             #t)))
       #:tests? #f)) ; no test target
    ;; FIXME: Fails to build with GCC 5.
    (native-inputs (list gcc-4.9))
    (home-page "https://www.haskell.org/hugs/")
    (synopsis "Functional programming system based on Haskell 98")
    (description
     "Hugs 98 is an interpreter and programming environment for developing
Haskell programs.  It provides an almost complete implementation of Haskell
98, which includes expression and pattern syntax, primitives for monadic I/O,
with support for simple interactive programs, handle-based I/O, and exception
handling.  Hugs has a nearly complete implementation of the Haskell module
system and supports a number of advanced extensions.")
   (license (non-copyleft "file://License"
                          "See License in the distribution."))))
Weaver 2018-12-12Merge branch 'master' into stagingMarius Bakke 2018-12-12gnu: nss, nss-certs: Update to 3.41....Marius Bakke 2018-12-11gnu: icecat: Add fixes from upstream mozilla-esr60 [security-fixes]....Mark H Weaver 2018-12-11gnu: icecat: Relabel patches to reflect CVE assignments....Mark H Weaver 2018-12-11gnu: icecat: Enable Stylo CSS engine....Mark H Weaver 2018-12-08gnu: nss, nss-certs: Update to 3.40.1....Marius Bakke 2018-11-17gnu: nss: Make tests deterministic....Ludovic Courtès 2018-11-10gnu: icecat: Add more fixes from mozilla-esr60....Mark H Weaver 2018-11-10gnu: icecat: Update to 60.3.0-gnu1....Mark H Weaver 2018-10-23gnu: icecat: Add fixes from mozilla-esr60 [security fixes]....Mark H Weaver 2018-10-14gnu: icecat: Build with rust-1.24....Efraim Flashner 2018-10-04gnu: icecat: Add fixes from mozilla-esr60 [security fixes]....Mark H Weaver 2018-09-25gnu: icecat: Rebundle NSPR and NSS [security fix]....Mark H Weaver 2018-09-25gnu: icecat: Unbundle libevent, libogg, and libvorbis....Mark H Weaver 2018-09-25gnu: icecat: Unbundle graphite2 and harfbuzz....Mark H Weaver 2018-09-22gnu: icecat: Add fixes from upstream mozilla-esr60 [security fixes]....Mark H Weaver 2018-09-21gnu: icecat: Update to 60.2.0-gnu1 (pre-release)....Mark H Weaver 2018-09-01gnu: nss, nss-certs: Update to 3.39 [fixes CVE-2018-12384]....Marius Bakke 2018-09-01gnu: nspr: Update to 4.20....Marius Bakke 2018-08-09gnu: Add mozjs-52....Ricardo Wurmus 2018-07-02Merge branch 'master' into stagingMarius Bakke 2018-06-27gnu: icecat: Add more fixes from upstream mozilla-esr52....Mark H Weaver 2018-06-27gnu: icecat: Relabel patches to reflect CVE assignments....Mark H Weaver 2018-06-26gnu: nss, nss-certs: Update to 3.38 [fixes CVE-2018-0495]....Marius Bakke 2018-06-19gnu: nss, nss-certs: Update to 3.37.3....Marius Bakke