aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018, 2020, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages hexedit)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages man)
  #:use-module (gnu packages ncurses)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu))

(define-public hexedit
  (package
    (name "hexedit")
    (version "1.6")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/pixel/hexedit")
                    (commit version)))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "00l8vazbjzdg09azp6w3nzq4rl7qyh06i65dh621r6zaprp0z23w"))))
    (build-system gnu-build-system)
    (arguments
     `(#:tests? #f                      ; no check target
       #:phases
       (modify-phases %standard-phases
         ;; Make F1 open the man page even if man-db is not in the profile.
         (add-after 'unpack 'patch-man-path
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (substitute* "interact.c"
               (("\"man\"")
                (string-append "\"" (assoc-ref inputs "man-db") "/bin/man\""))
               (("\"hexedit\"")
                (string-append "\"" (assoc-ref outputs "out")
                               "/share/man/man1/hexedit.1.gz\""))))))))
    (native-inputs
     (list autoconf automake))
    (inputs
     (list man-db ncurses))
    (synopsis "View and edit files or devices in hexadecimal or ASCII")
    (description "hexedit shows a file both in ASCII and in hexadecimal.  The
file can be a device as the file is read a piece at a time.  You can modify
the file and search through it.")
    (home-page "http://rigaux.org/hexedit.html")
    (license license:gpl2+)))

(define-public ht
  (package
    (name "ht")
    (version "2.1.0")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://sourceforge.net/projects/hte/files/ht-source/"
                    name "-" version ".tar.bz2"))
              (sha256
               (base32
                "0w2xnw3z9ws9qrdpb80q55h6ynhh3aziixcfn45x91bzrbifix9i"))))
    (build-system gnu-build-system)
    (inputs
     (list lzo ncurses))
    (synopsis "Viewer, editor, and analyzer for executable binaries")
    (description
     "ht is a terminal-based program to view, edit, and analyze any file, but
with a special focus on executable binaries.  Its goal is to combine the
low-level functionality of a debugger with the usability of an @dfn{Integrated
Development Environment} (IDE).")
    (home-page "https://hte.sourceforge.net/")
    (license license:gpl2)))

(define-public bvi
  (package
    (name "bvi")
    (version "1.4.2")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "mirror://sourceforge/bvi/bvi/" version
                    "/bvi-" version ".src.tar.gz"))
              (sha256
               (base32
                "1wllrvs8r8bdm11sx01095j8cj4drjmw0dlkjfdkm5lnnk11dfjb"))))
    (build-system gnu-build-system)
    (arguments '(#:tests? #f))          ; no check target
    (inputs
     (list ncurses))
    (synopsis "Binary file editor")
    (description "@command{bvi} is a display-oriented editor for binary files,
based on the @command{vi} text editor.")
    (home-page "https://bvi.sourceforge.net/")
    (license license:gpl3+)))
2 11:35:06 -0500'>2021-12-22gnu: disarchive: Update to 0.4.0....* gnu/packages/backup.scm (disarchive)[source]: Update to 0.4.0. [native-inputs, inputs]: Add guile-lzma. * gnu/packages/package-management.scm (guix)[arguments]: Include guile-lzma in the 'wrap-program' phase. [inputs]: Add guile-lzma. Timothy Sample 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus 2021-11-27gnu: borgmatic: Update to 1.5.21....* gnu/packages/backup.scm (borgmatic): Update to 1.5.21. Tobias Geerinckx-Rice 2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-15gnu: borgmatic: Fix typo in description....* gnu/packages/backup.scm (borgmatic): Fix typo, "software" being a mass noun. Nicolas Goaziou 2021-11-14gnu: Add borgmatic....* gnu/packages/backup.scm (borgmatic): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Arun Isaac 2021-11-13gnu: duplicity: Update to 0.8.21....* gnu/packages/backup.scm (duplicity): Update to 0.8.21. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2021-11-11gnu: Remove references to a removed patch....* gnu/packages/backup.scm (libchop)[source]: Remove the patch. (idutils)[source]: Ditto. Mathieu Othacehe 2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-24gnu: disarchive: Update to 0.3.0....* gnu/packages/backup.scm (disarchive): Update to 0.3.0. [source]: Remove cross-compilation patch. [arguments]: Remove field. * gnu/packages/patches/disarchive-cross-compilation.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Timothy Sample 2021-10-23gnu: Use 'search-input-file' some more....This patch replaces occurrences of: (string-append (assoc-ref %build-inputs "…") "/…") by: (search-input-file %build-inputs "/…") * doc/guix.texi (Miscellaneous Services): Use 'search-input-file' in R Shiny example. * gnu/packages/admin.scm (screenfetch): Use 'search-input-file'. (ufetch): Likewise. (hosts): Likewise. * gnu/packages/backup.scm (dirvish): Likewise. * gnu/packages/code.scm (colormake): Likewise. * gnu/packages/compression.scm (makeself-safeextract): Likewise. * gnu/packages/debug.scm (scanmem): Likewise. * gnu/packages/education.scm (snap): Likewise. (omnitux): Likewise. * gnu/packages/emacs-xyz.scm (epipe): Likewise. * gnu/packages/games.scm (openttd-opensfx): Likewise. (openttd-openmsx): Likewise. (openrct2-title-sequences): Likewise. (openrct2-objects): Likewise. (mrrescue): Likewise. (0ad-data): Likewise. (xonotic-data): Likewise. (drascula): Likewise. (make-lure-package): Likewise. (make-queen-package): Likewise. (sky): Likewise. * gnu/packages/gnome.scm (network-manager): Likewise. * gnu/packages/gnuzilla.scm (icedove): Likewise. * gnu/packages/guile-xyz.scm (guile-shapefile): Likewise. * gnu/packages/hurd.scm (netdde): Likewise. * gnu/packages/javascript.scm (js-context-menu): Likewise. (js-commander): Likewise. (js-xmldom-sre): Likewise. * gnu/packages/kde-frameworks.scm (krunner): Likewise. * gnu/packages/kodi.scm (kodi-cli): Likewise. * gnu/packages/libreoffice.scm (hunspell-dict-pl): Likewise. * gnu/packages/linux.scm (e2fsck/static): Likewise. * gnu/packages/markup.scm (markdown): Likewise. * gnu/packages/maths.scm (hdf-java): Likewise. * gnu/packages/multiprecision.scm (libtomcrypt): Likewise. * gnu/packages/networking.scm (batctl): Likewise. * gnu/packages/python-xyz.scm (python-pymediainfo): Likewise. * gnu/packages/shells.scm (fish-foreign-env): Likewise. * gnu/packages/tex.scm (texlive-fonts-iwona): Likewise. * gnu/packages/upnp.scm (miniupnpc): Likewise. * gnu/packages/version-control.scm (git-annex-remote-rclone): Likewise. * gnu/packages/virtualization.scm (qemu): Likewise. * gnu/packages/web.scm (icedtea-web): Likewise. * gnu/packages/wm.scm (stumpish): Likewise. Ludovic Courtès 2021-10-18Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-10-17gnu: duplicity: Update home-page....* gnu/packages/backup.scm (duplicity)[home-page]: Update to new upstream URI. Efraim Flashner 2021-10-17gnu: duplicity: Depend on dbus....* gnu/packages/backup.scm (duplicity)[inputs]: Add dbus. [arguments]: Adjust 'use-store-file-names to substitute the dbus-launch program name. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Vivien Kraus 2021-10-17gnu: duplicity: Depend on python-pygobject....* gnu/packages/backup.scm (duplicity)[propagated-inputs]: Add python-pygobject. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Vivien Kraus 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-03gnu: snapraid: Update to 11.6....* gnu/packages/backup.scm (snapraid): Update to 11.6. Tobias Geerinckx-Rice 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-08-30gnu: libchop: Don't append to CPATH unconditionally....* gnu/packages/backup.scm (libchop)[arguments]: Adjust 'set-libtirpc-include-path to return a valid CPATH. Efraim Flashner 2021-08-12Merge branch 'master' into core-updates-frozen... Conflicts: gnu/packages/algebra.scm gnu/packages/games.scm gnu/packages/golang.scm gnu/packages/kerberos.scm gnu/packages/mail.scm gnu/packages/python.scm gnu/packages/ruby.scm gnu/packages/scheme.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm Marius Bakke 2021-07-27gnu: Duplicity: Depend on python-paramiko....Fixes <https://bugs.gnu.org/49979>. * gnu/packages/backup.scm (duplicity)[native-inputs]: Add python-paramiko. Leo Famulari 2021-07-27gnu: Borg: Use bundled msgpack....This is an old and customized version of msgpack-python. * gnu/packages/backup.scm (borg)[source]: In the snippet, don't delete the bundled 'msgpack' directory, and remove the related substition applied to setup.py. [arguments]: Remove the 'use-system-msgpack' phase. [inputs]: Remove 'python-msgpack-transitional'. Leo Famulari 2021-08-15Update copyright/name notices for Christine Lemmer-Webber....* doc/guix-cookbook.texi: Update copyright/name for Christine Lemmer-Webber. * gnu/build/image.scm: Likewise. * gnu/build/vm.scm: Likewise. * gnu/packages/admin.scm: Likewise. * gnu/packages/assembly.scm: Likewise. * gnu/packages/audio.scm: Likewise. * gnu/packages/backup.scm: Likewise. * gnu/packages/check.scm: Likewise. * gnu/packages/databases.scm: Likewise. * gnu/packages/emacs-xyz.scm: Likewise. * gnu/packages/finance.scm: Likewise. * gnu/packages/gnupg.scm: Likewise. * gnu/packages/guile-xyz.scm: Likewise. * gnu/packages/guile.scm: Likewise. * gnu/packages/haskell-xyz.scm: Likewise. * gnu/packages/linux.scm: Likewise. * gnu/packages/mail.scm: Likewise. * gnu/packages/password-utils.scm: Likewise. * gnu/packages/perl.scm: Likewise. * gnu/packages/python-web.scm: Likewise. * gnu/packages/python-xyz.scm: Likewise. * gnu/packages/python.scm: Likewise. * gnu/packages/sphinx.scm: Likewise. * gnu/packages/ssh.scm: Likewise. * gnu/packages/xdisorg.scm: Likewise. * gnu/services/networking.scm: Likewise. * gnu/system/vm.scm: Likewise. Christopher Lemmer Webber 2021-08-05gnu: restic: Have the custom check phase honor TESTS?....* gnu/packages/backup.scm (restic)[phases]{check}: Honor TESTS?. Maxim Cournoyer 2021-08-05gnu: restic: Patch tests for go-1.16....* gnu/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/backup.scm (restic): Use it. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sarah Morgensen 2021-07-24gnu: Use 'search-input-directory' when looking for tzdata....* gnu/packages/backup.scm (duplicity)[arguments]: Use 'search-input-directory' for "share/zoneinfo". * gnu/packages/bioinformatics.scm (pigx-rnaseq): Likewise. (pigx-bsseq): Likewise. * gnu/packages/calcurse.scm (calcurse): Likewise. * gnu/packages/calendar.scm (date): Likewise. * gnu/packages/compression.scm (lhasa): Likewise. * gnu/packages/cran.scm (r-rstan): Likewise. * gnu/packages/django.scm (python-django): Likewise. * gnu/packages/dlang.scm (ldc-bootstrap): Likewise. * gnu/packages/finance.scm (ledger): Likewise. * gnu/packages/glib.scm (glib): Likewise. * gnu/packages/golang.scm (go-1.4): Likewise. (go-1.14): Likewise. * gnu/packages/kde-frameworks.scm (kcalendarcore): Likewise. (kdelibs4support): Likewise. * gnu/packages/kodi.scm (kodi): Likewise. * gnu/packages/mail.scm (mu): Likewise. * gnu/packages/perl.scm (perl-libtime-parsedate): Likewise. * gnu/packages/python-xyz.scm (python-robotframework): Likewise. (python-dparse): Likewise. * gnu/packages/rrdtool.scm (rrdtool): Likewise. * gnu/packages/statistics.scm (r-with-tests): Likewise. * gnu/packages/vim.scm (vim): Likewise. * gnu/packages/virtualization.scm (ganeti): Likewise. * gnu/packages/vpn.scm (strongswan): Likewise. * gnu/packages/xfce.scm (xfce4-panel): Likewise. * gnu/packages/mate.scm (libmateweather): Use 'search-input-file' for "share/zoneinfo/zone.tab". Ludovic Courtès 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-17gnu: rsnapshot: Remove modifications to tests....Upstream fixed those tests, no need to tweak them anymore. * gnu/packages/backup.scm (rsnapshot)[arguments]: Remove modifications to tests done in 'check' phase. Brice Waegeneire 2021-07-17gnu: rsnapshot: Fix tests....* gnu/packages/backup.scm (rsnapshot)[arguments]: Tweak substitution. Tobias Geerinckx-Rice 2021-07-15gnu: Add snapraid....* gnu/packages/backup.scm (snapraid): New public variable. Tobias Geerinckx-Rice 2021-07-13gnu: Borg: Update to 1.1.17....* gnu/packages/backup.scm (borg): Update to 1.1.17. Leo Famulari 2021-06-30gnu: duplicity: Update to 0.8.20....* gnu/packages/backup.scm (duplicity): Update to 0.8.20. Tobias Geerinckx-Rice 2021-06-23Merge branch 'master' into core-updates...Conflicts: gnu/packages/cups.scm gnu/packages/python-web.scm gnu/packages/web.scm guix/build/maven/pom.scm Tobias Geerinckx-Rice 2021-06-20gnu: rsnapshot: Update to 1.4.4....* gnu/packages/backup.scm (rsnapshot): Update to 1.4.4. Tobias Geerinckx-Rice