aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gxmessage)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages))

(define-public gxmessage
  (package
    (name "gxmessage")
    (version "3.4.3")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/gxmessage/gxmessage-"
                                 version ".tar.gz"))
             (sha256
              (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-before 'install 'skip-gtk-update-icon-cache
           ;; Don't create 'icon-theme.cache'.
           (lambda _
             (substitute* "Makefile"
               (("gtk-update-icon-cache") "true"))
             #t)))))
    (inputs
     (list gtk+))
    (native-inputs
     (list intltool pkg-config))
    (home-page "https://www.gnu.org/software/gxmessage/")
    (synopsis "Open popup message window with buttons for return")
    (description "GNU gxmessage is a program that pops up dialog windows, which display
a message to the user and waits for their action.  The program then exits
with an exit code corresponding to the response.")
    (license gpl3+)))
span class='msg-avail'>...* gnu/packages/cups.scm (hplip): Update to 3.23.8. Tobias Geerinckx-Rice 2023-07-16gnu: epson-inkjet-printer-escpr: Document missing newer tarballs....* gnu/packages/cups.scm (epson-inkjet-printer-escpr)[source]: Add more bad news to comment. Tobias Geerinckx-Rice 2023-07-16gnu: hplip: Update to 3.23.5....* gnu/packages/cups.scm (hplip): Update to 3.23.5. Tobias Geerinckx-Rice 2023-07-02gnu: brlaser: Use G-expressions....* gnu/packages/cups.scm (brlaser)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-07-02gnu: brlaser: Update to 6-2.2a49e32....* gnu/packages/cups.scm (brlaser): Update to 6-2.2a49e32. Tobias Geerinckx-Rice 2023-07-09gnu: cups: Don't set #:tests? to #:true....* gnu/packages/cups.scm (cups)[arguments]: Rewrite to strip the #:tests? argument from the inherited package. Efraim Flashner 2023-07-02gnu: cups: Replace with 2.4.6 [fixes CVE-2023-34241]....* gnu/packages/cups.scm (cups-minimal/fixed): New variable. (cups-minimal)[replacement]: Assign it to new field. Tobias Geerinckx-Rice 2023-04-14gnu: hplip: Update to 3.23.3....* gnu/packages/cups.scm (hplip): Update to 3.23.3. [arguments]: Remove the fix-build-with-python-3.8 phase. Maxim Cournoyer 2023-04-14gnu: hplip: Remove input labels....* gnu/packages/cups.scm (hplip) [inputs]: Remove input labels. Maxim Cournoyer 2023-04-14gnu: hplip: Use gexps....* gnu/packages/cups.scm (hplip) [arguments]: Use gexps. * gnu/packages/cups.scm (hplip-minimal): Likewise. Maxim Cournoyer 2023-04-14gnu: hplip: Re-order fields....* gnu/packages/cups.scm (hplip): Re-order fields. Maxim Cournoyer 2023-04-14gnu: hplip: Update to 3.22.10....* gnu/packages/cups.scm (hplip): Update to 3.22.10. [arguments]: Absorb the fix-more-hard-coded-file-names phase from hplip-next into the fix-hard-coded-file-names phase. (hplip-next): Delete variable. Maxim Cournoyer 2023-04-14gnu: cups-minimal: Add config to native inputs unconditionally....* gnu/packages/cups.scm (cups-minimal) [native-inputs]: Always add config. Maxim Cournoyer 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-10gnu: cups-minimal: Fix cross-building to riscv64-linux....* gnu/packages/cups.scm (cups-minimal)[arguments]: When building for riscv64-linux replace the config.guess and config.sub files. [native-inputs]: When building for riscv64-linux add config. Efraim Flashner 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-19gnu: epson-inkjet-printer-escpr: Update to 1.7.24....* gnu/packages/cups.scm (epson-inkjet-printer-escpr): Update to 1.7.24. Tobias Geerinckx-Rice 2023-02-19gnu: hplip-next: Simplify the fix-more-hard-coded-file-names phase....* gnu/packages/cups.scm (hplip-next) [phases]: Only substitute python files in the fix-more-hard-coded-file-names phase. This greatly reduce the time taken by the phase (from 21 s to 0.4 s) on my system, and is functionally equivalent. Maxim Cournoyer 2023-02-18gnu: hplip-next: Update to 3.22.10....* gnu/packages/cups.scm (hplip-next): Update to 3.22.10. Maxim Cournoyer 2023-02-18gnu: Add hplip-next....* gnu/packages/cups.scm (hplip-next): New variable. Maxim Cournoyer 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2022-11-27gnu: epson-inkjet-printer-escpr: Update to 1.7.22....* gnu/packages/cups.scm (epson-inkjet-printer-escpr): Update to 1.7.22. Tobias Geerinckx-Rice