aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gxmessage)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages))

(define-public gxmessage
  (package
    (name "gxmessage")
    (version "3.4.3")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/gxmessage/gxmessage-"
                                 version ".tar.gz"))
             (sha256
              (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-before 'install 'skip-gtk-update-icon-cache
           ;; Don't create 'icon-theme.cache'.
           (lambda _
             (substitute* "Makefile"
               (("gtk-update-icon-cache") "true"))
             #t)))))
    (inputs
     (list gtk+))
    (native-inputs
     (list intltool pkg-config))
    (home-page "https://www.gnu.org/software/gxmessage/")
    (synopsis "Open popup message window with buttons for return")
    (description "GNU gxmessage is a program that pops up dialog windows, which display
a message to the user and waits for their action.  The program then exits
with an exit code corresponding to the response.")
    (license gpl3+)))
:10:56 -0400'>2023-04-14gnu: libical: Update to 3.0.16....* gnu/packages/calendar.scm (libical): Update to 3.0.16. Marius Bakke 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2022-11-26Merge branch 'master' into stagingMarius Bakke 2022-11-24gnu: Add hebcal....* gnu/packages/calendar.scm (hebcal): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Felix Lechner 2022-11-20gnu: libical: Update to 3.0.16....* gnu/packages/calendar.scm (libical): Update to 3.0.16. Marius Bakke 2022-09-27Merge branch 'staging' into core-updates...Conflicts resolved in: gnu/local.mk gnu/packages/cran.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/icu4c.scm gnu/packages/java.scm gnu/packages/machine-learning.scm gnu/packages/tex.scm Maxim Cournoyer 2022-09-27Merge branch 'master' into staging....With resolved conflicts in: gnu/local.mk gnu/packages/crates-io.scm Maxim Cournoyer 2022-09-22gnu: gsimplecal: Update to 2.4.1....* gnu/packages/calendar.scm (gsimplecal): Update to 2.4.1. Signed-off-by: Björn Höfling <bjoern.hoefling@bjoernhoefling.de> Hendursaga 2022-08-28gnu: libical: Update to 3.0.14, enable tests and use gexps....* gnu/packages/calendar.scm (libical): Update to 3.0.14. [tests?]: Delete argument. [parallel-build?]: Likewise. [configure-flags]: Use gexps. [phases]: Use gexps. Delete trailing #t. {patch-docbook-reference}: Use this-package-native-input. {patch-paths}: Use search-input-directory. Set TZDIR for tests. Maxim Cournoyer 2022-07-21Merge branch 'master' into stagingMarius Bakke 2022-07-18gnu: khal: Update to 0.10.5....* gnu/packages/calendar.scm (khal): Update to 0.10.5. [arguments]: Remove trailing #t from phases. Efraim Flashner 2022-07-13Merge branch 'master' into stagingMarius Bakke 2022-06-26gnu: python-setuptools-scm: Move to (gnu packages python-build)....* gnu/packages/python-xyz.scm (python-setuptools-scm): Move from here... * gnu/packages/python-build.scm (python-setuptools-scm): ... to here. Maxim Cournoyer 2022-06-23gnu: libical: Update to 3.0.14....* gnu/packages/calendar.scm (libical): Update to 3.0.14. [arguments]: Remove trailing #t's. Marius Bakke