aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gxmessage)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages))

(define-public gxmessage
  (package
    (name "gxmessage")
    (version "3.4.3")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/gxmessage/gxmessage-"
                                 version ".tar.gz"))
             (sha256
              (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-before 'install 'skip-gtk-update-icon-cache
           ;; Don't create 'icon-theme.cache'.
           (lambda _
             (substitute* "Makefile"
               (("gtk-update-icon-cache") "true"))
             #t)))))
    (inputs
     (list gtk+))
    (native-inputs
     (list intltool pkg-config))
    (home-page "https://www.gnu.org/software/gxmessage/")
    (synopsis "Open popup message window with buttons for return")
    (description "GNU gxmessage is a program that pops up dialog windows, which display
a message to the user and waits for their action.  The program then exits
with an exit code corresponding to the response.")
    (license gpl3+)))
class='msg-tooltip'>* gnu/packages/instrumentation.scm (perf-tools)[arguments: Add 'patch-file-names' phase. [inputs]: Remove GCC-TOOLCHAIN, which appears to be redundant and would be retained as a reference due to the new phase. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Olivier Dion 2022-08-16gnu: lttng-tools: Update the hash....This is a follow-up of c53a5e7dc3153443cab5ac8ce7ff9d935785fe44. * gnu/packages/instrumentation.scm (lttng-tools)[source]: Update it. Mathieu Othacehe 2022-08-16gnu: lttng-ust: Update source hash....This was forgotten in eca0227239c7ca52a2a3f4eed82b546899d57fec. * gnu/packages/instrumentation.scm (lttng-ust)[source]: Correct the hash. Jonathan Brielmaier 2022-08-15gnu: lttng-tools: Update to 2.13.7....* gnu/packages/instrumentation.scm (lttng-tools): Update to 2.13.7. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Olivier Dion 2022-08-15gnu: lttng-ust: Update to 2.13.3....* gnu/packages/instrumentation.scm (lttng-ust): Update to 2.13.3. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Olivier Dion 2022-08-15gnu: Add lttng-modules....* gnu/packages/instrumentation.scm (lttng-modules): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Olivier Dion 2022-08-05gnu: Add perf-tools....* gnu/packages/instrumentation.scm (perf-tools): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Olivier Dion 2022-06-15gnu: lttng-ust: Fix dependencies....* gnu/packages/instrumentation.scm (lttng-ust): Fix dependencies. [inputs]: Remove liburcu. [propagated-inputs]: Add liburcu. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Olivier Dion 2022-05-25Move (gnu platform) and (gnu platforms ...) to guix/....* gnu/platform.scm: * gnu/platforms/arm.scm: * gnu/platforms/hurd.scm: * gnu/platforms/mips.scm: * gnu/platforms/powerpc.scm: * gnu/platforms/riscv.scm: * gnu/platforms/s390.scm: * gnu/platforms/x86.scm: Move to guix/. * Makefile.am: * doc/guix.texi (Porting to a New Platform): * etc/release-manifest.scm: * gnu/ci.scm: * gnu/image.scm: * gnu/local.mk: * gnu/packages/bioinformatics.scm: * gnu/packages/bootstrap.scm: * gnu/packages/cross-base.scm: * gnu/packages/instrumentation.scm: * gnu/packages/linux.scm: * gnu/system/image.scm: * gnu/system/images/hurd.scm: * gnu/system/images/novena.scm: * gnu/system/images/pine64.scm: * gnu/system/images/pinebook-pro.scm: * gnu/system/images/rock64.scm: * guix/scripts/build.scm: * guix/scripts/system.scm: * guix/self.scm: Update (gnu platform...) to (guix platform...). Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Josselin Poiret 2022-05-22linux: Remove system->linux-architecture procedure....* gnu/packages/linux.scm (system->linux-architecture): Remove it. (make-linux-libre-headers*, make-linux-libre*): Adapt them. * guix/build-system/linux-module.scm (system->arch): Adapt it. * gnu/packages/instrumentation.scm (uftrace): Ditto. * gnu/packages/cross-base.scm (cross-kernel-headers): Ditto. * gnu/packages/bioinformatics.scm (ncbi-vdb): Ditto. * doc/guix.texi (Porting to a new platform): Update it. Mathieu Othacehe 2022-05-21gnu: lttng-ust: Fix license....* gnu/packages/instrumentation.scm (lttng-ust): Fix license. [license]: Set to lgpl2.1 and expat. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Olivier Dion 2022-01-20gnu: Add uftrace....* gnu/packages/instrumentation.scm: (uftrace): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Olivier Dion 2022-01-20gnu: Add flamegraph....* gnu/packages/instrumentation.scm (flamegraph): New variable. Olivier Dion