aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gv)
  #:use-module (gnu packages)
  #:use-module (gnu packages ghostscript)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public gv
  (package
   (name "gv")
   (version "3.7.4")
   (source (origin
            (method url-fetch)
            (uri (string-append "mirror://gnu/gv/gv-"
                                version ".tar.gz"))
            (sha256 (base32
                     "0q8s43z14vxm41pfa8s5h9kyyzk1fkwjhkiwbf2x70alm6rv6qi1"))))
   (build-system gnu-build-system)
   (arguments
    '(#:phases (modify-phases %standard-phases
                 (add-before 'configure 'set-gs-file-name
                   (lambda* (#:key inputs #:allow-other-keys)
                     ;; Set the value of 'GV.gsInterpreter' in the generated
                     ;; 'gv_system.ad' file.
                     (let ((gs (assoc-ref inputs "ghostscript")))
                       (with-fluids ((%default-port-encoding "ISO-8859-1"))
                        (substitute* "src/Makefile.in"
                          (("GV\\.gsInterpreter:([[:blank:]]+)gs" _ blank)
                           (string-append "GV.gsInterpreter:" blank
                                          gs "/bin/gs"))
                          (("GV\\.gsCmd([[:alpha:]]+):([[:blank:]]+)gs" _
                            command blank)
                           (string-append "GV.gsCmd" command ":"
                                          blank gs "/bin/gs"))))
                       #t))))))
   (inputs `(("ghostscript" ,ghostscript/x)
             ("libx11" ,libx11)
             ("libxaw3d" ,libxaw3d)
             ("libxinerama" ,libxinerama)
             ("libxpm" ,libxpm)
             ("zlib" ,zlib)))
   (native-inputs
     (list pkg-config))
   (synopsis "PostScript and PDF viewer using Ghostscript as a back-end")
   (description
    "GNU GV is a graphical user interface to the Ghostscript interpreter.
With it, one can view and navigate through PostScript and PDF documents in X
Windows.")
   (license license:gpl3+)
   (home-page "https://www.gnu.org/software/gv/")))
et): New fields. Marius Bakke 2020-02-14gnu: nss, nss-certs: Update to 3.50....* gnu/packages/nss.scm (nss): Update to 3.50. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2020-02-14gnu: nspr: Update to 4.25....* gnu/packages/nss.scm (nspr): Update to 4.25. Marius Bakke 2020-02-14gnu: nspr: Do not build the static library....* gnu/packages/nss.scm (nspr)[arguments]: Add "--disable-static" in #:configure-flags. Marius Bakke 2020-02-14gnu: nss: Remove obsolete patch....* gnu/packages/patches/nss-freebl-stubs.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/nss.scm (nss)[source](patches): Remove 'nss-freebl-stubs.patch'. Marius Bakke 2020-01-21Merge branch 'staging' into core-updatesMarius Bakke 2020-01-19gnu: nss, nss-certs: Update to 3.49.1....* gnu/packages/certs.scm (nss-certs): Update to 3.49.1. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2020-01-12gnu: nss, nss-certs: Update to 3.49....* gnu/packages/certs.scm (nss-certs): Update to 3.49. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2020-01-11Merge branch 'master' into core-updatesMarius Bakke 2019-12-12gnu: nss: Ungraft....* gnu/packages/nss.scm (nss)[replacement]: Remove field. [source]: Add patch. (nss/fixed): Remove variable. Efraim Flashner 2019-12-11gnu: nss: Remove replacement package....The merge preceding this commit ignored the 'replacement' added to nss in commit 04b33ce205f38813b4dbd04b6ad3c7aa0be0b6f6, because the security fix is already present in NSS 3.48. This commit removes the remaining bits. * gnu/packages/patches/nss-CVE-2019-11745.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/nss.scm (nss/fixed): Remove variable. Marius Bakke 2019-12-11Merge branch 'master' into stagingMarius Bakke 2019-12-11gnu: nss: Fix CVE-2019-11745 via graft....* gnu/packages/patches/nss-CVE-2019-11745.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/nss.scm (nss/fixed): New variable. (nss)[replacement]: Add field. Mark H Weaver 2019-12-11gnu: nss: Update to 3.48....* gnu/packages/nss.scm (nss): Update to 3.48. Marius Bakke 2019-12-11gnu: nspr: Update to 4.24....* gnu/packages/nss.scm (nspr): Update to 4.24. Marius Bakke 2019-10-08gnu: nss, nss-certs: Update to 3.46.1....* gnu/packages/nss.scm (nss): Update to 3.46.1. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2019-10-08gnu: nspr: Update to 4.22....* gnu/packages/nss.scm (nspr): Update to 4.22. Marius Bakke 2019-08-06gnu: nss: Fix build failure on armhf-linux....Fixes <https://bugs.gnu.org/36930>. * gnu/packages/patches/nss-freebl-stubs.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/nss.scm (nss)[source](patches): Add it. Marius Bakke 2019-08-04gnu: nss, nss-certs: Update to 3.45....* gnu/packages/certs.scm (nss-certs): Update to 3.45. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-06-29gnu: nss, nss-certs: Update to 3.44.1....* gnu/packages/certs.scm (nss-certs): Update to 3.44.1. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-05-24gnu: nss, nss-certs: Update to 3.44....* gnu/packages/nss.scm (nss): Update to 3.44. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2019-04-08Merge branch 'master' into stagingMarius Bakke 2019-04-04gnu: Move nss & co. to nss.scm....* gnu/packages/gnuzilla.scm (nspr, nss): Move to... * gnu/packages/nss.scm: ... here. New file. * gnu/packages/chromium.scm, gnu/packages/disk.scm, gnu/packages/freedesktop.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/java.scm, gnu/packages/libreoffice.scm, gnu/packages/linux.scm, gnu/packages/mate.scm, gnu/packages/openldap.scm, gnu/packages/package-management.scm, gnu/packages/password-utils.scm, gnu/packages/polkit.scm, gnu/packages/qt.scm, gnu/packages/sssd.scm, gnu/packages/storage.scm, gnu/packages/vpn.scm, gnu/packages/web.scm, gnu/packages/xml.scm: Adjust accordingly. * gnu/local.mk (GNU_SYSTEM_MODULES): Add nss.scm. Ludovic Courtès