aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gv)
  #:use-module (gnu packages)
  #:use-module (gnu packages ghostscript)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public gv
  (package
   (name "gv")
   (version "3.7.4")
   (source (origin
            (method url-fetch)
            (uri (string-append "mirror://gnu/gv/gv-"
                                version ".tar.gz"))
            (sha256 (base32
                     "0q8s43z14vxm41pfa8s5h9kyyzk1fkwjhkiwbf2x70alm6rv6qi1"))))
   (build-system gnu-build-system)
   (arguments
    '(#:phases (modify-phases %standard-phases
                 (add-before 'configure 'set-gs-file-name
                   (lambda* (#:key inputs #:allow-other-keys)
                     ;; Set the value of 'GV.gsInterpreter' in the generated
                     ;; 'gv_system.ad' file.
                     (let ((gs (assoc-ref inputs "ghostscript")))
                       (with-fluids ((%default-port-encoding "ISO-8859-1"))
                        (substitute* "src/Makefile.in"
                          (("GV\\.gsInterpreter:([[:blank:]]+)gs" _ blank)
                           (string-append "GV.gsInterpreter:" blank
                                          gs "/bin/gs"))
                          (("GV\\.gsCmd([[:alpha:]]+):([[:blank:]]+)gs" _
                            command blank)
                           (string-append "GV.gsCmd" command ":"
                                          blank gs "/bin/gs"))))
                       #t))))))
   (inputs `(("ghostscript" ,ghostscript/x)
             ("libx11" ,libx11)
             ("libxaw3d" ,libxaw3d)
             ("libxinerama" ,libxinerama)
             ("libxpm" ,libxpm)
             ("zlib" ,zlib)))
   (native-inputs
     (list pkg-config))
   (synopsis "PostScript and PDF viewer using Ghostscript as a back-end")
   (description
    "GNU GV is a graphical user interface to the Ghostscript interpreter.
With it, one can view and navigate through PostScript and PDF documents in X
Windows.")
   (license license:gpl3+)
   (home-page "https://www.gnu.org/software/gv/")))
lass='msg-tooltip'>* gnu/packages/firmware.scm (fwupd)[inputs]: Add libsmbios conditionally. Change-Id: Id34135b180f5ee6e7abd2fd4eb10e0d3c6308e06 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Simon South 2024-01-07gnu: ovmf: Update to 202311....* gnu/packages/firmware.scm (ovmf): Update to 202311. Change-Id: I32b6d7587b37211b0de6a118024cb4f854ce112d Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Tomas Volf 2023-12-19gnu: ovmf: Set target to #f....* gnu/packages/firmware.scm (ovmf)[arguments]: Set target to #f. Change-Id: Iee1b731977f2731277d2e907ee2db2ad85af195f Efraim Flashner 2023-12-19gnu: Add ovmf-riscv64....* gnu/packages/firmware.scm (ovmf-riscv64): New variable. Change-Id: I483bc4496d7874cc0e9983de36cfc7a90ef7591c Efraim Flashner 2023-12-19gnu: ovmf: Build with newer gcc....* gnu/packages/firmware.scm (ovmf)[arguments]: Remove 'hide-implicit-gcc phase. [native-inputs]: Remove gcc-5. Change-Id: I2bcaea77019bb69214878713aa57cbef49c473db Efraim Flashner 2023-12-19gnu: ovmf-arm: Update to use GCC5....* gnu/packages/firmware.scm (ovmf-arm): Updating OVMF to 202308 requires GCC5, packages inheriting from ovmf also need to be updated. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I3a7b3f450e0da39129e7cffce7482b8e391e3858 spacecadet@purge.sh 2023-12-19gnu: ovmf-aarch64: Update to use GCC5....* gnu/packages/firmware.scm (ovmf-aarch64): Updating OVMF to 202308 requires GCC5, packages inheriting from ovmf also need to be updated. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: Iccd674f82c2f0160fa8097a09d10154be9736042 spacecadet@purge.sh 2023-12-19gnu: ovmf: Add OVMF_CODE and OVMF_VARS files....* gnu/packages/firmware.scm (ovmf)[arguments]: Add OVMF_CODE.fd and OVMF_VARS.fs to outputs as ovmf_code_arch.bin and ovmf_vars_arch.bin, respectively, for both ia32 and x64 architectures. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: Ie329f3f3515e7d015d9fbad01b8c2b82dc7da76e spacecadet@purge.sh 2023-12-19gnu: ovmf: Update to 202308....* gnu/packages/firmware.scm (ovmf): Update to 202308. [arguments]: Adjust phases to not hardcode gcc toolchain version. [native-inputs]: Remove python-2. Add perl, python-3. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I74a7bd26240821aacf35e5020d9687406e7da9ed spacecadet@purge.sh 2023-12-12gnu: make-crust-package: Don't run from avr....* gnu/packages/firmware.scm (make-crust-package)[arguments]: In make-flags don't create tools which can be run from avr. Change-Id: I118b4941889b884de1e491ace3818d878a887d7c Efraim Flashner 2023-12-11gnu: make-qmk-firmware: Use AVR target....* gnu/packages/firmware.scm (qmk)[inputs]: Remove AVR toolchain. [arguments]: Adjust phase wrapping output. (make-qmk-firmware/implementation)[arguments]: Add avr as target. Change-Id: Ibe09f6ef3c555052faf2c5c243303d85675866be Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Jean-Pierre De Jesus DIAZ 2023-12-11gnu: make-ergodox-firmware: Use AVR target....* gnu/packages/firmware.scm (make-ergodox-firmware/implementation): [arguments]: Add avr as target. [native-inputs]: Remove make-avr-toolchain. Change-Id: I4345a55d5dbd436d524de4886969b3332c6288a9 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Jean-Pierre De Jesus DIAZ 2023-10-31gnu: b43-tools: Use make-flags....* gnu/packages/firmware.scm (b43-tools)[arguments]: Add make-flags. Use make-flags in custom 'build and 'install phases. Remove trailing #t from phases. Change-Id: I8576351ecd571d191598943a2d143ab3e3e9da09 Efraim Flashner 2023-10-26gnu: fcode-utils: Fix cross-compilation....* gnu/packages/firmware.scm (fcode-utils) [arguments]: use STRIP-FOR-TARGET. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Zheng Junjie 2023-10-22gnu: make-opensbi-package: Set target to #false....* gnu/packages/firmware.scm (make-opensbi-package)[arguments]: Set target to #false. Efraim Flashner 2023-10-19gnu: openfwwf-firmware: Don't build for a specific target....* gnu/packages/firmware.scm (openfwwf-firmware)[arguments]: Set target to #f since we're building firmware files. Efraim Flashner 2023-10-19gnu: ath9k-htc-firmware: Don't build for a specific target....* gnu/packages/firmware.scm (ath9k-htc-firmware)[arguments]: Set target to #f since we're building firmware files. Efraim Flashner 2023-10-10gnu: Add ergodox-firmware-workman-p-kinesis-mod....* gnu/packages/firmware.scm (ergodox-firmware-workman-p-kinesis-mod): New variable. Maxim Cournoyer 2023-10-10gnu: Add ergodox-firmware-qwerty-kinesis-mod....* gnu/packages/firmware.scm (ergodox-firmware-qwerty-kinesis-mod): New variable. Maxim Cournoyer 2023-10-10gnu: Add ergodox-firmware-dvorak-kinesis-mod....* gnu/packages/firmware.scm (ergodox-firmware-dvorak-kinesis-mod): New variable. Maxim Cournoyer 2023-10-10gnu: Add ergodox-firmware-colemak-symbol-mod....* gnu/packages/firmware.scm (ergodox-firmware-colemak-symbol-mod): New variable. Maxim Cournoyer 2023-10-10gnu: Add ergodox-firmware-colemak-jc-mod....* gnu/packages/firmware.scm (make-ergodox-firmware): New procedure (ergodox-firmware-colemak-jc-mod): New variable. * gnu/packages/patches/ergodox-firmware-fix-json-target.patch: New file. * gnu/packages/patches/ergodox-firmware-fix-numpad.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. Maxim Cournoyer 2023-10-10gnu: Add qmk-firmware-ergodox-ez-dvorak-emacs-software....* gnu/packages/firmware.scm (qmk-firmware-ergodox-ez-dvorak-emacs-software): New variable. Maxim Cournoyer 2023-10-10gnu: Add qmk-firmware-ergodox-ez-dvorak-emacs....* gnu/packages/firmware.scm (qmk-firmware-ergodox-ez-dvorak-emacs): New variable. Maxim Cournoyer 2023-10-10gnu: Add qmk-firmware-ergodox-ez-dvorak....* gnu/packages/firmware.scm (qmk-firmware-ergodox-ez-dvorak): New variable. Maxim Cournoyer 2023-10-10gnu: Add qmk-firmware-ergodox-ez-hacker-dvorak....* gnu/packages/firmware.scm (qmk-firmware-ergodox-ez-hacker-dvorak): New variable. * gnu/packages/patches/qmk-firmware-fix-hacker-dvorak.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Maxim Cournoyer 2023-10-10gnu: Add qmk-udev-rules....* gnu/packages/firmware.scm (qmk-udev-rules): New variable. Maxim Cournoyer 2023-10-10gnu: Add qmk-firmware-ergodox-ez-dvorak-42-key....* gnu/packages/firmware.scm (qmk-firmware-ergodox-ez-dvorak-42-key): New variable. Maxim Cournoyer 2023-10-10gnu: Add qmk-firmware-ergodox-ez-default....* gnu/packages/firmware.scm (make-qmk-firmware/implementation) (make-qmk-firmware): New procedures. (qmk-firmware-ergodox-ez-default): New variable. Series-changes: 2 - Install firmware from root directory, not .build - Also honor .bin and .uf2 firmware file extensions Maxim Cournoyer 2023-10-10gnu: qmk: Add many missing inputs and add more commands to PATH....* gnu/packages/firmware.scm (qmk) [inputs]: Add bash-minimal, dfu-util, diffutils, gawk, gnu-make, grep and python. [arguments]: Add them to PATH in the wrapper in the wrap-path phase. Also capture avr-ar in the PATH. Add CROSS_C_INCLUDE_PATH and CROSS_LIBRARY_PATH to the wrapper. Maxim Cournoyer 2023-10-10gnu: qmk: Use GCC 8 for the AVR toolchain....* gnu/packages/firmware.scm (qmk) [inputs]: Specify 'gcc-8' as the #:xgcc argument to the 'make-avr-toolchain' procedure. Maxim Cournoyer 2023-10-10gnu: qmk: Avoid propagating inputs....* gnu/packages/firmware.scm (qmk): [arguments]: New modules and phases arguments. [propagated-inputs]: Turn into... [inputs]: ... this. Add coreutils-minimal, sed and util-linux. [description]: Expound. Maxim Cournoyer 2023-10-10gnu: qmk: Style....* gnu/packages/firmware.scm (qmk): Apply 'guix style' changes. Maxim Cournoyer 2023-09-25gnu: edk2-tools: Update to 202308....* gnu/packages/firmware.scm (edk2-tools): Update to 202308. [arguments] <make-flags>: Add CC. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Maxim Cournoyer 2023-09-17gnu: Remove extraneous imports....Found by running 'guild compile -W3 gnu/packages/$module.scm', using guild from the upcoming Guile. * gnu/packages/admin.scm: Remove extraneous imports. * gnu/packages/avr.scm: Likewise. * gnu/packages/base.scm: Likewise. * gnu/packages/bootloaders.scm: Likewise. * gnu/packages/firmware.scm: Likewise. * gnu/packages/linphone.scm: Likewise. * gnu/packages/telephony.scm: Likewise. * gnu/packages/cran.scm: Likewise. * gnu/packages/kde.scm: Likewise. * gnu/packages/libcanberra.scm: Likewise. * gnu/packages/libreoffice.scm: Likewise. * gnu/packages/mes.scm: Likewise. * gnu/packages/mingw.scm: Likewise. * gnu/packages/serialization.scm: Likewise. * gnu/packages/sync.scm: Likewise. * gnu/packages/syncthing.scm: Likewise. * gnu/packages/terminals.scm: Likewise. * gnu/packages/version-control.scm: Likewise. * gnu/packages/video.scm: Likewise. * gnu/packages/wm.scm: Likewise. * gnu/packages/emulators.scm: Likewise. Reviewed-by: Ludovic Courtès <ludo@gnu.org> Maxim Cournoyer 2023-08-29gnu: Add qmk....* gnu/packages/firmware.scm (qmk): New variable. Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> Signed-off-by: Vagrant Cascadian <vagrant@debian.org> Jean-Pierre De Jesus DIAZ