aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gsasl)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages libidn)
  #:use-module (gnu packages gnupg)
  #:use-module (gnu packages nettle)
  #:use-module (gnu packages kerberos)
  #:use-module (gnu packages tls)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libntlm
  (package
    (name "libntlm")
    (version "1.6")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.nongnu.org/libntlm/releases/"
                                  "libntlm-" version ".tar.gz"))
              (sha256
               (base32
                "08b83nss16jsn213j326yhn1vnrz10k15fwq6jm5b1vdn23nndzj"))))
    (build-system gnu-build-system)
    (synopsis "Library that implements NTLM authentication")
    (description
     "Libntlm is a library that implements NTLM authentication.")
    (license license:lgpl2.1+)
    (home-page "https://www.nongnu.org/libntlm/")))

(define-public gss
  (package
   (name "gss")
   (version "1.0.4")
   (source (origin
            (method url-fetch)
            (uri (string-append "mirror://gnu/gss/gss-" version
                                ".tar.gz"))
            (sha256 (base32
                     "0www841ax21f5f61pdjk9fjdn9s2xf1wnblb47kzrqyaykgapkpc"))))
   (build-system gnu-build-system)
   (inputs (list nettle shishi zlib))
   (synopsis "Generic Security Service library")
   (description
    "The GNU Generic Security Service provides a free implementation of the
GSS-API specification.  It provides a generic application programming
interface for programs to access security services.  Security services present
a generic, GSS interface, with which the calling application interacts via
this library, freeing the application developer from needing to know about
the underlying security implementation.")
   (license license:gpl3+)
   (home-page "https://www.gnu.org/software/gss/")))

(define-public gsasl
  (package
   (name "gsasl")
   (version "2.2.0")
   (source (origin
            (method url-fetch)
            (uri (string-append "mirror://gnu/gsasl/gsasl-" version
                                ".tar.gz"))
            (sha256
             (base32
              "0nbp62isfdfrsnp34vfkwinfjyw9x05clacvsn2c8vcpp7inif3r"))))
   (build-system gnu-build-system)
   (arguments
    `(#:configure-flags '("--with-gssapi-impl=mit"
                          "--disable-static")))
   (inputs
    (list libgcrypt libidn libntlm mit-krb5 zlib))
   (native-inputs
    (list ;; Needed for cross compiling.
          libgcrypt))
   (propagated-inputs
    ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
    ;; propagated input of GnuTLS.
    (list gnutls))
   (synopsis "Simple Authentication and Security Layer library")
   (description
    "GNU SASL is an implementation of the Simple Authentication and
Security Layer framework.  On network servers such as IMAP or SMTP servers,
SASL is used to handle client/server authentication.  This package contains
both a library and a command-line tool to access the library.")
   (license license:gpl3+)
   (home-page "https://www.gnu.org/software/gsasl/")))
an title='2021-11-30 01:08:55 +0100'>2021-11-30services: Accept <inferior-package>s in lieu of <package>s....Tobias Geerinckx-Rice 2021-11-15gnu: hpcguix-web: Update to 0.2.0....Ludovic Courtès 2021-09-25gnu: Consolidate duplicate copyright names....Greg Hogan 2021-07-23gnu: hpcguix-web: Update to 0.1.0....Ludovic Courtès 2021-04-01gnu: services: web: Have fcgiwrap log to a file....Christopher Baines 2021-04-01gnu: services: web: Cleanup whitespace....Christopher Baines 2021-02-15services: Add Agate Gemini service....Alexandru-Sergiu Marton 2021-01-17gnu: php-fpm: Ensure no duplicate group....Julien Lepiller 2020-11-14services: gmnisrv: Export procedures and service type....Alexandru-Sergiu Marton 2020-11-09services: nginx: Re-introduce server-names-hash-bucket-size....Julien Lepiller 2020-10-27services: Add gmnisrv web service....Alexandru-Sergiu Marton 2020-10-27services: hpcguix-web: Set 'XDG_CACHE_HOME' to a writable directory....Ludovic Courtès 2020-10-14services: nginx: Add lua module....Oleg Pykhalov 2020-10-14services: nginx: Fix typo in exported symbol....Lulu 2020-09-10services: php-fpm: Add 'php-ini-file' configuration....Jelle Licht 2020-08-26services: fcgiwrap: Create parent directory for unix socket....Arun Isaac 2020-07-12services: web: Do not export record type descriptors....Ludovic Courtès 2020-07-12services: mumi: Run in a UTF-8 locale....Ludovic Courtès 2020-06-25services: Add missing (ice-9 format) import....Ludovic Courtès 2020-05-13mailmap: Update entries for Nikita....nikita 2020-04-08services/web: Fix ordering of default-nginx-config....Florian Pelz 2020-04-06services/web: Add missing ungexp for mumi shepherd services....Ricardo Wurmus 2020-04-06services/web: Add default values to all mumi-configuration fields....Ricardo Wurmus 2020-04-06gnu: mumi: Update to 0.0.0-12.bb2fe92....Ricardo Wurmus 2020-03-16services/web: Export nginx-configuration-global-directives....Ricardo Wurmus 2020-03-16services: nginx: Fix broken default configuration....Tobias Geerinckx-Rice 2020-03-15services/web: nginx-configuration: Add support for global directives....Ricardo Wurmus 2020-03-15services/web: Remove empty events directive from default-nginx-config....Ricardo Wurmus 2020-03-12services: mumi-service-type: Update to latest version of mumi....Ricardo Wurmus 2020-02-09services: web: Use the Patchwork default-from-email....Christopher Baines 2019-12-21services: Add Mumi service....Ludovic Courtès 2019-11-28services: nginx: Add description....Ludovic Courtès