aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gsasl)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages libidn)
  #:use-module (gnu packages gnupg)
  #:use-module (gnu packages nettle)
  #:use-module (gnu packages kerberos)
  #:use-module (gnu packages tls)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libntlm
  (package
    (name "libntlm")
    (version "1.6")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.nongnu.org/libntlm/releases/"
                                  "libntlm-" version ".tar.gz"))
              (sha256
               (base32
                "08b83nss16jsn213j326yhn1vnrz10k15fwq6jm5b1vdn23nndzj"))))
    (build-system gnu-build-system)
    (synopsis "Library that implements NTLM authentication")
    (description
     "Libntlm is a library that implements NTLM authentication.")
    (license license:lgpl2.1+)
    (home-page "https://www.nongnu.org/libntlm/")))

(define-public gss
  (package
   (name "gss")
   (version "1.0.4")
   (source (origin
            (method url-fetch)
            (uri (string-append "mirror://gnu/gss/gss-" version
                                ".tar.gz"))
            (sha256 (base32
                     "0www841ax21f5f61pdjk9fjdn9s2xf1wnblb47kzrqyaykgapkpc"))))
   (build-system gnu-build-system)
   (inputs (list nettle shishi zlib))
   (synopsis "Generic Security Service library")
   (description
    "The GNU Generic Security Service provides a free implementation of the
GSS-API specification.  It provides a generic application programming
interface for programs to access security services.  Security services present
a generic, GSS interface, with which the calling application interacts via
this library, freeing the application developer from needing to know about
the underlying security implementation.")
   (license license:gpl3+)
   (home-page "https://www.gnu.org/software/gss/")))

(define-public gsasl
  (package
   (name "gsasl")
   (version "2.2.0")
   (source (origin
            (method url-fetch)
            (uri (string-append "mirror://gnu/gsasl/gsasl-" version
                                ".tar.gz"))
            (sha256
             (base32
              "0nbp62isfdfrsnp34vfkwinfjyw9x05clacvsn2c8vcpp7inif3r"))))
   (build-system gnu-build-system)
   (arguments
    `(#:configure-flags '("--with-gssapi-impl=mit"
                          "--disable-static")))
   (inputs
    (list libgcrypt libidn libntlm mit-krb5 zlib))
   (native-inputs
    (list ;; Needed for cross compiling.
          libgcrypt))
   (propagated-inputs
    ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
    ;; propagated input of GnuTLS.
    (list gnutls))
   (synopsis "Simple Authentication and Security Layer library")
   (description
    "GNU SASL is an implementation of the Simple Authentication and
Security Layer framework.  On network servers such as IMAP or SMTP servers,
SASL is used to handle client/server authentication.  This package contains
both a library and a command-line tool to access the library.")
   (license license:gpl3+)
   (home-page "https://www.gnu.org/software/gsasl/")))
>* gnu/packages/embedded.scm (stlink): Update to 1.7.0. [home-page]: Update it. Mathieu Othacehe 2021-12-16gnu: openocd: Explicitly enable all the programmers....* gnu/packages/embedded.scm (openocd)[arguments]<#:configure-flags>: Add "enable" flags for rshim, ft232r, xds110, cmsis-dap-v2, nulink, kitprog, jtag_dpi, bcm2835gpio, imx_gpio, ep93xx, at91rm9200, sysfsgpio, xlnx-pcie-xvc. Danny Milosavljevic 2021-12-16gnu: openocd: Make build reproducible....* gnu/packages/embedded.scm (openocd)[arguments]<#:phases>[bootstrap]: Make build reproducible. Danny Milosavljevic 2021-12-16gnu: openocd: Update to 0.11.0....* gnu/packages/embedded.scm (openocd): Update to 0.11.0. Danny Milosavljevic 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-23gnu: Add stcgal....* gnu/packages/embedded.scm (stcgal): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Simon South 2021-07-13gnu: openocd: Build and install info manual....* gnu/packages/embedded.scm (openocd)[native-inputs]: Add texinfo. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Morgan Smith 2021-05-18gnu: fc-host-tools: Make installation path patcher more self-maintaining....* gnu/packages/embedded.scm (fc-host-tools)[arguments]<#:phases> [patch-installation-paths]: Make phase more self-maintaining. Danny Milosavljevic 2021-05-18gnu: fc-host-tools: Update to 15....* gnu/packages/embedded.scm (fc-host-tools): Update to 15. [description]: Add fc-simint. [arguments]<#:phases>[patch-installation-paths]: Add files. Danny Milosavljevic 2021-05-14gnu: sdcc: Build sdcdb debugger....* gnu/packages/embedded.scm (sdcc)[arguments]<phases>: Add sdcc-misc target. Jelle Licht 2021-05-14gnu: ucsim: Update to 0.6-pre68....* gnu/packages/embedded.scm (ucsim): Update to 0.6-pre68. Jelle Licht 2021-04-12gnu: newlib-nano: Fix nano lib and header paths....* gnu/packages/embedded.scm (newlib-nano-arm-none-eabi)[arguments]: Hard link library files from *.a to *_nano.a. Hard link newlib.h to a common location. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Morgan Smith 2021-04-08gnu: gcc-arm-none-eabi: Fix C++ header location....Previously the C++ headers where installed in the include folder, overwriting some C headers. * gnu/packages/embedded.scm (gcc-arm-none-eabi-4.9) [native-search-paths]: Add C++ header locations. (gcc-arm-none-eabi-7-2018-q2-update)[native-search-paths]: Add C++ header locations. (make-libstdc++-arm-none-eabi)[arguments]: Change C++ header install location to include/c++. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Morgan Smith 2021-03-10gnu: sdcc: Update to 4.1.0....* gnu/packages/embedded.scm (sdcc): Update to 4.1.0. * gnu/packages/patches/sdcc-disable-non-free-code.patch: Update to match new version. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Simon South