aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019, 2020, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gpodder)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system cmake)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system python)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages base)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages check)
  #:use-module (gnu packages curl)
  #:use-module (gnu packages freedesktop)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages groff)
  #:use-module (gnu packages mp3)
  #:use-module (gnu packages music)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python-web)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages video)
  #:use-module (gnu packages xml))

(define-public gpodder
  (package
    (name "gpodder")
    (version "3.11.4")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/gpodder/gpodder")
             (commit version)))
       (sha256
        (base32 "1zmp7kkldb59fx1y6k4mkff8ngmyb9pflcd3yqb28m9wb9bp4j4h"))
       (file-name (git-file-name name version))
       (patches (search-patches "gpodder-disable-updater.patch"))))
    (build-system python-build-system)
    (native-inputs
     (list intltool
           python-coverage
           python-minimock
           python-pytest
           python-pytest-cov
           python-pytest-httpserver
           which))
    (inputs
     (list bash-minimal
           gtk+
           python-pygobject
           python-pycairo
           python-requests
           python-dbus
           python-html5lib
           python-mutagen
           python-mygpoclient
           python-podcastparser
           yt-dlp
           xdg-utils))
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          ;; Avoid needing xdg-utils as a propagated input.
          (add-after 'unpack 'patch-xdg-open
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "src/gpodder/util.py"
                (("xdg-open") (search-input-file inputs "bin/xdg-open")))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
                (invoke "make" "unittest"))))
          ;; 'msgmerge' introduces non-determinism by resetting the
          ;; POT-Creation-Date in .po files.
          (add-before 'install 'do-not-run-msgmerge
            (lambda _
              (substitute* "makefile"
                (("msgmerge") "true"))))
          (add-before 'install 'make-po-files-writable
            (lambda _
              (for-each
               (lambda (f)
                 (chmod f #o664))
               (find-files "po"))))
          (replace 'install
            (lambda _
              (setenv "PREFIX" #$output)
              (invoke "make" "install")))
          (add-after 'install 'wrap-gpodder
            (lambda _
              (let ((gi-typelib-path (getenv "GI_TYPELIB_PATH")))
                (wrap-program (string-append #$output "/bin/gpodder")
                  `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))))))
    (home-page "https://gpodder.github.io")
    (synopsis "Simple podcast client")
    (description "gPodder is a podcatcher, i.e. an application that allows
podcast feeds (RSS, Atom, Youtube, Soundcloud, Vimeo and XSPF) to be
subscribed to, checks for new episodes and allows the podcast to be saved
locally for later listening.")
    (license license:gpl3+)))

(define-public libmygpo-qt
  (package
    (name "libmygpo-qt")
    (version "1.1.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "http://stefan.derkits.at/files/"
                                  "libmygpo-qt/libmygpo-qt." version ".tar.gz"))
              (sha256
               (base32
                "1kg18qrq2rsswgzhl65r3mlyx7kpqg4wwnbp4yiv6svvmadmlxl2"))
              (patches (search-patches "libmygpo-qt-fix-qt-5.11.patch"
                                       "libmygpo-qt-missing-qt5-modules.patch"))))
    (build-system cmake-build-system)
    (native-inputs
     (list pkg-config))
    (inputs
     (list qtbase-5))
    (arguments
     '(#:configure-flags '("-DMYGPO_BUILD_TESTS=ON")
       ;; TODO: Enable tests when https://github.com/gpodder/gpodder/issues/446
       ;; is fixed.
       #:tests? #f))
    (home-page "https://gpodder.github.io")
    (synopsis "Qt/C++ library wrapping the gpodder web service")
    (description "@code{libmygpo-qt} is a Qt/C++ library wrapping the
@url{https://gpodder.net} APIs.  It allows applications to discover, manage
and track podcasts.")
    (license license:lgpl2.1+)))

(define-public python-mygpoclient
  (package
    (name "python-mygpoclient")
    (version "1.9")
    (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "mygpoclient" version))
       (sha256
        (base32
         "05hmjdb73m7vl6lzvh58bnliy4227pv8hprwfka0bg19cnvgpyf5"))))
    (build-system python-build-system)
    (native-inputs
     (list python-coverage python-minimock python-nose python-pytest))
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (replace 'check
           (lambda _
             (invoke "make" "test"))))))
    (home-page "https://mygpoclient.readthedocs.io")
    (synopsis "Python library for the gPodder web service")
    (description "@code{mygpoclient} provides an easy and structured way to
access the @url{https://gpodder.net} web services.  In addition to
subscription list synchronization and storage, the API supports uploading and
downloading episode status changes.")
    (license license:gpl3+)))

(define-public python-podcastparser
  (package
    (name "python-podcastparser")
    (version "0.6.10")
    (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "podcastparser" version))
       (sha256
        (base32 "1mqkkxz928y430xx3mgw9dj78ilkgv9hjdha1hizbks6mmhcp6ib"))))
    (native-inputs
     (list python-pytest))
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (replace 'check
           (lambda _ (invoke "pytest"))))))
    (build-system python-build-system)
    (home-page "http://gpodder.org/podcastparser")
    (synopsis "Simplified and fast RSS parser Python library")
    (description "@code{podcastparser} is a library for the gPodder project to
provide an easy and reliable way of parsing RSS and Atom-based podcast feeds
in Python.")
    (license license:isc)))

(define-public castget
  ;; Since ronn-ng uses a newer ruby-nokogiri, the test suite would fail on a
  ;; free call with the error: "free(): invalid pointer".  Use the latest
  ;; commit, which is immune to that problem.
  (let ((revision "0")
        (commit "da9727de1b9e4e636be21bf07c73eb41f5d8439b"))
    (package
      (name "castget")
      (version (git-version "2.0.0" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "https://github.com/mlj/castget")
               (commit commit)))
         (sha256
          (base32 "0d5ji21af5mfj1xa90v4hp104c1ipy076175kp7nzz1c4sxdadff"))
         (file-name (git-file-name name version))))
      (build-system gnu-build-system)
      (native-inputs
       (list autoconf automake libtool pkg-config ronn-ng))
      (inputs (list curl glib taglib libxml2))
      (synopsis "Command line podcast downloader")
      (description
       "castget is a simple, command-line based RSS enclosure downloader.  It is
primarily intended for automatic, unattended downloading of podcasts.  It uses
libcurl for the download process.")
      (license license:lgpl2.1+)
      (home-page "https://castget.johndal.com"))))
2020-05-23 21:19:13 +0200'>2020-05-23gnu: icedove: Add a desktop file....* gnu/packages/gnuzilla.scm (icedove)[phases]: Add install-desktop-file phase. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Jonathan Brielmaier 2020-05-08Merge branch 'core-updates'Marius Bakke 2020-05-07gnu: Add icedove....* gnu/packages/gnuzilla.scm (%icedove-build-id, icedove): New variables. Co-authored-by: Nikita <nikita@n0.is> Co-authored-by: Adrian Malacoda <malacoda@monarch-pass.net> Co-authored-by: Ricardo Wurmus <rekado@elephly.net> Jonathan Brielmaier 2020-05-06Merge branch 'master' into core-updatesMarius Bakke 2020-05-06gnu: icecat: Update to 68.8.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2020-6831, CVE-2020-12387, CVE-2020-12388, CVE-2020-12389, CVE-2020-12392, CVE-2020-12393, and CVE-2020-12395. * gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. Apply icecat-use-older-reveal-hidden-html.patch. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to new version. * gnu/packages/patches/icecat-use-older-reveal-hidden-html.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Mark H Weaver 2020-04-15Merge branch 'master' into core-updatesMarius Bakke 2020-04-15gnu: IceCat: Build with the latest libvpx....* gnu/packages/gnuzilla.scm (icecat)[inputs]: Change from LIBVPX-1.7 to LIBVPX. Marius Bakke 2020-04-08Merge branch 'master' into core-updates... Conflicts: etc/news.scm gnu/local.mk gnu/packages/check.scm gnu/packages/cross-base.scm gnu/packages/gimp.scm gnu/packages/java.scm gnu/packages/mail.scm gnu/packages/sdl.scm gnu/packages/texinfo.scm gnu/packages/tls.scm gnu/packages/version-control.scm Marius Bakke 2020-04-07gnu: icecat: Update to 68.7.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2020-6821, CVE-2020-6822, CVE-2020-6825, CVE-2020-6827, and CVE-2020-6828. * gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to new version. Mark H Weaver 2020-04-03gnu: icecat: Update to 68.6.1-guix0-preview1 [security fixes]....Includes fixes for CVE-2020-6819 and CVE-2020-6820. * gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to new version. Mark H Weaver 2020-04-03gnu: IceCat: Remove obsolete phase....* gnu/packages/gnuzilla.scm (icecat)[arguments]: Remove phase 'augment-CPLUS_INCLUDE_PATH'. Marius Bakke 2020-03-29gnu: Remove more packages deprecated for over almost a year....* gnu/packages/games.scm (armagetron-advanced) (cataclysm-dark-days-ahead, gnubackgammon, l-abbaye-des-morts) (the-battle-for-wesnoth, the-battle-for-wesnoth-server) (project-starfighter, kiki-the-nano-bot, fish-fillets-ng) (dungeon-crawl-stone-soup): Let's forget this ever happened. * gnu/packages/emacs-xyz.scm (geiser, paredit, git-modes/old-name) (magit, magit-svn, haskell-mode, emacs-emms-player-mpv, bbdb) (ert-runner, groovy-emacs-modes): Remove variable. * gnu/packages/engineering.scm (emacs-emms-player-simple-mpv) (emacs-evil-ediff, emacs-evil-mu4e, emacs-wgrep-helm, ao): Likewise. * gnu/packages/finance.scm (monero-core): Likewise. * gnu/packages/gnome.scm (dungeon-crawl-stone-soup-tiles) (tales-of-maj-eyal, battle-tanks, the-legend-of-edgar) (gnome-tweak-tool): Likewise. * gnu/packages/gnuzilla.scm (conkeror): Likewise. * gnu/packages/guile-xyz.scm (mcron2): Likewise. * gnu/packages/image.scm (pngcrunch): Likewise. * gnu/packages/linux.scm (eudev-with-hwdb): Likewise. * gnu/packages/maths.scm (qtoctave): Likewise. * gnu/packages/package-management.scm (guile2.0-guix): Likewise. * gnu/packages/php.scm (php-with-bcmath): Likewise. * gnu/packages/python-xyz.scm (python-kivy-next, python2-kivy-next): Likewise. * gnu/packages/video.scm (livestreamer): Likewise. * gnu/packages/virtualization.scm (lookingglass): Likewise. * gnu/packages/vulkan.scm (vulkan-icd-loader): Likewise. * gnu/packages/syndication.scm (newsbeuter): Likewise. (newsboat)[description]: Remove historical footnote. Tobias Geerinckx-Rice 2020-03-10gnu: icecat: Update to 68.6.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2019-20503, CVE-2020-6805, CVE-2020-6806, CVE-2020-6807, CVE-2020-6811, CVE-2020-6812, and CVE-2020-6814. * gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to new version. Mark H Weaver 2020-03-01gnu: mozjs@17, mozjs@24: Fix build....* gnu/packages/gnuzilla.scm (mozjs): Add ‘-fpermissive’ to CXXFLAGS. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Damien Cassou 2020-02-26gnu: icecat: Remove about:buildconfig store references....* gnu/packages/gnuzilla.scm (icecat)[arguments]: New ‘neutralise-store-references’ phase. Co-authored-by: Tobias Geerinckx-Rice <me@tobias.gr> Jakub Kądziołka 2020-02-11gnu: icecat: Update to 68.5.0-guix0-preview1....* gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to new version. Mark H Weaver 2020-01-18gnu: Add firefox-decrypt....* gnu/packages/gnuzilla.scm (firefox-decrypt): New variable. Oleg Pykhalov 2020-01-16gnu: icecat: Fix support for ffmpeg codecs....Fixes <https://bugs.gnu.org/38045>. Thanks to Jakub Kądziołka <kuba@kadziolka.net> and Amin Bandali <bandali@gnu.org> for their helpful observations and suggestions. This is a followup to commit 8e5567195f5d29301d571612085b5afdb460619d. * gnu/packages/gnuzilla.scm (icecat)[inputs]: Add shared-mime-info. [arguments]: Add elf and binary I/O modules to #:modules. Add code to the 'fix-ffmpeg-runtime-linker' phase that sets the sandbox read-path whitelist to include libavcodec's RUNPATH, as well as shared-mime-info. Mark H Weaver 2020-01-09gnu: icecat: Update to 68.4.1-guix0-preview1 [fixes CVE-2019-17026]....* gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update hash of upstream firefox source tarball, 'upstream-icecat-base-version', and commit and hash of gnuzilla checkout. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to upstream changes. Mark H Weaver 2020-01-07gnu: icecat: Update to 68.4.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2019-17015, CVE-2019-17016, CVE-2019-17017, CVE-2019-17021, CVE-2019-17022, and CVE-2019-17024. * gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update hash of upstream firefox source tarball, 'upstream-icecat-base-version', and commit and hash of gnuzilla checkout. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to upstream changes. Mark H Weaver 2020-01-02gnu: rust-cbindgen: Move to rust-apps.scm...* gnu/packages/rust-cbindgen.scm (rust-cbindgen): Move to ... * gnu/packages/rust-apps.scm: ... here. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove it. Efraim Flashner 2019-12-23gnu: icecat: Fix linking with ffmpeg....* gnu/packages/gnuzilla.scm (icecat)[arguments]: Add 'fix-ffmpeg-runtime-linker' phase. Co-authored-by: Mark H Weaver <mhw@netris.org>. Julien Lepiller 2019-12-04Merge branch 'staging'Marius Bakke 2019-12-04gnu: icecat: Update to 68.3.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2019-11745, CVE-2019-17005, CVE-2019-17008, CVE-2019-17009, CVE-2019-17010, CVE-2019-17011, and CVE-2019-17012. * gnu/packages/patches/icecat-gnuzilla-fixes.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update hash for the firefox source tarball. Update to the latest from gnuzilla.git. Don't apply icecat-gnuzilla-fixes.patch. Remove determinism fix in makeicecat that is now upstream. Tweak a status message. (icecat)[arguments]: Add "--with-unsigned-addon-scopes=app" configure flag. * gnu/packages/patches/icecat-makeicecat.patch: Adapt. Mark H Weaver 2019-11-15Merge branch 'master' into stagingMarius Bakke