aboutsummaryrefslogtreecommitdiff
# This l
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2017 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gperf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public gperf
  (package
    (name "gperf")
    (version "3.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/gperf/gperf-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq"))))
    (build-system gnu-build-system)
    (arguments '(#:parallel-tests? #f))
    (home-page "https://www.gnu.org/software/gperf/")
    (synopsis "Perfect hash function generator")
    (description
     "gperf is a perfect hash function generator.  For a given list of
strings, it produces a hash function and hash table in C or C++ code.  That
the hash function is perfect means that no collisions can exist and that
look-ups can be made by single string comparisons.")
    (license gpl3+)))

(define-public gperf-3.0
  ;; This older version would use 'unsigned int' in its generated lookup
  ;; functions whereas 3.1 uses 'size_t', which causes breakage such as
  ;; <https://github.com/wingo/elogind/issues/8>.
  (package
    (inherit gperf)
    (version "3.0.4")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gperf/gperf-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn"))))))
iliana Marie Prikler <liliana.prikler@gmail.com> Leo Prikler <leo.prikler@student.tugraz.at> Ludovic Courtès <ludo@gnu.org> <ludovic.courtes@inria.fr> Marek Benc <dusxmt@gmx.com> <merkur32@gmail.com> Marius Bakke <marius@gnu.org> <mbakke@fastmail.com> Marius Bakke <marius@gnu.org> <m.bakke@warwick.ac.uk> Marius Bakke <marius@gnu.org> <marius.bakke@usit.uio.no> Marius Bakke <marius@gnu.org> <mbakke@berlin.guixsd.org> Mathieu Lirzin <mthl@gnu.org> <mthl@openmailbox.org> Mathieu Lirzin <mthl@gnu.org> <mathieu.lirzin@openmailbox.org> Mathieu Othacehe <m.othacehe@gmail.com> Mathieu Othacehe <mathieu.othacehe@parrot.com> Mathieu Othacehe <othacehe@gnu.org> Matthew James Kraai <kraai@ftbfs.org> Nikita Karetnikov <nikita@karetnikov.org> <nikita.karetnikov@gmail.com> nikita <nikita@n0.is> nikita <nikita@n0.is> ng0 <ng0@n0.is> nikita <nikita@n0.is> Nils Gillmann <ng0@n0.is> nikita <nikita@n0.is> Nils Gillmann <gillmann@infotropique.org> nikita <nikita@n0.is> ng0 <ng0@crash.cx> nikita <nikita@n0.is> <ng0@infotropique.org> nikita <nikita@n0.is> <ng0@no-reply.infotropique.org> nikita <nikita@n0.is> <ng0@no-reply.pragmatique.xyz> nikita <nikita@n0.is> <ng0@pragmatique.xyz> nikita <nikita@n0.is> <contact.ng0@cryptolab.net> nikita <nikita@n0.is> <ng0@we.make.ritual.n0.is> nikita <nikita@n0.is> <ngillmann@runbox.com> nikita <nikita@n0.is> <niasterisk@grrlz.net> nikita <nikita@n0.is> <ng@niasterisk.space> nikita <nikita@n0.is> <ng0@libertad.pw> Pierre Neidhardt <mail@ambrevar.xyz> Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr> Pjotr Prins <pjotr.guix@thebird.nl> <pjotr.public01@thebird.nl> Pjotr Prins <pjotr.guix@thebird.nl> <pjotr.public12@thebird.nl> Pjotr Prins <pjotr.guix@thebird.nl> <pjotr.public12@email> Raimon Grau <raimonster@gmail.com> <raimon@3scale.net> Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com> Raymond Nicholson <rain1@openmailbox.org> Rene Saavedra <rennes@openmailbox.org> Ricardo Wurmus <rekado@elephly.net> Ricardo Wurmus <rekado@elephly.net> <ricardo.wurmus@mdc-berlin.de> Sou Bunnbu (宋文武) <iyzsong@gmail.com> Sou Bunnbu (宋文武) <iyzsong@gmail.com> <iyzsong@member.fsf.org> Stefan Reichör <stefan@xsteve.at> Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com> Theodoros Foradis <theodoros.for@openmailbox.org> <theodoros@foradis.org> Thomas Danckaert <thomas.danckaert@gmail.com> <post@thomasdanckaert.be> Tobias Geerinckx-Rice <me@tobias.gr> <tobias.geerinckx.rice@gmail.com> Tomas Volf <~@wolfsden.cz> <wolf@wolfsden.cz> Tomáš Čech <sleep_walker@gnu.org> <sleep_walker@suse.cz> Vincent Legoll <vincent.legoll@gmail.com> <vincent.legoll@idgrilles.fr> Zheng Junjie <873216071@qq.com> Z572 <873216071@qq.com>