aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2017 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gperf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public gperf
  (package
    (name "gperf")
    (version "3.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/gperf/gperf-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq"))))
    (build-system gnu-build-system)
    (arguments '(#:parallel-tests? #f))
    (home-page "https://www.gnu.org/software/gperf/")
    (synopsis "Perfect hash function generator")
    (description
     "gperf is a perfect hash function generator.  For a given list of
strings, it produces a hash function and hash table in C or C++ code.  That
the hash function is perfect means that no collisions can exist and that
look-ups can be made by single string comparisons.")
    (license gpl3+)))

(define-public gperf-3.0
  ;; This older version would use 'unsigned int' in its generated lookup
  ;; functions whereas 3.1 uses 'size_t', which causes breakage such as
  ;; <https://github.com/wingo/elogind/issues/8>.
  (package
    (inherit gperf)
    (version "3.0.4")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gperf/gperf-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn"))))))
"vm: Use virtio network driver."...Marius Bakke 2020-06-09system: vm: Add missing imported module....Royce Strange 2020-06-08hurd-boot: Further cleanup of "rc"....Jan (janneke) Nieuwenhuizen 2020-06-06vm: Shared-store script runs the native QEMU and Bash....Ludovic Courtès 2020-06-06vm: <virtual-machine> compiler honors system and target....Ludovic Courtès 2020-06-06vm: 'qemu-image' preserves the cross-compilation target of the OS....Ludovic Courtès 2020-06-06vm: 'qemu-image' uses the native partitioning tools and bootloader....Ludovic Courtès 2020-06-06vm: 'expression->derivation-in-linux-vm' always returns a native build....Ludovic Courtès 2020-05-16vm: Use 'let-system'....Ludovic Courtès 2020-05-08Merge branch 'core-updates'Marius Bakke 2020-05-07guix system: 'docker-image' honors '--network'....Ludovic Courtès 2020-05-05Merge branch 'master' into core-updatesMarius Bakke 2020-05-05vm: Remove obsolete procedures....Mathieu Othacehe 2020-05-05image: Add a new API....Mathieu Othacehe 2020-05-05system: vm: Move operating-system-uuid....Mathieu Othacehe 2020-04-26Merge branch 'master' into core-updatesMarius Bakke 2020-04-26vm: Remove unused import....Marius Bakke 2020-04-11vm: Make the device node procedure a parameter....Ludovic Courtès 2020-04-11vm: 'qemu-image' can pass options to the 'mkfs' command....Ludovic Courtès 2020-04-11vm: 'qemu-image' accepts a list of extra populate directives....Ludovic Courtès 2020-04-10vm: Use virtio network driver....Marius Bakke 2020-04-10vm: 'system-disk-image' honors #:substitutable? for ISO9660 images....Ludovic Courtès 2020-04-08vm: Allow images to be marked as non-substitutable....Ludovic Courtès