aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2017 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gperf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public gperf
  (package
    (name "gperf")
    (version "3.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/gperf/gperf-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq"))))
    (build-system gnu-build-system)
    (arguments '(#:parallel-tests? #f))
    (home-page "https://www.gnu.org/software/gperf/")
    (synopsis "Perfect hash function generator")
    (description
     "gperf is a perfect hash function generator.  For a given list of
strings, it produces a hash function and hash table in C or C++ code.  That
the hash function is perfect means that no collisions can exist and that
look-ups can be made by single string comparisons.")
    (license gpl3+)))

(define-public gperf-3.0
  ;; This older version would use 'unsigned int' in its generated lookup
  ;; functions whereas 3.1 uses 'size_t', which causes breakage such as
  ;; <https://github.com/wingo/elogind/issues/8>.
  (package
    (inherit gperf)
    (version "3.0.4")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gperf/gperf-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn"))))))
e='2024-02-07 13:30:33 +0100'>2024-02-07gnu: proj: Update to 9.3.1....Felix Gruber 2024-01-28gnu: openorienteering-mapper: Remove input labels....Sharlatan Hellseher 2024-01-28gnu: python-haversine: Simplify package....Sharlatan Hellseher 2024-01-28gnu: python-pyshp: Simplify package....Sharlatan Hellseher 2024-01-28gnu: Add python-ogr2osm....Patrick Noll 2024-01-28gnu: python-osmnx: Reformat with guix style....Troy Figiel 2024-01-28gnu: python-osmnx: Update to 1.8.1....Troy Figiel 2024-01-19gnu: python-metpy: Update to 1.6.1....Vinicius Monego 2024-01-16gnu: python-geopandas: Update to 0.14.2....Ricardo Wurmus 2024-01-16gnu: python-metpy: Update to 1.6.0....Ricardo Wurmus 2024-01-16gnu: python-cartopy: Update to 0.22.0....Ricardo Wurmus 2024-01-12gnu: qmapshack: Update to 1.17.1....Guillaume Le Vaillant 2024-01-07gnu: Add laszip....Mattia Bunel 2024-01-01gnu. josm. Update to 18907....Julien Lepiller 2023-12-29gnu: spatialite-tools: Update to 5.1.0a....Felix Gruber 2023-12-08gnu: Make webkitgtk-next the new webkitgtk....Liliana Marie Prikler 2023-12-02gnu: josm: Reduce closure size....Julien Lepiller 2023-11-09gnu: josm: Update to 18822....Julien Lepiller 2023-10-12gnu: python-metpy: Update to 1.5.1....Vinicius Monego 2023-09-21gnu: routino: Update to 3.4.1....Hendursaga 2023-09-21gnu: osmium-tool: Update to 1.15.0....Hendursaga 2023-09-21gnu: osm2pgsql: Update to 1.9.2....Hendursaga 2023-09-21gnu: libosmium: Update to 2.19.0....Hendursaga 2023-09-09gnu: qgis: Fix build....Guillaume Le Vaillant 2023-09-03gnu: Add python-metpy....Vinicius Monego 2023-08-22gnu: qtimageformats: Rename variable to qtimageformats-5....Maxim Cournoyer 2023-08-13gnu: spatialite-tools: Update to 5.1.0....Felix Gruber 2023-08-13gnu: libspatialite: Update to 5.1.0....Felix Gruber 2023-06-26gnu: Add gmt....Ricardo Wurmus 2023-06-26gnu: python-geopandas: Update to 0.13.2....Ricardo Wurmus 2023-06-26gnu: python-fiona: Update to 1.9.4.post1....Ricardo Wurmus 2023-06-26gnu: Add r-rnaturalearthhires....Ricardo Wurmus 2023-06-13gnu: qgis: Allow building on more architectures....Efraim Flashner 2023-06-05gnu: proj-7: Add upstream patch....Ricardo Wurmus 2023-05-24gnu: xygrib: Build with newer proj....Efraim Flashner 2023-05-24gnu: xygrib: Fix building with newer openjpeg....Efraim Flashner 2023-05-08gnu: Add python-timezonefinder....Sharlatan Hellseher 2023-05-08gnu: Add python-h3....Sharlatan Hellseher 2023-05-08gnu: Sort use-module alphabetically in (gnu packages geo)....Sharlatan Hellseher 2023-05-08gnu: Add h3....Sharlatan Hellseher