aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2017 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gperf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public gperf
  (package
    (name "gperf")
    (version "3.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/gperf/gperf-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq"))))
    (build-system gnu-build-system)
    (arguments '(#:parallel-tests? #f))
    (home-page "https://www.gnu.org/software/gperf/")
    (synopsis "Perfect hash function generator")
    (description
     "gperf is a perfect hash function generator.  For a given list of
strings, it produces a hash function and hash table in C or C++ code.  That
the hash function is perfect means that no collisions can exist and that
look-ups can be made by single string comparisons.")
    (license gpl3+)))

(define-public gperf-3.0
  ;; This older version would use 'unsigned int' in its generated lookup
  ;; functions whereas 3.1 uses 'size_t', which causes breakage such as
  ;; <https://github.com/wingo/elogind/issues/8>.
  (package
    (inherit gperf)
    (version "3.0.4")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gperf/gperf-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn"))))))
r inspect the private %default-modules variable of (guix build-systems gnu) to discover which modules to include when extending the used modules via the #:modules argument. The renaming was automated via the command: $ git grep -l %gnu-build-system-modules | xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i * guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to... (%default-gnu-imported-modules): ... this. (%default-modules): Rename to... (%default-gnu-modules): ... this. Export. (dist-package, gnu-build, gnu-cross-build): Adjust accordingly. Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee Maxim Cournoyer 2024-08-18gnu: gimp: Update to 2.10.38....* gnu/packages/gimp.scm (gimp): Update to 2.10.38. Change-Id: I3288c989a5b70e04ddffc97c38c8f52c032f973e Tobias Geerinckx-Rice 2024-04-17gnu: babl: Disable failing test on aarch64....The float-to-8bit test fails on an Apple M1 (aarch64) with the following message: 9/28 float-to-8bit FAIL 0.11s exit status 1 >>> LD_LIBRARY_PATH=/tmp/guix-build-babl-0.1.108.drv-0/build/babl BABL_PATH=/tmp/guix-build-babl-0.1.108.drv-0/build/extensions MALLOC_PERTURB_=94 /tmp/guix-build-babl-0.1.108.drv-0/build/tests/float-to-8bit stdout: float -> u8 1 failed #1[1] got 76 expected 77 stderr: " 0x43b9f0 0x4390b0 1" 1541377792 BablFishPath cost:146.000000 error:0.000000000000 "/tmp/guix-build-babl-0.1.108.drv-0/build/extensions/gggl.so 0: R'G'B'A float to R'G'B'A u8" 0 BablConversionLinear pixels:0 error: 0.000000 * gnu/packages/gimp.scm (babl): Disable failing test on aarch64. Change-Id: Icf2c2a9ea5986149902f741f96d1847d2403c1f4 Signed-off-by: Christopher Baines <mail@cbaines.net> Roman Scherer 2024-03-10Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-03-09gnu: gnome-photos: Build against gegl-0.4.44....On gnome-team, this dependency was already accounted for in commit 4beac7d95c84ea3be809030f942b8b71d155129e, but it was forgotten when updating gimp on master. * gnu/packages/gimp.scm (babl-0.1.96, gegl-0.4.44): New variables. * gnu/packages/gnome.scm (gnome-photos)[inputs]: Replace gegl with gegl-0.4.44. Liliana Marie Prikler 2024-03-09gnu: Add gimp-next....* gnu/packages/gimp.scm (gimp-next): New variable. Liliana Marie Prikler 2024-03-09gnu: gimp: Update to 2.10.36....* gnu/packages/gimp.scm (gimp): Update to 2.10.36. Liliana Marie Prikler 2024-03-09gnu: gegl: Build with introspection....* gnu/packages/gimp.scm (gegl)[arguments]: Remove #:configure-flags. Liliana Marie Prikler 2024-03-09gnu: babl: Build with introspection....* gnu/packages/gimp.scm (babl)[#:configure-flags]: Remove “-Denable-gir=false”. Liliana Marie Prikler 2024-03-09gnu: gegl: Update to 0.4.48....* gnu/packages/gimp.scm (gegl): Update to 0.4.48. Liliana Marie Prikler 2024-03-09gnu: babl: Update to 0.1.108....* gnu/packages/gimp.scm (babl): Update to 0.1.108. Liliana Marie Prikler 2023-09-14gnu: gegl: Use new style for inputs....* gnu/packages/gimp.scm (gegl)[inputs]: Drop labels. Liliana Marie Prikler 2023-09-14gnu: gimp: Update to 2.10.34....* gnu/packages/gimp.scm (gimp): Update to 2.10.34. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Vivien Kraus 2023-09-14gnu: gegl: Update to 0.4.46....* gnu/packages/gimp.scm (gegl): Update to 0.4.46. * gnu/packages/gimp.scm (gegl-0.4.44): New variable. * gnu/packages/gnome.scm (gnome-photos)[inputs]: Replace gegl with gegl-0.4.44. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Vivien Kraus 2023-05-09gnu: gimp: Build with librsvg-for-system....* gnu/packages/gimp.scm (gimp)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-05-09gnu: gegl: Build with librsvg-for-system....* gnu/packages/gimp.scm (gegl)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-03-31gnu: Replace all uses of atk by at-spi2-core....* gnu/packages/animation.scm (gnash) * gnu/packages/chromium.scm (ungoogled-chromium) * gnu/packages/crates-gtk.scm (rust-atk-sys-0.14, rust-atk-sys-0.10, rust-atk-0.14, rust-gtk-0.14) * gnu/packages/gimp.scm (gimp) * gnu/packages/gnome.scm (evince, glade3, clutter, totem, rhythmbox, mutter, ghex): * gnu/packages/graphviz.scm (xdot) * gnu/packages/gtk.scm (gtk+-2, gtk+, guile-gnome, atkmm) * gnu/packages/mate.scm (mate-applets, atril, mate-control-center, mate-calc, mate-utils, eom, pluma) * gnu/packages/messaging.scm (dino) * gnu/packages/qt.scm (qtwebengine-5) * gnu/packages/rust-apps.scm (alfis) * gnu/packages/vim.scm (vim-full) * gnu/packages/vnc.scm (remmina) * gnu/packages/web.scm (castor): Replace atk by at-spi2-core. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Josselin Poiret 2023-03-07gnu: gegl: Update to 0.4.42...* gnu/packages/gimp.scm (gegl): Update to 0.4.42 Signed-off-by: Leo Famulari <leo@famulari.name> Andy Tai 2023-03-02gnu: gimp: Don't retain reference on GCC....Partly fixes <https://issues.guix.gnu.org/57677>. * gnu/packages/gimp.scm (gimp)[arguments]: Add #:modules and #:phases. 宋文武 2023-01-03gnu: Remove Glimpse....This package no longer builds and is abandoned upstream: https://glimpse-editor.org/posts/a-project-on-hiatus/ * gnu/packages/gimp.scm (gegl-for-glimpse, glimpse): Remove variables. Leo Famulari