aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2017 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gperf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public gperf
  (package
    (name "gperf")
    (version "3.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/gperf/gperf-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq"))))
    (build-system gnu-build-system)
    (arguments '(#:parallel-tests? #f))
    (home-page "https://www.gnu.org/software/gperf/")
    (synopsis "Perfect hash function generator")
    (description
     "gperf is a perfect hash function generator.  For a given list of
strings, it produces a hash function and hash table in C or C++ code.  That
the hash function is perfect means that no collisions can exist and that
look-ups can be made by single string comparisons.")
    (license gpl3+)))

(define-public gperf-3.0
  ;; This older version would use 'unsigned int' in its generated lookup
  ;; functions whereas 3.1 uses 'size_t', which causes breakage such as
  ;; <https://github.com/wingo/elogind/issues/8>.
  (package
    (inherit gperf)
    (version "3.0.4")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gperf/gperf-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn"))))))
title='2017-01-16 11:03:26 +0100'>2017-01-16services: Export 'service-extension' procedures....Christopher Baines 2016-12-11services: Activate system prior to services....Christopher Baines 2016-09-20services: Use 'source-module-closure' for (gnu build activation)....Ludovic Courtès 2016-09-19services: Add 'simple-service'....Ludovic Courtès 2016-07-12gnu: Use 'gexp->file' in conjunction with 'with-imported-modules'....Ludovic Courtès 2016-07-12gnu: Switch to 'with-imported-modules'....Ludovic Courtès 2016-06-20services: Add 'gc-root-service-type'....Ludovic Courtès 2016-03-15doc: Clarify and consolidate modify-services documentation....Chris Marusich 2016-03-07services: Use 'packages->manifest' in 'packages->profile-entry'....宋文武 2016-02-08file-systems: Spawn a Bournish REPL upon fsck failure....Ludovic Courtès 2016-02-03services: 'file-union' makes sure each source file exists....Ludovic Courtès 2016-01-29services: Rename 'dmd' services to 'shepherd'....Alex Kost 2016-01-06services: cleanup-service: Catch 'system-error' instead of everything....Ludovic Courtès 2016-01-05services: Move /tmp cleanup to a separate service....Ludovic Courtès 2016-01-05services: boot: Reinstate /tmp and /var/run deletion....Ludovic Courtès 2015-11-02services: Add 'profile-service-type'....Ludovic Courtès 2015-11-02services: Add 'system-service-type'....Ludovic Courtès 2015-11-02services: Clarify extend/compose of BOOT-SERVICE-TYPE....Ludovic Courtès 2015-10-29services: Add 'linux-bare-metal-service-type'....Ludovic Courtès 2015-10-28services: Add 'modify-services'....Ludovic Courtès 2015-10-14services: Export 'service-back-edges'....Ludovic Courtès 2015-10-10services: Introduce extensible services....Ludovic Courtès 2014-11-10services: Add 'auto-start?' field to <service>....Ludovic Courtès 2014-09-17services: Change default 'stop' value to #~(const #f)....Ludovic Courtès 2014-05-24services: Support per-service activation scripts....Ludovic Courtès 2014-04-28services: Rewrite using gexps....Ludovic Courtès