aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
;;; Copyright © 2020 Christopher Lam <christopher.lck@gmail.com>
;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gnucash)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages base)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages check)
  #:use-module (gnu packages cmake)
  #:use-module (gnu packages databases)
  #:use-module (gnu packages docbook)
  #:use-module (gnu packages documentation)
  #:use-module (gnu packages finance)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gnupg)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages guile)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages multiprecision)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages swig)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages web)
  #:use-module (gnu packages webkit)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages)
  #:use-module (guix build-system cmake)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix utils))

(define-public gnucash
  ;; TODO: Unbundle libraries such as guile-json found under the "borrowed/"
  ;; directory.
  (package
    (name "gnucash")
    (version "5.9")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
                           version "/gnucash-" version ".tar.bz2"))
       (sha256
        (base32 "1l1g4acangbf4r27vsvavds0yqqa8smy4s676by68r639wvfbqjv"))))
    (outputs '("out" "doc" "debug" "python"))
    (build-system cmake-build-system)
    (arguments
     (list
      #:test-target "check"
      #:configure-flags #~(list "-DWITH_PYTHON=ON")
      #:make-flags #~(list "GUILE_AUTO_COMPILE=0")
      #:imported-modules `(,@%default-gnu-imported-modules
                           (guix build cmake-build-system)
                           (guix build glib-or-gtk-build-system))
      #:modules '((guix build cmake-build-system)
                  ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
                  (guix build utils))
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'disable-online-test
            (lambda _
              (call-with-output-file "libgnucash/app-utils/test/CMakeLists.txt"
                (lambda (port)
                  (display "set(CTEST_CUSTOM_TESTS_IGNORE online_wiggle test-lots)" port)))))
          (add-after 'unpack 'set-env-vars
            (lambda* (#:key inputs #:allow-other-keys)
              ;; At least one test is time-related and requires this
              ;; environment variable.
              (setenv "TZDIR" (search-input-directory inputs "share/zoneinfo"))
              (substitute* "CMakeLists.txt"
                (("set\\(SHELL /bin/bash\\)")
                 (string-append "set(SHELL " (which "bash") ")")))))
          ;; The qof test requires the en_US, en_GB, and fr_FR locales.
          (add-before 'check 'install-locales
            (lambda _
              (setenv "LOCPATH" (getcwd))
              (invoke "localedef" "-i" "en_US" "-f" "UTF-8" "./en_US.UTF-8")
              (invoke "localedef" "-i" "en_GB" "-f" "UTF-8" "./en_GB.UTF-8")
              (invoke "localedef" "-i" "fr_FR" "-f" "UTF-8" "./fr_FR.UTF-8")))
          ;; There is about 100 MiB of documentation.
          (add-after 'install 'install-docs
            (lambda _
              (mkdir-p (string-append #$output:doc "/share"))
              (symlink (string-append
                        #$(this-package-native-input "gnucash-docs")
                        "/share/help")
                       (string-append #$output:doc "/share/help"))))
          (add-after 'install 'split-python-bindings
            (lambda _
              (let ((python-bindings (string-append
                                      "lib/python"
                                      #$(version-major+minor
                                         (package-version python)))))
                (mkdir-p (string-append #$output:python "/" python-bindings))
                (copy-recursively
                 (string-append #$output "/" python-bindings)
                 (string-append #$output:python "/" python-bindings))
                (delete-file-recursively
                 (string-append #$output "/" python-bindings)))))
          (add-after 'install-docs 'wrap-programs
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (for-each
               (lambda (prog)
                 (wrap-program (search-input-file
                                outputs (string-append "bin/" prog))
                   `("GNC_DBD_DIR" =
                     (,(search-input-directory inputs "lib/dbd")))
                   `("PERL5LIB" ":" prefix
                     ,(map (lambda (o)
                             (string-append o "/lib/perl5/site_perl/"
                                            #$(package-version perl)))
                           (if (string=? prog "gnc-fq-helper")
                               (list
                                #$@(transitive-input-references
                                    'inputs
                                    (map (lambda (l)
                                           (assoc l (package-inputs this-package)))
                                         '("perl-finance-quote"
                                           "perl-date-manip"))))
                               (list
                                #$@(transitive-input-references
                                    'inputs
                                    (map (lambda (l)
                                           (assoc l (package-inputs this-package)))
                                         '("perl-finance-quote")))))))))
               '("gnucash"
                 "gnc-fq-update"))))
          (add-after 'install 'glib-or-gtk-compile-schemas
            (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
          (add-after 'install 'glib-or-gtk-wrap
            (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
    (native-inputs
     (list gmp
           `(,glib "bin")               ;glib-compile-schemas, etc.
           gnucash-docs
           googletest
           intltool
           (libc-utf8-locales-for-target)
           pkg-config
           swig))
    (inputs
     (list aqbanking
           bash-minimal
           boost
           glib
           gtk+
           guile-3.0
           icu4c
           libdbi
           libdbi-drivers
           libofx
           libxml2
           libxslt
           perl-date-manip
           perl-finance-quote
           perl-json
           perl-json-parse
           python
           tzdata-for-tests
           webkitgtk-with-libsoup2))
    (propagated-inputs
     ;; dconf is required at runtime according to README.dependencies.
     (list dconf))
    (home-page "https://www.gnucash.org/")
    (synopsis "Personal and small business financial accounting software")
    (description
     "GnuCash is personal and professional financial-accounting software.
It can be used to track bank accounts, stocks, income and expenses, based on
the double-entry accounting practice.  It includes support for QIF/OFX/HBCI
import and transaction matching.  It also automates several tasks, such as
financial calculations or scheduled transactions.

To make the GnuCash documentation available, its doc output must be
installed as well as Yelp, the Gnome help browser.")
    (license license:gpl3+)))

;; This package is not public, since we use it to build the "doc" output of
;; the gnucash package (see above).  It would be confusing if it were public.
(define gnucash-docs
  (let ((revision ""))               ;set to the empty string when no revision
    (package
      (name "gnucash-docs")
      (version (package-version gnucash))
      (source
       (origin
         (method url-fetch)
         (uri (string-append
               "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
               version "/gnucash-docs-" version revision ".tar.gz"))
         (sha256
          (base32 "1jclya8p005dfwhkx4yqbcml631y4xngl8v08kg33d0ws4mkmi4v"))))
      (build-system cmake-build-system)
      ;; These are native-inputs because they are only required for building the
      ;; documentation.
      (native-inputs
       ;; The "check" target needs docbook-xml package to validate the DocBook
       ;; XML during the tests.
       (list docbook-xml
             docbook-xsl
             libxml2
             libxslt
             scrollkeeper))
      (arguments
       `(#:tests? #f))                  ;no test target
      (home-page "https://www.gnucash.org/")
      (synopsis "Documentation for GnuCash")
      (description
       "User guide and other documentation for GnuCash in various languages.
This package exists because the GnuCash project maintains its documentation in
an entirely separate package from the actual GnuCash program.  It is intended
to be read using the GNOME Yelp program.")
      (license (list license:fdl1.1+ license:gpl3+)))))

(define-public gwenhywfar
  (let ((attachid "501")) ;; file attachid changes for each version
    (package
      (name "gwenhywfar")
      (version "5.10.2")
      (source
       (origin
         (method url-fetch)
         (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
                             "download/" attachid "/gwenhywfar-" version ".tar.gz"))
         (sha256
          (base32 "1qd950kilf9bcb51b1daykipanml6bg1h3pj10950r98ah1xm9v0"))))
      (build-system gnu-build-system)
      (arguments
       `(#:configure-flags
         (list "--disable-network-checks"
               ;; GTK+3, GTK+2 and QT4 are supported.
               "--with-guis=gtk3"
               "--enable-system-certs"
               "--with-libxml2-code=yes"
               "--disable-binreloc")))
      (inputs
       (list libgcrypt gnutls openssl gtk+ libxml2))
      (native-inputs
       (list pkg-config))
      (home-page "https://www.aquamaniac.de")
      (synopsis "Utility library for networking and security applications")
      (description
       "This package provides a helper library for networking and security
applications and libraries.  It is used by AqBanking.")
      ;; The license includes an explicit additional permission to compile and
      ;; distribute this library with the OpenSSL Toolkit.
      (license license:lgpl2.1+))))

(define-public aqbanking
  (let ((attachid "499")) ;; file attachid changes for each version
    (package
      (name "aqbanking")
      (version "6.5.4")
      (source
       (origin
         (method url-fetch)
         (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
                             "download/" attachid "/aqbanking-" version ".tar.gz"))
         (sha256
          (base32 "16dc63gav0b4rmwj0clqilfpz4hlidx59x1qcr38wwghfspcw5hd"))))
      (build-system gnu-build-system)
      (arguments
       `(;; Parallel building fails because aqhbci is required before it's
         ;; built.
         #:parallel-build? #f
         #:phases
         (modify-phases %standard-phases
           ;; Embed the package version instead of the build date
           (add-after 'unpack 'use-version-instead-of-date
             (lambda _
               (substitute*
                   "src/libs/plugins/backends/aqhbci/header.xml.in"
                 (("@DATETIME@") ,version)))))))
      (propagated-inputs
       (list gwenhywfar))
      (inputs
       (list gmp xmlsec gnutls))
      (native-inputs
       (list pkg-config gettext-minimal libltdl))
      (home-page "https://www.aquamaniac.de")
      (synopsis "Interface for online banking tasks")
      (description
       "AqBanking is a modular and generic interface to online banking tasks,
financial file formats (import/export) and bank/country/currency information.
AqBanking uses backend plugins to actually perform the online tasks.  HBCI,
OFX DirectConnect, YellowNet, GeldKarte, and DTAUS discs are currently
supported.  AqBanking is used by GnuCash, KMyMoney, and QBankManager.")
      ;; AqBanking is licensed under the GPLv2 or GPLv3
      (license (list license:gpl2 license:gpl3)))))
nel modules are Linux kernel modules which make LTTng kernel tracing possible. They include essential control modules and many probes which instrument numerous interesting parts of Linux.") (license (list license:lgpl2.1 license:gpl2 license:expat)))) (define-public lttng-ust (package (name "lttng-ust") (version "2.13.8") (source (origin (method url-fetch) (uri (string-append "https://lttng.org/files/lttng-ust/" "lttng-ust-" version ".tar.bz2")) (sha256 (base32 "0dyr4j8f8y6fmfpxb3ajkc1ndwpl1baxzbyc4ksx8ym3p7d9ivyl")))) (build-system gnu-build-system) (inputs (list numactl)) (propagated-inputs (list liburcu)) ;headers of liburcu are used by headers of lttng (native-inputs (list python-3 pkg-config)) (home-page "https://lttng.org/") (synopsis "LTTng userspace tracer libraries") (description "The user space tracing library, liblttng-ust, is the LTTng user space tracer. It receives commands from a session daemon, for example to enable and disable specific instrumentation points, and writes event records to ring buffers shared with a consumer daemon.") (license (list license:lgpl2.1 license:expat)))) (define-public lttng-tools (package (name "lttng-tools") (version "2.13.14") (source (origin (method url-fetch) (uri (string-append "https://lttng.org/files/lttng-tools/" "lttng-tools-" version ".tar.bz2")) (sha256 (base32 "1jxdwm0a3z70jrx6yg57x5cswi7ycgyazng41rkgxnq7mp2gggak")))) (build-system gnu-build-system) (arguments `(#:configure-flags '("--enable-python-bindings") ;; FIXME - Tests are disabled for now because one test hangs ;; indefinetely. Also, parallel testing is not possible because of how ;; the lttng-daemon handles sessions. Thus, keep parallel testing ;; disabled even after tests are enabled! #:tests? #f #:parallel-tests? #f #:phases (modify-phases %standard-phases (add-before 'configure 'set-environment-variables (lambda _ (setenv "HOME" "/tmp") (setenv "LTTNG_HOME" "/tmp"))) ;; We don't put (which "man") here because LTTng uses execlp. (add-after 'unpack 'patch-default-man-path (lambda _ (substitute* "src/common/defaults.h" (("/usr/bin/man") "man")))) (add-before 'configure 'autoreconf (lambda _ (invoke "autoreconf" "-vfi")))))) ;; NOTE - Users have to install python-3 in their profile to use the ;; bindings. We don't put it in the inputs, because the rest of the tools ;; can work without it. (inputs (list liburcu popt numactl)) (propagated-inputs (list kmod module-init-tools)) ;; NOTE - LTTng 2.13.9 is distributed with a aclocal.m4 that does not ;; support Python3.10. We can either disable Python's bindings or we can ;; reconfigure the project with our autoconf. This is because the ;; distribution tarballs are generated on Ubuntu LTS 18.04. ;; ;; `paredit-raise-sexp' on the first list of native inputs and remove the ;; 'autoreconf build step whenever we bump to the next version that is ;; goind to be generated on Ubuntu LTS 22.04. (native-inputs (append (list pkg-config perl libpfm4 python-3 swig procps which flex bison asciidoc libxml2 lttng-ust) (list autoconf automake libtool))) (home-page "https://lttng.org/") (synopsis "LTTng userspace tracer libraries") (description "The lttng-tools project provides a session daemon @code{lttng-sessiond} that acts as a tracing registry, the @command{lttng} command line for tracing control, a @code{lttng-ctl} library for tracing control and a @code{lttng-relayd} for network streaming.") (license (list license:gpl2 license:lgpl2.1)))) (define-public perf-tools (package (name "perf-tools") (version "1.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/brendangregg/perf-tools") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1ab735idi0h62yvhzd7822jj3555vygixv4xjrfrdvi8d2hhz6qn")))) (build-system copy-build-system) (arguments `(#:phases (modify-phases %standard-phases (add-after 'unpack 'patch-file-names (lambda* (#:key inputs #:allow-other-keys) (substitute* '("execsnoop" "killsnoop" "kernel/funcslower") (("/usr/bin/gawk") (search-input-file inputs "/bin/awk"))) (substitute* "execsnoop" (("/usr/bin/getconf") (search-input-file inputs "/bin/getconf")))))) #:install-plan ',(append (map (cut list <> "bin/") '("disk/bitesize" "fs/cachestat" "execsnoop" "kernel/funccount" "kernel/funcgraph" "kernel/funcslower" "kernel/functrace" "iolatency" "iosnoop" "killsnoop" "kernel/kprobe" "opensnoop" "misc/perf-stat-hist" "tools/reset-ftrace" "syscount" "net/tcpretrans" "system/tpoint" "user/uprobe")) '(("man/man8/" "share/man/man8"))))) (propagated-inputs (list bash coreutils ; cat + rm gawk file perf perl procps ; sysctl which)) (home-page "https://github.com/brendangregg/perf-tools") (synopsis "Performance analysis tools") (description "Perf-tools is a collection of scripts for performance analysis and instrumentation based on Linux perf_events (aka perf) and ftrace.") (license (list license:gpl2)))) (define-public systemtap (package (name "systemtap") (version "4.9") (source (origin (method url-fetch) (uri (string-append "https://sourceware.org/ftp/systemtap/releases/" name "-" version ".tar.gz")) (sha256 (base32 "161smpv4ajqfncmgylvs89bbix1id60nf0g7clmga2lxxax3646h")))) (build-system gnu-build-system) (native-inputs (list cpio python)) (inputs (list elfutils)) (home-page "https://sourceware.org/systemtap/") (synopsis "GNU/Linux trace/probe tool") (description "SystemTap provides infrastructure to simplify the gathering of information about the running Linux system. This assists diagnosis of a performance or functional problem. SystemTap eliminates the need for the developer to go through the tedious and disruptive instrument, recompile, install, and reboot sequence that may be otherwise required to collect data. SystemTap provides a simple command line interface and scripting language for writing instrumentation for a live running kernel plus user-space applications. We are publishing samples, as well as enlarging the internal \"tapset\" script library to aid reuse and abstraction. SystemTap is a tool for complex tasks that may require live analysis, programmable on-line response, and whole-system symbolic access, and can also handle simple tracing jobs.") (license license:gpl2+))) (define-public uftrace (package (name "uftrace") (version "0.11") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/namhyung/uftrace") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0gk0hv3rnf5czvazz1prg21rf9qlniz42g5b389n8a29hqj4q6xr")))) (build-system gnu-build-system) (arguments (list #:modules `((ice-9 match) ,@%default-gnu-modules) #:make-flags #~(list (string-append "CC=" #$(cc-for-target))) ;; runtest hangs at some point -- probably due to ;; failed socket connection -- but we want to keep the ;; unit tests. Change the target to "test" when fixed. #:test-target "unittest" #:phases #~(modify-phases %standard-phases (replace 'configure (lambda* (#:key outputs target #:allow-other-keys) (let ((arch #$(platform-linux-architecture (lookup-platform-by-target-or-system (or (%current-target-system) (%current-system)))))) (setenv "ARCH" (match arch ("arm64" "aarch64") (_ arch))) (when target (setenv "CROSS_COMPILE" (string-append target "-")))) (setenv "SHELL" (which "sh")) (invoke "./configure" (string-append "--prefix=" #$output))))))) (inputs (list capstone elfutils libunwind ncurses)) (native-inputs (list luajit pandoc pkg-config python-wrapper)) (home-page "https://github.com/namhyung/uftrace") (synopsis "Function graph tracer for C/C++/Rust") (description "uftrace is a tool for tracing and analyzing the execution of programs written in C/C++. It is heavily inspired by the ftrace framework of the Linux kernel, while supporting userspace programs. It supports various kind of commands and filters to help analysis of the program execution and performance. It provides the command @command{uftrace}. User that want to do scripting need to install python-3 or luajit in their profile.") (license license:gpl2)))