aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gnu-pw-mgr)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages autogen))

(define-public gnu-pw-mgr
  (package
    (name "gnu-pw-mgr")
    (version "2.7.4")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/gnu-pw-mgr/gnu-pw-mgr-"
                          version ".tar.xz"))
      (sha256
       (base32 "0fhwvsmsqpw0vnivarfg63l8pgwqfv7d5wi6l80jpb41dj6qpjz8"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-after 'patch-source-shebangs 'patch-more-shebangs
           (lambda _
             (substitute* "tests/dom.test"
               (("/usr/bin/printf") (which "printf")))
             #t))
         (add-before 'check 'pre-check
           (lambda _
             ;; In the build environment, there is no /dev/tty.
             (substitute* "tests/base.test"
               (("/dev/tty") "/dev/null"))
             #t)))))
    (native-inputs
     (list which))
    (home-page "https://www.gnu.org/software/gnu-pw-mgr/")
    (synopsis "Retrieve login credentials without recording passwords")
    (description
     "This program is designed to make it easy to reconstruct difficult
passwords when they are needed while limiting the risk of attack.  The
user of this program inputs a self-defined transformation of a web
site URL and obtains the password and user name hint for that web
site.")
    (license gpl3+)))
7ce9eaf0132ab00b7adf26953eb193f152ee7f2f'>gnu: Krita: Update to 4.1.1....Leo Famulari 2018-09-01gnu: libksysguard: Update to 5.13.4....Leo Famulari 2018-04-11gnu: krita: Update to 4.0.1....Leo Famulari 2018-03-27gnu: libkomparediff2: Update to 17.12.3....Tobias Geerinckx-Rice 2018-03-23gnu: Keep Krita 3 along with Krita 4....Leo Famulari 2018-03-22gnu: krita: Update to 4.0.0....Leo Famulari 2018-02-18gnu: qca: Use mirror://kde scheme for source-url....Hartmut Goebel 2018-02-18gnu: snorenotify: Use mirror://kde scheme for source-url....Hartmut Goebel 2018-02-18gnu: libkomparediff2: Use mirror://kde scheme for source-url....Hartmut Goebel 2018-02-18gnu: libkomparediff2: Update to 17.12.1...Hartmut Goebel 2018-02-18gnu: libksysguard: Update to 5.11.5....Hartmut Goebel 2018-02-15gnu: Add kholidays....Hartmut Goebel 2018-01-13gnu: krita: Update to 3.3.3....Leo Famulari 2018-01-03gnu: krita: Add comment about the wrapper....Leo Famulari 2018-01-03gnu: krita: Ensure icons are found at runtime....Leo Famulari 2018-01-02gnu: libksysguard: Update to 5.11.4....Tobias Geerinckx-Rice 2017-12-16gnu: krita: Enhance krita....Mark Meyer 2017-12-12gnu: Add krita....Mark Meyer 2017-11-05gnu: libksysguard: Update to 5.11.2....Hartmut Goebel 2017-10-08gnu: kdevelop: Do not hardcode user profile locations in wrapper....Thomas Danckaert 2017-08-30gnu: kdevelop: Update to 5.1.2....Thomas Danckaert 2017-08-24gnu: libksysguard: Enable more tests (not all working yet)....Hartmut Goebel 2017-08-18gnu: libksysguard: Update to 5.10.4....Efraim Flashner 2017-06-15