aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gnu-pw-mgr)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages autogen))

(define-public gnu-pw-mgr
  (package
    (name "gnu-pw-mgr")
    (version "2.7.4")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/gnu-pw-mgr/gnu-pw-mgr-"
                          version ".tar.xz"))
      (sha256
       (base32 "0fhwvsmsqpw0vnivarfg63l8pgwqfv7d5wi6l80jpb41dj6qpjz8"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-after 'patch-source-shebangs 'patch-more-shebangs
           (lambda _
             (substitute* "tests/dom.test"
               (("/usr/bin/printf") (which "printf")))
             #t))
         (add-before 'check 'pre-check
           (lambda _
             ;; In the build environment, there is no /dev/tty.
             (substitute* "tests/base.test"
               (("/dev/tty") "/dev/null"))
             #t)))))
    (native-inputs
     (list which))
    (home-page "https://www.gnu.org/software/gnu-pw-mgr/")
    (synopsis "Retrieve login credentials without recording passwords")
    (description
     "This program is designed to make it easy to reconstruct difficult
passwords when they are needed while limiting the risk of attack.  The
user of this program inputs a self-defined transformation of a web
site URL and obtains the password and user name hint for that web
site.")
    (license gpl3+)))
1.2 to go-github-com-robfig-cron * gnu/packages/golang.scm (go-github-com-robfig-cron-1.2): Delete variable. Change-Id: Ie2c25254ffefb99f8808f74ae4a9d85bbbcb6437 Sharlatan Hellseher 2023-12-05gnu: python-setuptools-lint: Add missing input....* gnu/packages/check.scm (python-setuptools-lint)[propagated-inputs]: Add python-tomli. Change-Id: I0ab7d3b129d6c347c212b968c4aeb425e3ee97ae Efraim Flashner 2023-12-02gnu: python-lit: Update to 17.0.6....* gnu/packages/check.scm (python-lit): Update to 17.0.6. [native-inputs]: Remove llvm-14; add llvm. Change-Id: I45ccc5302c2481b82f26201e66994e15eeaecc9d Efraim Flashner 2023-11-18gnu: python-pytest-perf: Update to 0.13.1....* gnu/packages/check.scm (python-pytest-perf): Update to 0.13.1. [build-system]: Switch to pyproject-build-system, because setup.py has been removed since 0.12.1. [arguments]<#:phases>: Remove ignored tests from the check phase. <#:test-flags>: And use test flags instead. Change-Id: Id81e47666a51b411740c6e6a6f6976cee616b6a4 Troy Figiel 2023-10-14gnu: guile-proba: Fix environment vars in Guile Proba's script....* gnu/packages/check.scm (guile-proba): Micro fix. Guile Proba's CLI script, as created via Guix's `wrap-program', should take into account (as opposed to discard) the original, user-defined values of `GUILE_LOAD_PATH' and `GUILE_LOAD_COMPILED_PATH'. Currently, Guile Proba's CLI script is unable to find any third-party library needed by the app being tested. This micro change should fix this. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Fabio Natali 2023-10-11gnu: guile-proba: Update to 0.3.1....* gnu/packages/check.scm (guile-proba): Update to 0.3.1. Signed-off-by: Christopher Baines <mail@cbaines.net> Change-Id: I7cc9708078fee14723eec90e4ce45d2beb3a01d0 Fabio Natali 2023-09-02gnu: pict: Update to 3.7.4....* gnu/packages/check.scm (pict): Update to 3.7.4. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> fanquake 2023-09-01gnu: Add ftest....* gnu/packages/check.scm (ftest): New variable. Co-authored-by: Hilton Chain <hako@ultrarare.space> Signed-off-by: Hilton Chain <hako@ultrarare.space> Reza Housseini 2023-08-27gnu: catch2: Update to 3.4.0....* gnu/packages/check.scm (catch2): Update to 3.4.0. Signed-off-by: Christopher Baines <mail@cbaines.net> Greg Hogan 2023-08-21gnu: googlebenchmark: Update to 1.8.2....* gnu/packages/check.scm (googlebenchmark): Update to 1.8.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2023-07-30gnu: cxxtest: Use Web Archived home page....* gnu/packages/check.scm (cxxtest)[home-page]: Use a copy archived by the Wayback Machine. Tobias Geerinckx-Rice 2023-07-18gnu: Add python-gixy....* gnu/packages/check.scm (python-gixy): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-07-11gnu: Add rapidcheck....* gnu/packages/check.scm (rapidcheck): New variable. Zhu Zihao 2023-07-09gnu: python-pytest-enabler: Don't set #:tests to #:true....* gnu/packages/check.scm (python-pytest-enabler)[arguments]: Rewrite to strip the #:tests? argument from the inherited package. Efraim Flashner 2023-07-01Revert "gnu: Add rapidcheck."...This reverts commit 4236e24cb9e80201e42d13c9a70bd918299b12fa. Wrong patch revision. Nicolas Goaziou 2023-07-01gnu: Add rapidcheck....* gnu/packages/check.scm (rapidcheck): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Zhu Zihao 2023-07-01gnu: catch2: Use correct configure flag to disable errors....* gnu/packages/check.scm (catch2)[#:configure-flags]: Replace “-DENABLE_ERROR=OFF” with “-DCATCH_ENABLE_WERROR=OFF”. Liliana Marie Prikler 2023-07-01gnu: catch2: Update to 3.3.2....* gnu/packages/check.scm (catch2-3.1): Rename to catch2-3.3. [version, source]: Update to 3.3.2. [outputs]: Remove ‘doc’. [build-system]: Use cmake-build-system. [arguments]: Remove special phases. Add CMake options to #:configure-flags. * gnu/packages/potassco.scm (clingo): Adjust accordingly. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> David Elsing 2023-06-24gnu: Add subunit....* gnu/packages/check.scm (subunit): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Antero Mejr 2023-05-04gnu: Add python-pytest-mypy-plugins....* gnu/packages/check.scm (python-pytest-mypy-plugins): New variable. Ricardo Wurmus 2023-04-30gnu: clitest: Fix test failure with newer grep....* gnu/packages/patches/clitest-grep-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/check.scm (clitest)[source](patches): New field. [arguments]: While at it, remove obsolete substitution. Marius Bakke 2023-04-26gnu: cppcheck: Update to 2.10.3....* gnu/packages/check.scm (cppcheck): Update to 2.10.3. [home-page]: Update to new home-page. Efraim Flashner 2023-04-26gnu: cppcheck: Skip failing test....* gnu/packages/patches/check.scm (cppcheck)[source]: Add patch. * gnu/packages/patches/cppcheck-disable-char-signedness-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Efraim Flashner 2023-04-20gnu: python-pytest-flakes: Update to 4.0.5....* gnu/packages/check.scm (python-pytest-flakes): Update to 4.0.5. [native-inputs]: Remove python-pytest-cache. John Kehayias 2023-04-19gnu: python-pytest-asyncio: Update to 0.21.0....* gnu/packages/check.scm (python-pytest-asyncio): Update to 0.21.0. [build-system]: Use pyproject-build-system. [arguments]: Set #:tests? to #f. Remove check phase override. [native-inputs]: Remove now unused python-async-generator, python-flaky, python-hypothesis and python-pytest. [propagated-inputs]: Add python-pytest. Maxim Cournoyer 2023-04-18gnu: python-pytest-localserver: Update to 0.7.1....* gnu/packages/check.scm (python-pytest-localserver): Update to 0.7.1. John Kehayias 2023-04-15gnu: python-pytest: Fix failing test_raising_repr....* gnu/packages/patches/pytest-fix-unstrable-exception-test.patch: Add new patch from upstream. * gnu/packages/check.scm (python-pytest): Use it. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Andreas Enge <andreas@enge.fr> Josselin Poiret 2023-04-15Revert "gnu: python-pytest: Update to 7.3.1."...This reverts commit 81682e2e9042bfb9621482eb2d0f46104a86aa11. Andreas Enge 2023-04-15gnu: clara: Fix build....* gnu/packages/check.scm (clara) [source]: Add snippet to un-bundle catch2. [arguments]: Add #:configure-flags argument. [native-inputs]: Add catch2. Maxim Cournoyer 2023-04-15gnu: python-pytest: Update to 7.3.1....* gnu/packages/check.scm (python-pytest): Update to 7.3.1. [propagated-inputs]: Add python-exceptiongroup. Maxim Cournoyer 2023-04-14gnu: python-pytest-7.1: Deprecate package....The source was adjusted using the following command: $ git grep -rl python-pytest-7.1 | xargs sed -i 's/python-pytest-7.1/python-pytest/g' * gnu/packages/check.scm (python-pytest-7.1): Delete variable. Maxim Cournoyer 2023-04-14gnu: python-pluggy: Update to 1.0.0....* gnu/packages/python-xyz.scm (python-pluggy): Update to 1.0.0. (python-pluggy-next): Delete variable. * gnu/packages/check.scm (python-pytest-7.1) [propagated-inputs]: Remove python-pluggy replacement. * gnu/packages/databases.scm (datasette) [propagated-inputs]: Replace python-pluggy-next with python-pluggy. Maxim Cournoyer 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-13gnu: python-pytest-fork: Update to 1.6.0....* gnu/packages/check.scm (python-pytest-fork): Update to 1.6.0. [build-system]: Use pyproject-build-system. [arguments]: Replace disable-setuptools-scm phase with pretend-version. [native-inputs]: Remove input labels. Add python-setuptools-scm. (python-pytest-forked-next): Delete variable. (python-pytest-xdist-next): Replace python-pytest-forked-next with python-pytest-forked. Maxim Cournoyer 2023-04-11gnu: python-pytest-7.1: Replace python-toml with python-tomli....* gnu/packages/check.scm (python-pytest-7.1) [propagated-inputs]: Replace python-toml with python-tomli. Maxim Cournoyer 2023-04-10gnu: python-lit: Honor the #:tests? flag....* gnu/packages/check.scm (python-lit)[arguments]: Honor the #:tests? flag in the custom 'check phase. Efraim Flashner