aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gnu-doc)
  #:use-module (gnu packages base)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages texinfo)

  #:use-module (guix build-system gnu)
  #:use-module (guix build-system trivial)
  #:use-module (guix cvs-download)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages))

(define-public miscfiles
  (package
    (name "miscfiles")
    (version "1.5")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/" name "/" name "-"
                          version ".tar.gz"))
      (sha256
       (base32
        "005588vfrwx8ghsdv9p7zczj9lbc9a3r4m5aphcaqv8gif4siaka"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/miscfiles/")
    (synopsis
     "Data files for airport codes, zip codes, a dictionary, and more")
    (description
     "GNU Miscfiles is a collection of common data files.  They include, for
example, country abbreviations, names and capital cities; currency
abbreviations and names; a Best Current Practices index; a map of the ASCII
character set; a list of three-letter airport codes; and an English word
list.")
    (license gpl2+)))

(define-public gnu-standards
  (package
    (name "gnu-standards")
    (version "2020-11-25")
    (source
     (origin
       (method cvs-fetch)
       (uri (cvs-reference
             (root-directory
              ":pserver:anonymous@cvs.savannah.gnu.org:/sources/gnustandards")
             (module "gnustandards")
             (revision version)))
       (sha256
        (base32
         "1xlwmgcnvp81ipgfir4ckpgl922mbckvxy1x758r0lksq5vrpglj"))
       (file-name (string-append name "-" version "-checkout"))))
    (build-system trivial-build-system)
    (native-inputs `(("gzip" ,gzip)
                     ("source" ,source)
                     ("texinfo" ,texinfo)))
    (arguments
     `(#:modules ((guix build utils))
       #:builder
        (begin
          (use-modules (guix build utils))
          (let ((gzip (assoc-ref %build-inputs "gzip"))
                (source (assoc-ref %build-inputs "source"))
                (texinfo (assoc-ref %build-inputs "texinfo"))
                (info-dir (string-append %output "/share/info")))
            (setenv "PATH" (string-append gzip "/bin"
                                          ":" texinfo "/bin"))
            (mkdir-p info-dir)
            (invoke "makeinfo" "--output" info-dir
                    (string-append source "/maintain.texi"))
            (invoke "makeinfo" "--output" info-dir
                    (string-append source "/standards.texi"))
            (invoke "gzip" "-n" (string-append info-dir "/maintain.info"))
            (invoke "gzip" "-n" (string-append info-dir "/standards.info"))))))
    (home-page "https://www.gnu.org/prep/standards/")
    (synopsis "GNU coding standards and maintainer information")
    (description "The GNU Coding Standards were written by Richard Stallman
and other GNU Project volunteers.  Their purpose is to make the GNU system
clean, consistent, and easy to install.

The information for maintainers of GNU software has guidelines and advice for
someone who is the maintainer of a GNU program on behalf of the GNU Project.")
    (license fdl1.3+)))
n class='msg-tooltip'>By only testing the final Rust in the bootstrap chain, the total build time is reduced by approximately 30%, from about 11 hours to 8 hours on a fast machine. Combined with commit df93fc21a4, the total Rust bootstrap chain build time should have been halved. * gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. * gnu/packages/rust.scm (rust-1.29): Do not apply the above patch. (rust-1.30): Remove the "doc" output. Disable tests. [phases]{set-env}: Do not set CFG_DISABLE_CROSS_TESTS. {relax-gdb-auto-load-safe-path, patch-tests, patch-cargo-index-update} {patch-aarch64-test, remove-unsupported-tests, disable-amd64-avx-test} {patch-cargo-tests, patch-cargo-env-shebang} {ignore-cargo-package-tests}: Remove phases. {configure}: Remove the doc and gdb bindings and their respective configuration entries in the generated config.toml file. {check}: Remove phase. [native-inputs]{bison, flex, gdb, procps}: Remove inputs. {python-2}: Replace by python-wrapper. {rust-1.29}: Do not export variable. {rust-1.30}: Likewise. (rust-1.31): Likewise. [arguments]: Remove field. (rust-1.32): Do not export variable. [source]: Remove patch. [phases]{override-jemalloc}: Order following 'configure. {remove-flaky-test, patch-aarch64-test}: Remove deletions. (rust-1.33): Do not export variable. [arguments]: Remove field. (rust-1.34): Do not export variable. (rust-1.35): Likewise. (rust-1.36): Likewise. [arguments]: Remove field. (rust-1.37): Do not export variable. (rust-1.38): Do not export variable. [arguments]: Likewise. (rust-1.39): Do not export variable. (rust-1.40): Do not export variable. [phases]: Do not alter the #:phases argument. (rust-1.41, rust-1.42, rust-1.43): Do not export variables. (rust-1.44): Likewise. [arguments]: Remove field. (rust-1.45): Do not export variable. [phases]{skip-shebang-tests, skip-networking-test}: Remove phases. (rust-1.46): Do not export variable. (rust-1.47): Do not export variable. [arguments]: Remove field. (rust-1.48): Do not export variable. [arguments]: Remove field. (rust-1.49): Rename to... (rust): ... this. [outputs]: Add a "doc" output. [phases]{enable-docs, add-gdb-to-config} {relax-gdb-auto-load-safe-path, patch-cargo-env-shebang} {disable-tests-requiring-git, disable-interrupt-tests} {patch-command-exec-tests, patch-command-uid-gid-test} {skip-shebang-tests, patch-process-tests}: New phases. [native-inputs]{gdb-9.2, procps}: New inputs. Maxim Cournoyer 2021-02-05gnu: rust: Bootstrap rust@1.29.2 by mrustc@0.9....This reduced bootstrap reduces the complete Rust bootstrap chain build time by approximately 30% compared to the original (about 11 hours instead of 16 hours, on a fast machine). * gnu/packages/patches/rust-1.45-linker-locale.patch: Delete file. * gnu/packages/patches/rust-1.48-linker-locale.patch: Likewise. * gnu/local.mk (dist_patch_DATA): De-register deleted files. * gnu/packages/rust.scm (%mrustc-source): New variable. (rust-1.29): New variable. It is bootstrapped from mrust 0.9, which is used in source form. (rust-1.30): New variable. (rust-1.31)[phases]{patch-command-exec-tests-phase}: Rewrite so that it doesn't need to be redefined later when the file is moved. {enable-docs}: New phase. (rust-1.32): Disable tests. [inputs]: Remove field. [phases]{override-jemalloc}: Reorder after the configure phase. (rust-1.33): Enable tests. [phases]{disable-codegen-tests}: New phase. (rust-1.34)[phases]{disable-codegen-tests}: Delete phase. (rust-1.35)[arguments]: Remove field. The disable-tidy-bins-check phase is now defined in rust-1.30. (rust-1.38)[phases]{patch-command-exec-tests-phase}: Remove. {patch-command-uid-gid-test}: Do not worry about the Tidy lint test, which is disabled. (rust-1.40)[phases]: Move #:validate-runpath? inside the use of 'substitute-keyword-arguments'. {neuter-tidy}: Delete. {patch-command-uid-gid-test}: Make the regexp more precise. Remove the TODO comment, which has been addressed. (rust-1.44)[inputs]: Replace python2 by python-wrapper. [phases]{use-python3}: New phase. (rust-1.45)[source]: Remove field. The linker locale fix is now made via ... [phases]{set-linker-locale-to-utf8}: ... this phase. (rust-1.46)[phases]{build, check}: Allow parallel execution. Add comments. {delete-install-logs}: Delete phase; it's now done in rust-1.30. (rust-1.47)[phases]{patch-cargo-checksums}: Do not reorder phase. The initial ordering of the phase has been fixed with in the rust-1.30 package. (rust-1.48)[source]: Remove field. Danny Milosavljevic 2021-02-05rust: Cleanup commit to prepare for new bootstrap....This commit is not atomic and is not functional by itself; this is done so to make the next set of changes more comprehensible. * gnu/packages/patches/rust-1.19-mrustc.patch: Delete file. * gnu/packages/patches/rust-1.30-gdb-llvm.patch: Likewise. * gnu/packages/patches/rust-bootstrap-stage0-test.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Un-register files. * gnu/packages/rust.scm (mrustc): Delete variable. (rust-1.19, rust-1.20, rust-1.21 rust-1.22, rust-1.23, rust-1.24) (rust-1.25, rust-1.26, rust-1.27, rust-1.28, rust-1.29) (rust-1.30): Delete variables. (rust-1.31 through rust-1.49): Fix indentation and do other cosmetic changes. (rust): Define as rust-1.49. Maxim Cournoyer 2021-01-10Merge branch 'master' into stagingEfraim Flashner 2021-01-02gnu: Add Rust 1.49....* gnu/packages/rust.scm (rust-1.49): New variable. Jakub Kądziołka 2021-01-02gnu: Add Rust 1.48....* gnu/packages/rust.scm (rust-1.48): New variable. Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net> Matthew Kraai 2021-01-02gnu: Add Rust 1.47....* gnu/packages/rust.scm (rust-1.47): New variable. Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net> Matthew Kraai 2020-12-29Merge branch 'ungrafting' into stagingMarius Bakke 2020-12-29gnu: rust: Remove "i686-linux" from supported systems....* gnu/packages/rust.scm (rust-1.19): Only support "x86_64-linux" architecture. Mathieu Othacehe 2020-12-13gnu: rust-1.46: Add rustfmt output...* gnu/packages/rust.scm (rust-1.46)[outputs]: Add a rustfmt output. [arguments]: Adjust to the new rustfmt output. Matthew Kraai 2020-10-05Merge branch 'master' into stagingGuillaume Le Vaillant 2020-09-25gnu: rust: Fix install phase for non-x86_64 platforms....* gnu/packages/rust.scm (rust-1.20)[arguments]: Replace hardcoded x86_64 triplet with nix-system->gnu-triplet-for-rust in 'delete-install-logs phase. Pierre Langlois 2020-09-23Merge branch 'staging' into wip-lispGuillaume Le Vaillant 2020-09-23gnu: Fix typoes in package descriptions....* gnu/packages/audio.scm (caps-plugins-lv2)[synopsis]: Fix typo. * gnu/packages/bioconductor.scm (r-karyoploter, r-anota, r-gcrma) (r-bigmemoryextras)[description]: Likewise. * gnu/packages/cran.scm (r-geometry)[synopsis]: Likewise. (r-stringdist, r-patchwork, r-depth, r-tea)[description]: Likewise. * gnu/packages/crates-io.scm (rust-assert-fs-0.11, rust-notify-4) (rust-tokio-fs-0.1)[synopsis, description]: Likewise. (rust-blas-sys-0.7)[description]: Likewise. (rust-fs-extra-1.1, rust-xattr-0.2)[synopsis]: Likewise. * gnu/packages/databases.scm (perl-mysql-config)[description]: Likewise. * gnu/packages/disk.scm (hddtemp)[description]: Likewise. * gnu/packages/django.scm (python-djangorestframework)[description]: Likewise. * gnu/packages/documentation.scm (doc++)[description]: Likewise. * gnu/packages/emacs-xyz.scm (emacs-kakoune, emacs-pyim-basedict, eless) (emacs-scpaste)[description]: Likewise. * gnu/packages/file-systems.scm (dbxfs)[description]: Likewise. * gnu/packages/finance.scm (python-stdnum)[description]: Likewise. * gnu/packages/fontutils.scm (woff2)[description]: Likewise. * gnu/packages/games.scm (openttd-opengfx)[description]: Likewise. * gnu/packages/gnome-xyz.scm (gnome-shell-extension-topicons-redux) [description]: Likewise. * gnu/packages/gnome.scm (libgrss)[description]: Likewise. * gnu/packages/golang.scm (go-github-com-mitchellh-reflectwalk) [description]: Likewise. (go-github-com-go-git-go-billy)[synopsis, description]: Likewise. * gnu/packages/haskell-check.scm (ghc-inspection-testing)[description]: Likewise. * gnu/packages/haskell-web.scm (ghc-yesod-form)[description]: Likewise. * gnu/packages/haskell-xyz.scm (ghc-hex)[description]: Likewise. * gnu/packages/hyperledger.scm (hyperledger-iroha-ed25519)[description]: Likewise. * gnu/packages/java.scm (java-mail)[synopsis]: Likewise. (java-native-access-platform)[description]: Likewise. * gnu/packages/kde-frameworks.scm (kactivities-stats)[description]: Likewise. * gnu/packages/kde-utils.scm (krusader)[description]: Likewise. * gnu/packages/language.scm (praat)[description]: Likewise. * gnu/packages/linux.scm (light)[description]: Likewise. * gnu/packages/lisp-xyz.scm (sbcl-hu.dwim.defclass-star)[description]: Likewise. * gnu/packages/mail.scm (dovecot-trees, sieve-connect)[description]: Likewise. * gnu/packages/ocaml.scm (ocaml-opam-file-format, ocaml-cppo) (ocaml4.07-ppx-variants-conv)[description]: Likewise. * gnu/packages/perl.scm (perl-convert-binhex)[description]: Likewise. * gnu/packages/python-crypto.scm (python-ecdsa)[description]: Likewise. * gnu/packages/python-web.scm (python-html5lib)[synopsis, description]: Likewise. (python-venusian)[synopsis]: Likewise. * gnu/packages/python-xyz.scm (python-readlike, python-gssapi) (python-flufl-i18n)[description]: Likewise. (python-pox, python-watchdog, python-xattr)[synopsis, description]: Likewise. * gnu/packages/ruby.scm (ruby-sorcerer)[description]: Likewise. * gnu/packages/rust-apps.scm (watchexec)[description]: Likewise. * gnu/packages/rust.scm (mrustc)[synopsis]: Likewise. * gnu/packages/shells.scm (s-shell)[description]: Likewise. * gnu/packages/ssh.scm (sshpass)[description]: Likewise. * gnu/packages/terminals.scm (beep)[description]: Likewise. * gnu/packages/web.scm (perl-lwp-useragent-cached)[description]: Likewise. * gnu/packages/wv.scm (wv)[description]: Likewise. Tobias Geerinckx-Rice 2020-09-07gnu: Add Rust 1.46....* gnu/packages/rust.scm (rust-1.46): New variable. Jakub Kądziołka 2020-09-05Merge remote-tracking branch 'origin/master' into stagingEfraim Flashner