;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014, 2015, 2017 Ludovic Courtès ;;; Copyright © 2015 Ricardo Wurmus ;;; Copyright © 2015, 2017 Andreas Enge ;;; Copyright © 2016, 2017, 2018 Efraim Flashner ;;; Copyright © 2017 Roel Janssen ;;; Copyright © 2018 Tobias Geerinckx-Rice ;;; Copyright © 2018 Leo Famulari ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages photo) #:use-module (guix build-system cmake) #:use-module (guix build-system gnu) #:use-module (guix build-system perl) #:use-module (guix download) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix utils) #:use-module (gnu packages) #:use-module (gnu packages algebra) #:use-module (gnu packages autotools) #:use-module (gnu packages base) #:use-module (gnu packages boost) #:use-module (gnu packages compression) #:use-module (gnu packages curl) #:use-module (gnu packages databases) #:use-module (gnu packages gettext) #:use-module (gnu packages ghostscript) #:use-module (gnu packages gl) #:use-module (gnu packages gnome) #:use-module (gnu packages glib) #:use-module (gnu pack
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gnu-doc)
  #:use-module (gnu packages base)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages texinfo)

  #:use-module (guix build-system gnu)
  #:use-module (guix build-system trivial)
  #:use-module (guix cvs-download)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages))

(define-public miscfiles
  (package
    (name "miscfiles")
    (version "1.5")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/" name "/" name "-"
                          version ".tar.gz"))
      (sha256
       (base32
        "005588vfrwx8ghsdv9p7zczj9lbc9a3r4m5aphcaqv8gif4siaka"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/miscfiles/")
    (synopsis
     "Data files for airport codes, zip codes, a dictionary, and more")
    (description
     "GNU Miscfiles is a collection of common data files.  They include, for
example, country abbreviations, names and capital cities; currency
abbreviations and names; a Best Current Practices index; a map of the ASCII
character set; a list of three-letter airport codes; and an English word
list.")
    (license gpl2+)))

(define-public gnu-standards
  (package
    (name "gnu-standards")
    (version "2020-11-25")
    (source
     (origin
       (method cvs-fetch)
       (uri (cvs-reference
             (root-directory
              ":pserver:anonymous@cvs.savannah.gnu.org:/sources/gnustandards")
             (module "gnustandards")
             (revision version)))
       (sha256
        (base32
         "1xlwmgcnvp81ipgfir4ckpgl922mbckvxy1x758r0lksq5vrpglj"))
       (file-name (string-append name "-" version "-checkout"))))
    (build-system trivial-build-system)
    (native-inputs `(("gzip" ,gzip)
                     ("source" ,source)
                     ("texinfo" ,texinfo)))
    (arguments
     `(#:modules ((guix build utils))
       #:builder
        (begin
          (use-modules (guix build utils))
          (let ((gzip (assoc-ref %build-inputs "gzip"))
                (source (assoc-ref %build-inputs "source"))
                (texinfo (assoc-ref %build-inputs "texinfo"))
                (info-dir (string-append %output "/share/info")))
            (setenv "PATH" (string-append gzip "/bin"
                                          ":" texinfo "/bin"))
            (mkdir-p info-dir)
            (invoke "makeinfo" "--output" info-dir
                    (string-append source "/maintain.texi"))
            (invoke "makeinfo" "--output" info-dir
                    (string-append source "/standards.texi"))
            (invoke "gzip" "-n" (string-append info-dir "/maintain.info"))
            (invoke "gzip" "-n" (string-append info-dir "/standards.info"))))))
    (home-page "https://www.gnu.org/prep/standards/")
    (synopsis "GNU coding standards and maintainer information")
    (description "The GNU Coding Standards were written by Richard Stallman
and other GNU Project volunteers.  Their purpose is to make the GNU system
clean, consistent, and easy to install.

The information for maintainers of GNU software has guidelines and advice for
someone who is the maintainer of a GNU program on behalf of the GNU Project.")
    (license fdl1.3+)))
turbo" ,libjpeg-turbo) ("popt" ,popt) ("libexif" ,libexif) ("libgphoto2" ,libgphoto2))) (arguments '(#:phases (modify-phases %standard-phases (add-before 'check 'pre-check (lambda* (#:key inputs #:allow-other-keys) (substitute* (find-files "tests/data" "\\.param$") (("/usr/bin/env") (which "env"))) #t))) ;; FIXME: There is 1 test failure, most likely related to the build ;; environment. #:tests? #f)) (home-page "http://www.gphoto.org/") (synopsis "Command-line tools to access digital cameras") (description "Gphoto2 is a set of command line utilities for manipulating a large number of different digital cameras. Through libgphoto2, it supports PTP, MTP, and much more.") ;; Files are typically under LGPLv2+, but 'COPYING' says GPLv2+. (license license:gpl2+))) (define-public perl-image-exiftool (package (name "perl-image-exiftool") (version "11.11") (source (origin (method url-fetch) (uri (string-append "mirror://cpan/authors/id/E/EX/EXIFTOOL/Image-ExifTool-" version ".tar.gz")) (sha256 (base32 "1szg1k82nz88pp5n7lg71ja7q3hh5i5f9bcbb7m482dwrmsywkp6")))) (build-system perl-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-after 'install 'post-install (lambda* (#:key outputs #:allow-other-keys) ;; Make sure the 'exiftool' commands finds the library. ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM? (let* ((out (assoc-ref outputs "out")) (pm (find-files out "^ExifTool\\.pm$")) (lib (dirname (dirname (car pm))))) (wrap-program (string-append out "/bin/exiftool") `("PERL5LIB" prefix (,lib))))))))) (home-page "https://metacpan.org/release/Image-ExifTool") (synopsis "Program and Perl library to manipulate EXIF and other metadata") (description "This package provides the @code{exiftool} command and the @code{Image::ExifTool} Perl library to manipulate EXIF tags of digital images and a wide variety of other metadata.") (license license:perl-license))) (define-public libpano13 (package (name "libpano13") (version "2.9.19") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/panotools/libpano13/" "libpano13-" version "/" "libpano13-" version ".tar.gz")) (sha256 (base32 "1a4m3plmfcrrplqs9zfzhc5apibn10m5sajpizm1sd3q74w5fwq3")))) (build-system cmake-build-system) (inputs `(("libjpeg" ,libjpeg) ("libpng" ,libpng) ("libtiff" ,libtiff) ("zlib" ,zlib))) (home-page "http://panotools.sourceforge.net/") (synopsis "Library for panoramic images") (description "The libpano13 package contains the backend library written by the Panorama Tools project for building panoramic images from a set of overlapping images, as well as some command line tools.") (license license:gpl2+))) (define-public enblend-enfuse (package (name "enblend-enfuse") (version "4.2") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/enblend/" name "/" name "-" (version-major+minor version) "/" name "-" version ".tar.gz")) (sha256 (base32 "0j5x011ilalb47ssah50ag0a4phgh1b0wdgxdbbp1gcyjcjf60w7")))) (build-system gnu-build-system) (native-inputs `(("pkg-config" ,pkg-config) ("perl" ,perl) ("perl-timedate" ,perl-timedate) ;; for building the documentation ("gnuplot" ,gnuplot) ("help2man" ,help2man) ("imagemagick" ,imagemagick) ("libxml2" ,libxml2) ("texlive-minimal" ,texlive-tiny) ("tidy" ,tidy) ("transfig" ,transfig))) (inputs `(("boost" ,boost) ("gsl" ,gsl) ("lcms" ,lcms) ("libjpeg" ,libjpeg) ("libpng" ,libpng) ("libtiff" ,libtiff) ("openexr" ,openexr) ("vigra" ,vigra) ("zlib" ,zlib))) (arguments `(#:configure-flags `("--enable-openmp"))) (home-page "http://enblend.sourceforge.net/") (synopsis "Tools for combining and blending images") (description "Enblend blends away the seams in a panoramic image mosaic using a multi-resolution spline. Enfuse merges different exposures of the same scene to produce an image that looks much like a tone-mapped image.") (license license:gpl2+))) (define-public lensfun (package (name "lensfun") (version "0.3.2") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/lensfun/" version "/lensfun-" version ".tar.gz")) (sha256 (base32 "0cfk8jjhs9nbfjfdy98plrj9ayi59aph0nx6ppslgjhlcvacm2xf")))) (build-system cmake-build-system) (arguments `(,@(if (any (cute string-prefix? <> (or (%current-system) (%current-target-system))) '("x86_64" "i686")) ;; SSE and SSE2 are supported only on Intel processors. '() '(#:configure-flags '("-DBUILD_FOR_SSE=OFF" "-DBUILD_FOR_SSE2=OFF"))) #:tests? #f)) ; There are no tests to run. (native-inputs `(("pkg-config" ,pkg-config))) (inputs `(("glib" ,glib))) (home-page "https://sourceforge.net/projects/lensfun/") (synopsis "Library to correct optical lens defects with a lens database") (description "Digital photographs are not ideal. Of course, the better is your camera, the better the results will be, but in any case if you look carefully at shots taken even by the most expensive cameras equipped with the most expensive lenses you will see various artifacts. It is very hard to make ideal cameras, because there are a lot of factors that affect the final image quality, and at some point camera and lens designers have to trade one factor for another to achieve the optimal image quality, within the given design restrictions and budget. But we all want ideal shots, don't we? So that's what's Lensfun is all about: rectifying the defects introduced by your photographic equipment.") ;; The libraries are licensed under the LGPL3, the programs are ;; licensed GPL3, and the database is license CC-BY-SA 3.0. See the ;; README.md file for this clarification. (license (list license:lgpl3 license:gpl3 license:cc-by-sa3.0)))) (define-public darktable (package (name "darktable") (version "2.4.4") (source (origin (method url-fetch) (uri (string-append "https://github.com/darktable-org/darktable/releases/" "download/release-" version "/darktable-" version ".tar.xz")) (sha256 (base32 "0kdhmiw4wxk2w9v2hms9yk8nl4ymdshnqyj0l07nivzzr6w20hwn")))) (build-system cmake-build-system) (arguments `(#:tests? #f ; There are no tests. #:configure-flags '("-DBINARY_PACKAGE_BUILD=On") #:make-flags (list (string-append "CPATH=" (assoc-ref %build-inputs "ilmbase") "/include/OpenEXR:" (or (getenv "CPATH") ""))) #:phases (modify-phases %standard-phases (add-before 'configure 'set-ldflags (lambda* (#:key outputs #:allow-other-keys) (setenv "LDFLAGS" (string-append "-Wl,-rpath=" (assoc-ref outputs "out") "/lib/darktable")) #t))))) (native-inputs `(("llvm" ,llvm-3.9.1) ("clang" ,clang-3.9.1))) (inputs `(("libxslt" ,libxslt) ("libxml2" ,libxml2) ("pugixml" ,pugixml) ("gtk+" ,gtk+) ("sqlite" ,sqlite) ("libjpeg" ,libjpeg) ("libpng" ,libpng) ("cairo" ,cairo) ("lcms" ,lcms) ("exiv2" ,exiv2) ("libtiff" ,libtiff) ("curl" ,curl) ("libgphoto2" ,libgphoto2) ("dbus-glib" ,dbus-glib) ("openexr" ,openexr) ("ilmbase" ,ilmbase) ("libsoup" ,libsoup) ("python-jsonschema" ,python-jsonschema) ("intltool" ,intltool) ("perl" ,perl) ("pkg-config" ,pkg-config) ("libwebp" ,libwebp) ("lensfun" ,lensfun) ("librsvg" ,librsvg) ("json-glib" ,json-glib) ("freeimage" ,freeimage))) (home-page "https://www.darktable.org") (synopsis "Virtual lighttable and darkroom for photographers") (description "Darktable is a photography workflow application and RAW developer. It manages your digital negatives in a database, lets you view them through a zoomable lighttable and enables you to develop raw images and enhance them.") ;; see src/is_supported_platform.h for supported platforms (supported-systems '("i686-linux" "x86_64-linux" "aarch64-linux")) (license license:gpl3+))) (define-public hugin (package (name "hugin") (version "2016.2.0") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/hugin/hugin/hugin-" (version-major+minor version) "/hugin-" version ".tar.bz2")) (sha256 (base32 "058zd63vx29yrx2pphbbll7kzcxkai22q26lpw13rn4lvp41pasl")))) (build-system cmake-build-system) (native-inputs `(("gettext" ,gnu-gettext) ("pkg-config" ,pkg-config))) (inputs `(("boost" ,boost) ("enblend-enfuse" ,enblend-enfuse) ("exiv2" ,exiv2) ("fftw" ,fftw) ("flann" ,flann) ("freeglut" ,freeglut) ("glew" ,glew) ("lcms" ,lcms) ("libjpeg" ,libjpeg) ("libpano13" ,libpano13) ("libpng" ,libpng) ("libtiff" ,libtiff) ("libxi" ,libxi) ("libxmu" ,libxmu) ("mesa" ,mesa) ("openexr" ,openexr) ("sqlite" ,sqlite) ("vigra" ,vigra) ("wxwidgets" ,wxwidgets) ("zlib" ,zlib))) (arguments `(#:tests? #f ; no check target #:configure-flags (list ;; The header files of ilmbase (propagated by openexr) are not found ;; when included by the header files of openexr, and an explicit ;; flag needs to be set. (string-append "-DCMAKE_CXX_FLAGS=-I" (assoc-ref %build-inputs "ilmbase") "/include/OpenEXR") ;; Disable installation of the Python scripting interface. ;; It would require the additional inputs python and swig. ;; Installation would need to be tweaked, as it tries to install ;; into the python directory. "-DBUILD_HSI=OFF") #:phases (modify-phases %standard-phases (add-before 'configure 'substitute (lambda _ (substitute* "src/hugin1/base_wx/StitchingExecutor.cpp" (("wxT\\(\"enblend\"\\)") (string-append "wxT(\"" (which "enblend") "\")")) (("wxT\\(\"enfuse\"\\)") (string-append "wxT(\"" (which "enfuse") "\")"))) #t))))) (home-page "http://hugin.sourceforge.net/") (synopsis "Panorama photo stitcher") (description "Hugin is an easy to use panoramic imaging toolchain with a graphical user interface. It can be used to assemble a mosaic of photographs into a complete panorama and stitch any series of overlapping pictures.") (license license:gpl2+))) (define-public rawtherapee (package (name "rawtherapee") (version "5.4") (source (origin (method url-fetch) (uri (string-append "http://rawtherapee.com/shared/source/" "rawtherapee-" version ".tar.xz")) (sha256 (base32 "1229hxqq824hcqg1hy2cfglsp7kjbhhis9m33ss39pgmrb1w227d")))) (build-system cmake-build-system) (arguments '(#:tests? #f ; no test suite #:build-type "release" #:configure-flags (list (string-append "-DLENSFUNDBDIR=" (assoc-ref %build-inputs "lensfun") "/share/lensfun") ; Don't optimize the build for the host machine. See the file ; 'ProcessorTargets.cmake' in the source distribution for more ; information. "-DPROC_TARGET_NUMBER=1" ; These flags are recommended by upstream for distributed packages. ; See the file 'RELEASE_NOTES.txt' in the source distribution. "-O3" "-DCACHE_NAME_SUFFIX=\"\""))) (native-inputs `(("pkg-config" ,pkg-config))) (inputs `(("expat" ,expat) ("fftw" ,fftwf) ("glib" ,glib) ("glibmm" ,glibmm) ("gtk+" ,gtk+) ("gtkmm" ,gtkmm) ("lcms" ,lcms) ("lensfun" ,lensfun) ("libcanberra" ,libcanberra) ("libiptcdata" ,libiptcdata) ("libjpeg" ,libjpeg) ("libpng" ,libpng) ("libsigc++" ,libsigc++) ("libtiff" ,libtiff) ("zlib" ,zlib))) (home-page "http://rawtherapee.com") (synopsis "Raw image developing and processing") (description "RawTherapee is a raw image processing suite. It comprises a subset of image editing operations specifically aimed at non-destructive raw photo post-production and is primarily focused on improving a photographer's workflow by facilitating the handling of large numbers of images. Most raw formats are supported, including Pentax Pixel Shift, Canon Dual-Pixel, and those from Foveon and X-Trans sensors.") (license license:gpl3+)))