aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gkrellm)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))

(define-public gkrellm
  (package
    (name "gkrellm")
    (version "2.3.11")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "http://gkrellm.srcbox.net/releases/gkrellm-"
                          version ".tar.bz2"))
      (sha256
       (base32 "01lccz4fga40isv09j8rjgr0qy10rff9vj042n6gi6gdv4z69q0y"))))
    (build-system gnu-build-system)
    (inputs
     `(("gettext" ,gettext-minimal)
       ("gtk+" ,gtk+-2)
       ("libice" ,libice)
       ("libsm" ,libsm)))
    (native-inputs
     (list pkg-config))
    (arguments
     `(#:tests? #f                      ; there is no check target
       #:phases
       (modify-phases %standard-phases
         (delete 'configure))           ; no configure script
       #:make-flags
       (let ((out (assoc-ref %outputs "out")))
         (list (string-append "INSTALLROOT=" out)
               "CC=gcc"))))
    (home-page "http://gkrellm.srcbox.net/")
    (synopsis "System monitors")
    (description
     "GKrellM is a single process stack of system monitors which supports
applying themes to match its appearance to your window manager, Gtk, or any
other theme.")
    (license license:gpl3+)))
Brett Gilio 2019-12-04gnu: Remove duplicate nlohmann-json-cpp package....* gnu/packages/serialization.scm (nlohmann-json-cpp): Move variable ... * gnu/packages/cpp.scm (nlohmann-json-cpp): ... here. Mark as deprecated by JSON-MODERN-CXX. * gnu/packages/jupyter.scm (xeus)[inputs]: Change NLOHMANN-JSON-CPP to JSON-MODERN-CXX. * gnu/packages/video.scm (mkvtoolnix)[inputs]: Likewise. Marius Bakke 2019-12-02gnu: ccls: Update to 0.20190823.5....* gnu/packages/cpp.scm (ccls): Update to 0.20190823.5. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Brett Gilio 2019-12-01gnu: Add sobjectizer....* gnu/packages/cpp.scm (sobjectizer): New variable. Jan Wielkiewicz 2019-11-21gnu: json-modern-cxx: Update to 3.7.3....* gnu/packages/cpp.scm (json-modern-cxx): Update to 3.7.3. Marius Bakke 2019-11-15gnu: Add cpplint....* gnu/packages/cpp.scm (cpplint): New variable. Mathieu Othacehe 2019-11-03gnu: xtl: Update to 0.6.8....* gnu/packages/cpp.scm (xtl): Update to 0.6.8. Tobias Geerinckx-Rice 2019-10-22gnu: Add gperftools....* gnu/packages/cpp.scm (gperftools): New variable. Pierre Neidhardt 2019-10-12gnu: json-modern-cxx: Update to 3.7.0....* gnu/packages/cpp.scm (json-modern-cxx): Update to 3.7.0. [source](snippet): Adjust for new doctest requirement. [native-inputs]: Add DOCTEST. [inputs]: Remove CATCH-FRAMEWORK2. Marius Bakke 2019-10-01Merge branch 'master' into core-updatesLudovic Courtès 2019-09-28gnu: xtl: Update to 0.6.7....* gnu/packages/cpp.scm (xtl): Update to 0.6.7. Tobias Geerinckx-Rice 2019-09-26gnu: Add ccls....* gnu/packages/cpp.scm (ccls): New variable. Mathieu Othacehe 2019-06-07gnu: dashel: Don't use unstable tarball....* gnu/packages/cpp.scm (dashel)[source]: Use GIT-FETCH and GIT-FILE-NAME. [home-page]: Move down to its conventional spot. Tobias Geerinckx-Rice 2019-06-07gnu: xsimd: Update to 7.2.3....* gnu/packages/cpp.scm (xsimd): Update to 7.2.3. [arguments]: Add a configure flag required to build the tests. Tobias Geerinckx-Rice 2019-06-07gnu: xsimd: Don't use unstable tarball....* gnu/packages/cpp.scm (xsimd)[source]: Use GIT-FETCH and GIT-FILE-NAME. [home-page]: Move down to its conventional spot. Tobias Geerinckx-Rice 2019-05-11gnu: xtl: Update to 0.6.4....* gnu/packages/cpp.scm (xtl): Update to 0.6.4. Tobias Geerinckx-Rice 2019-04-19gnu: rct: Be more idiomatic....* gnu/packages/cpp.scm (rct): Move the call to 'git-version' into the package definition. [source]: Explicitly include the source URI rather than using 'home-page'. Leo Famulari