aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gcal)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses))

(define-public gcal
  (package
    (name "gcal")
    (version "4.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/gcal/gcal-"
                                 version ".tar.xz"))
             (sha256
              (base32
               "1av11zkfirbixn05hyq4xvilin0ncddfjqzc4zd9pviyp506rdci"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 ;; Adjust the bundled gnulib to work with glibc 2.28.  See e.g.
                 ;; "m4-gnulib-libio.patch".  This is a phase rather than patch
                 ;; or snippet to work around <https://bugs.gnu.org/32347>.
                 (substitute* (find-files "lib" "\\.c$")
                   (("#if defined _IO_ftrylockfile")
                    "#if defined _IO_EOF_SEEN"))
                 (substitute* "lib/stdio-impl.h"
                   (("^/\\* BSD stdio derived implementations")
                    (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
                                   "# define _IO_IN_BACKUP 0x100\n"
                                   "#endif\n\n"
                                   "/* BSD stdio derived implementations")))
                 #t))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/gcal/")
    (synopsis "Calculating and printing a wide variety of calendars")
    (description
     "Gcal is a program to calculate and print calendars on the
command-line.  Calendars can be printed in 1-month, 3-month or whole-year
views.  In addition, eternal holiday lists can be generated for many
countries, which can be complemented by user-made lists of fixed dates to
make an agenda.  Gcal can also calculate astronomical data, such as the
phases of the moon, and supports alternative calendar formats: Julian,
Gregorian, Islamic, Chinese and more.")
    (license gpl3+)))
NUX-LIBRE-X.Y-VERSION variables. Leo Famulari 2020-09-06gnu: Do not truncate the version of the linux-libre deblobbing script file na......* gnu/packages/linux.scm (linux-libre-deblob-scripts): Use VERSION instead of VERSION-MAJOR+MINOR. Leo Famulari 2020-09-06gnu: linux-libre: Update to 5.8.7....* gnu/packages/linux.scm (linux-libre-5.8-version): Update to 5.8.7. (linux-libre-5.8-pristine-source): Update hash. (deblob-scripts-5.8): Update to 5.8.7. Mark H Weaver 2020-09-06gnu: linux-libre@5.4: Update to 5.4.63....* gnu/packages/linux.scm (linux-libre-5.4-version): Update to 5.4.63. (linux-libre-5.4-pristine-source): Update hash. (deblob-scripts-5.4): Update to 5.4.63. Mark H Weaver 2020-09-04gnu: linux-libre: Validate that the cleaned up tarball is free of blobs....* gnu/packages/linux.scm (make-linux-libre-source): Call the deblob-check script on the generated tarball archive with the --use-awk and --list-blobs options. Maxim Cournoyer 2020-09-04gnu: make-linux-libre-source: Set output port buffering to line mode....* gnu/packages/linux.scm (make-linux-libre-source): Set output port buffering to line mode via setvbuf. Remove the ad-hoc calls to force-output. Maxim Cournoyer 2020-09-03gnu: linux-libre: Use Python 3 in make-linux-libre-source....Successfully tested with all of the linux-libre versions we carry in Guix: 4.4.234, 4.9.234, 4.14.195, 4.19.142, 5.4.61 and 5.8.5. * gnu/packages/linux.scm (make-linux-libre-source): Replace python-2 by python-wrapper. Do not set the PYTHON environment variable, which is not required when using python-wrapper. Maxim Cournoyer 2020-09-03gnu: linux-libre: Update to 5.8.6....* gnu/packages/linux.scm (linux-libre-5.8-version): Update to 5.8.6. (linux-libre-5.8-pristine-source): Update hash. (deblob-scripts-5.8): Update to 5.8.6. Mark H Weaver 2020-09-03gnu: linux-libre@5.4: Update to 5.4.62....* gnu/packages/linux.scm (linux-libre-5.4-version): Update to 5.4.62. (linux-libre-5.4-pristine-source): Update hash. (deblob-scripts-5.4): Update to 5.4.62. Mark H Weaver 2020-09-03gnu: linux-libre@4.19: Update to 4.19.143....* gnu/packages/linux.scm (linux-libre-4.19-version): Update to 4.19.143. (linux-libre-4.19-pristine-source): Update hash. (deblob-scripts-4.19): Update to 4.19.143. Mark H Weaver 2020-09-03gnu: linux-libre@4.14: Update to 4.14.196....* gnu/packages/linux.scm (linux-libre-4.14-version): Update to 4.14.196. (linux-libre-4.14-pristine-source): Update hash. (deblob-scripts-4.14): Update to 4.14.196. Mark H Weaver 2020-09-03gnu: linux-libre@4.9: Update to 4.9.235....* gnu/packages/linux.scm (linux-libre-4.9-version): Update to 4.9.235. (linux-libre-4.9-pristine-source): Update hash. (deblob-scripts-4.9): Update to 4.9.235. Mark H Weaver 2020-09-03gnu: linux-libre@4.4: Update to 4.4.235....* gnu/packages/linux.scm (linux-libre-4.4-version): Update to 4.4.235. (linux-libre-4.4-pristine-source): Update hash. (deblob-scripts-4.4): Update to 4.4.235. Mark H Weaver 2020-09-02gnu: xfsprogs: Update to 5.7.0....* gnu/packages/linux.scm (xfsprogs): Update to 5.7.0. Efraim Flashner 2020-09-01gnu: %default-extra-linux-options: Enable kernel options for elogind service....Fixes: https://issues.guix.gnu.org/43078 These options are already enabled in the kernel configs included in guix, but might be missing from variants using a defconfig from the upstream kernel, such as linux-libre-arm-generic and linux-libre-arm64-generic. * gnu/packages/linux (%default-extra-linux-options): Enable CONFIG_CGROUP_FREEZER, CONFIG_BLK_CGROUP, CONFIG_CGROUP_WRITEBACK, CONFIG_CGROUP_SCHED, CONFIG_CGROUP_PIDS, CONFIG_CGROUP_FREEZER, CONFIG_CGROUP_DEVICE, CONFIG_CGROUP_CPUACCT, CONFIG_CGROUP_PERF, CONFIG_SOCK_CGROUP_DATA, CONFIG_BLK_CGROUP_IOCOST, CONFIG_CGROUP_NET_PRIO, CONFIG_CGROUP_NET_CLASSID, CONFIG_MEMCG, CONFIG_MEMCG_SWAP, CONFIG_MEMCG_KMEM, CONFIG_CPUSETS and CONFIG_PROC_PID_CPUSET. Vagrant Cascadian 2020-09-01gnu: wireless-regdb: Update to 2020.04.29....* gnu/packages/linux.scm (wireless-regdb): Update to 2020.04.29. Efraim Flashner 2020-08-30gnu: Remove linux-libre 5.7....The 5.7 kernel series is no longer supported upstream. * gnu/packages/linux.scm (deblob-scripts-5.7, linux-libre-5.7-version, linux-libre-5.7-pristine-source, linux-libre-5.7-source, linux-libre-headers-5.7, linux-libre-5.7) Remove variables. * gnu/packages/aux-files/linux-libre/5.7-arm.conf, gnu/packages/aux-files/linux-libre/5.7-arm64.conf, gnu/packages/aux-files/linux-libre/5.7-i686.conf, gnu/packages/aux-files/linux-libre/5.7-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them. Leo Famulari 2020-08-27gnu: linux-libre: Update to 5.8.5....* gnu/packages/linux.scm (linux-libre-5.8-version): Update to 5.8.5. (linux-libre-5.8-pristine-source): Update hash. Mark H Weaver 2020-08-27gnu: linux-libre@5.7: Update to 5.7.19....* gnu/packages/linux.scm (linux-libre-5.7-version): Update to 5.7.19. (linux-libre-5.7-pristine-source): Update hash. Mark H Weaver 2020-08-26gnu: linux-libre@5.7: Update to 5.7.18....* gnu/packages/linux.scm (linux-libre-5.7-version): Update to 5.7.18. (linux-libre-5.7-pristine-source): Update hash. (deblob-scripts-5.7): Update to 5.7.18. Mark H Weaver 2020-08-26gnu: linux-libre@5.4: Update to 5.4.61....* gnu/packages/linux.scm (linux-libre-5.4-version): Update to 5.4.61. (linux-libre-5.4-pristine-source): Update hash. (deblob-scripts-5.4): Update to 5.4.61. Mark H Weaver 2020-08-26gnu: linux-libre@4.19: Update to 4.19.142....* gnu/packages/linux.scm (linux-libre-4.19-version): Update to 4.19.142. (linux-libre-4.19-pristine-source): Update hash. (deblob-scripts-4.19): Update to 4.19.142. Mark H Weaver 2020-08-26gnu: linux-libre@4.14: Update to 4.14.195....* gnu/packages/linux.scm (linux-libre-4.14-version): Update to 4.14.195. (linux-libre-4.14-pristine-source): Update hash. (deblob-scripts-4.14): Update to 4.14.195. Mark H Weaver 2020-08-26gnu: linux-libre@4.9: Update to 4.9.234....* gnu/packages/linux.scm (linux-libre-4.9-version): Update to 4.9.234. (linux-libre-4.9-pristine-source): Update hash. (deblob-scripts-4.9): Update to 4.9.234. Mark H Weaver 2020-08-26gnu: linux-libre@4.4: Update to 4.4.234....* gnu/packages/linux.scm (linux-libre-4.4-version): Update to 4.4.234. (linux-libre-4.4-pristine-source): Update hash. (deblob-scripts-4.4): Update to 4.4.234. Mark H Weaver 2020-08-26gnu: linux-libre: Update to 5.8.4....* gnu/packages/linux.scm (linux-libre-5.8-version): Update to 5.8.4. (linux-libre-5.8-pristine-source): Update hash. (deblob-scripts-5.8): Update to 5.8.4. Mark H Weaver 2020-08-26gnu: pipewire: Update to 0.3.10....* gnu/packages/linux.scm (pipewire): Update to 0.3.10. [arguments]: Set the ‘udevrulesdir’ configure flag. Tobias Geerinckx-Rice 2020-08-24gnu: Remove duplicated linux-libre-arm64-generic-5.8....This fixes a test failure in "fold-available-packages with/without cache". * gnu/packages/linux.scm (linux-libre-arm64-generic-5.8): Remove it as it duplicates linux-libre-arm64-generic. Mathieu Othacehe 2020-08-21gnu: linux-libre@4.9: Update to 4.9.233....* gnu/packages/linux.scm (linux-libre-4.9-version): Update to 4.9.233. (linux-libre-4.9-pristine-source): Update hash. (deblob-scripts-4.9): Update to 4.9.232. Mark H Weaver 2020-08-21gnu: linux-libre@4.4: Update to 4.4.233....* gnu/packages/linux.scm (linux-libre-4.4-version): Update to 4.4.233. (linux-libre-4.4-pristine-source): Update hash. (deblob-scripts-4.4): Update to 4.4.232. Mark H Weaver 2020-08-21gnu: linux-libre: Update to 5.8.3....* gnu/packages/linux.scm (linux-libre-5.8-version): Update to 5.8.3. (linux-libre-5.8-pristine-source): Update hash. Mark H Weaver 2020-08-21gnu: linux-libre@5.7: Update to 5.7.17....* gnu/packages/linux.scm (linux-libre-5.7-version): Update to 5.7.17. (linux-libre-5.7-pristine-source): Update hash. Mark H Weaver 2020-08-21gnu: linux-libre@5.4: Update to 5.4.60....* gnu/packages/linux.scm (linux-libre-5.4-version): Update to 5.4.60. (linux-libre-5.4-pristine-source): Update hash. Mark H Weaver 2020-08-21gnu: linux-libre@4.19: Update to 4.19.141....* gnu/packages/linux.scm (linux-libre-4.19-version): Update to 4.19.141. (linux-libre-4.19-pristine-source): Update hash. Mark H Weaver 2020-08-21gnu: linux-libre@4.14: Update to 4.14.194....* gnu/packages/linux.scm (linux-libre-4.14-version): Update to 4.14.194. (linux-libre-4.14-pristine-source): Update hash. Mark H Weaver 2020-08-21gnu: linux-libre: Update to 5.8.2....* gnu/packages/aux-files/linux-libre/5.8-arm.conf, gnu/packages/aux-files/linux-libre/5.8-arm64.conf, gnu/packages/aux-files/linux-libre/5.8-i686.conf, gnu/packages/aux-files/linux-libre/5.8-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them. * gnu/packages/linux.scm (linux-libre-5.8): New variable. (linux-libre-version, linux-libre-pristine-source, linux-libre-source, linux-libre): Point to linux-libre-5.8*. Leo Famulari 2020-08-21gnu: Use a descriptive file-name for linux-libre deblobbing scripts....Fixes <https://bugs.gnu.org/42789>. * gnu/packages/linux.scm (linux-libre-deblob-scripts): Set the file-name of the deblob and deblob-check scripts. Leo Famulari 2020-08-19gnu: linux-libre: Update to 5.7.16....* gnu/packages/linux.scm (linux-libre-5.7-version): Update to 5.7.16. (linux-libre-5.7-pristine-source): Update hash. (deblob-scripts-5.7): Update to 5.7.16. Mark H Weaver 2020-08-19gnu: linux-libre@5.8: Update to 5.8.2....* gnu/packages/linux.scm (linux-libre-5.8-version): Update to 5.8.2. (linux-libre-5.8-pristine-source): Update hash. (deblob-scripts-5.8): Update to 5.8.2. Mark H Weaver 2020-08-19gnu: linux-libre@5.4: Update to 5.4.59....* gnu/packages/linux.scm (linux-libre-5.4-version): Update to 5.4.59. (linux-libre-5.4-pristine-source): Update hash. (deblob-scripts-5.4): Update to 5.4.59. Mark H Weaver 2020-08-19gnu: linux-libre@4.19: Update to 4.19.140....* gnu/packages/linux.scm (linux-libre-4.19-version): Update to 4.19.140. (linux-libre-4.19-pristine-source): Update hash. (deblob-scripts-4.19): Update to 4.19.140. Mark H Weaver 2020-08-19gnu: lvm2: Default to an HTTPS mirror....* gnu/packages/linux.scm (lvm2)[source]: Talk HTTPS to sourceware.org. Tobias Geerinckx-Rice 2020-08-19gnu: lvm2: Update to 2.03.10....* gnu/packages/linux.scm (lvm2): Update to 2.03.10. Tobias Geerinckx-Rice 2020-08-19gnu: sysstat: Update to 12.4.0....* gnu/packages/linux.scm (sysstat): Update to 12.4.0. Tobias Geerinckx-Rice 2020-08-15gnu: earlyoom: Use pandoc instead of ghc-pandoc....* gnu/packages/linux.scm (earlyoom)[native-inputs]: Use pandoc instead of ghc-pandoc. Ricardo Wurmus