aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gcal)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses))

(define-public gcal
  (package
    (name "gcal")
    (version "4.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/gcal/gcal-"
                                 version ".tar.xz"))
             (sha256
              (base32
               "1av11zkfirbixn05hyq4xvilin0ncddfjqzc4zd9pviyp506rdci"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 ;; Adjust the bundled gnulib to work with glibc 2.28.  See e.g.
                 ;; "m4-gnulib-libio.patch".  This is a phase rather than patch
                 ;; or snippet to work around <https://bugs.gnu.org/32347>.
                 (substitute* (find-files "lib" "\\.c$")
                   (("#if defined _IO_ftrylockfile")
                    "#if defined _IO_EOF_SEEN"))
                 (substitute* "lib/stdio-impl.h"
                   (("^/\\* BSD stdio derived implementations")
                    (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
                                   "# define _IO_IN_BACKUP 0x100\n"
                                   "#endif\n\n"
                                   "/* BSD stdio derived implementations")))
                 #t))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/gcal/")
    (synopsis "Calculating and printing a wide variety of calendars")
    (description
     "Gcal is a program to calculate and print calendars on the
command-line.  Calendars can be printed in 1-month, 3-month or whole-year
views.  In addition, eternal holiday lists can be generated for many
countries, which can be complemented by user-made lists of fixed dates to
make an agenda.  Gcal can also calculate astronomical data, such as the
phases of the moon, and supports alternative calendar formats: Julian,
Gregorian, Islamic, Chinese and more.")
    (license gpl3+)))
href='/guix/commit/nix/libstore?id=dc0f74e5fc26977a3ee6c4f2aa74a141f4359982'>Add (guix status) and use it for pretty colored output....Ludovic Courtès 2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès 2018-06-14database: 'with-database' can now initialize new databases....Ludovic Courtès 2018-05-17daemon: Allow building for armhf-linux on aarch64-linux....Efraim Flashner 2018-03-30daemon: Remove unused schema upgrade code....Ludovic Courtès 2018-03-30daemon: Remove dead code....Ludovic Courtès 2018-01-11daemon: Always try to execute the builder regardless of the platform....Ludovic Courtès 2018-01-07daemon: Make libbz2 an optional dependency....Ludovic Courtès 2018-01-07daemon: Add gzip log compression....Ludovic Courtès 2017-08-18Simplify remouting with MS_PRIVATE in sandbox build...Jörg Thalheim 2017-08-07daemon: Ensure the child stack is aligned on a 16-byte boundary....Mark H Weaver 2017-08-05daemon: On aarch64, use increments of 16 on the stack....Efraim Flashner 2017-08-05Revert "daemon: Ensure proper alignment on the stack."...Mark H Weaver 2017-05-30daemon: Report hash mismatches in a cleaner way....Ludovic Courtès 2017-02-20daemon: Ensure proper alignment on the stack....Efraim Flashner 2017-02-07daemon: Define 'NIX_STORE' before invoking 'guix perform-download'....Ludovic Courtès 2017-01-15daemon: Client settings no longer override daemon settings....Ludovic Courtès 2017-01-11daemon: Allow check builds of 'builtin:download' derivations....Ludovic Courtès 2016-12-29daemon: Allow fixed-output derivation builds with TMPDIR set....Ludovic Courtès 2016-12-09daemon: Set ownership of kept build directories to the calling user....Hartmut Goebel 2016-12-05daemon: Fix invalid Boost format string....Ludovic Courtès 2016-11-16daemon: Add 'built-in-builders' RPC....Ludovic Courtès 2016-11-16daemon: Add "builtin:download" derivation builder....Ludovic Courtès 2016-10-28daemon: Do not error out when deduplication fails due to ENOSPC....Ludovic Courtès 2016-10-28daemon: Improve the SQLite wrapper API....Eelco Dolstra 2016-10-28daemon: Factor out SQLite handling....Eelco Dolstra 2016-10-28daemon: Turn retrying SQLite transactions into a higher-order function....Eelco Dolstra 2016-06-26daemon: Rename 'NIX_CONF_DIR' to 'GUIX_CONFIGURATION_DIRECTORY'....David Craven 2016-05-31daemon: Substitute queries return immediately when substitutes are disabled....Ludovic Courtès 2016-05-31daemon: Fix typo....Ludovic Courtès 2016-05-31daemon: rounds: Keep the differing output if -K is given....Eelco Dolstra 2016-05-31daemon: Canonicalize gids to 0....Eelco Dolstra 2016-05-31daemon: check: Keep the differing output if -K is given....Eelco Dolstra 2016-05-31daemon: check: Fix "failed to produce output path"....Eelco Dolstra 2016-05-31daemon: check: Fix assertion failure when some outputs are missing....Eelco Dolstra 2016-05-31daemon: When repairing, rebuild if there is no substituter.Eelco Dolstra 2016-05-31daemon: Fix --repair failure on multiple-output derivations....Eelco Dolstra 2016-05-31daemon: ~PathLocks(): Handle exceptions....Eelco Dolstra 2016-05-31daemon: Handle /tmp being a symlink....Eelco Dolstra