aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages fvwm)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages fribidi)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages image)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))

(define-public fvwm
  (package
    (name "fvwm")
    (version "2.7.0")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/fvwmorg/fvwm/releases/download/"
                    version "/fvwm-" version ".tar.gz"))
              (sha256
               (base32
                "12s1wgkvrvl8m62gpb2918izfx9ysj7hgn9p00blfi3p1gb6v0k6"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-after 'install 'install-xsession
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (xsessions (string-append out "/share/xsessions")))
               (mkdir-p xsessions)
               (make-desktop-entry-file
                 (string-append xsessions "/fvwm2.desktop")
                 #:name "FVWM"
                 #:exec (string-append out "/bin/" ,name)
                 #:comment '("FVWM")))
             #t)))))
    (native-inputs
     `(("perl" ,perl)
       ("pkg-config" ,pkg-config)
       ("xsltproc" ,libxslt)))
    (inputs
     (list fribidi
           libpng
           (librsvg-for-system)
           libxcursor
           libxext
           libxft
           libxinerama
           libxpm
           libxt
           readline))
    (synopsis "Virtual window manager for X11")
    (description
     "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
window manager for the X Window system.")
    (home-page "https://www.fvwm.org/")
    (license gpl2+)))
span>gnu: vim: Update to 9.1.0146....* gnu/packages/vim.scm (vim): Update to 9.1.0146. [arguments]: Adjust 'patch-absolute-paths phase to patch another /bin/sh invocation. Change-Id: I61e65988b96561bd10c9d35506e24c702cfb38d3 Efraim Flashner 2024-02-22gnu: Add neovim-dispatch....* gnu/packages/vim.scm (neovim-dispatch): New variable. Change-Id: I458b0d390168170b47119c7f592042177f1402ae Efraim Flashner 2024-02-22gnu: vim-dispatch: Update to 1.8-1.4c695bc....* gnu/packages/vim.scm (vim-dispatch): Update to 1.8-1.4c695bc. Change-Id: I70b53f048c365fda47ba8820392b1f94b6bcfedd Efraim Flashner 2024-02-22gnu: Add neovim-asyncrun....* gnu/packages/vim.scm (neovim-asyncrun): New variable. Change-Id: I8716ff4a1beeee3364973c12e0e6243a1b21afe6 Efraim Flashner 2024-02-22gnu: vim-asyncrun: Update to 2.12.4....* gnu/packages/vim.scm (vim-asyncrun): Update to 2.12.4. Change-Id: I316eb22c71ac4e807b9fd4590c7819478e4f7260 Efraim Flashner 2024-02-10gnu: vim: Update to 9.1.0059....* gnu/packages/vim.scm (vim): Update to 9.1.0059. Change-Id: Idf89d04a6c4e2297bcaad7a8b275de4a124001a9 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Nguyễn Gia Phong