aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages fvwm)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages fribidi)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages image)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))

(define-public fvwm
  (package
    (name "fvwm")
    (version "2.7.0")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/fvwmorg/fvwm/releases/download/"
                    version "/fvwm-" version ".tar.gz"))
              (sha256
               (base32
                "12s1wgkvrvl8m62gpb2918izfx9ysj7hgn9p00blfi3p1gb6v0k6"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-after 'install 'install-xsession
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (xsessions (string-append out "/share/xsessions")))
               (mkdir-p xsessions)
               (make-desktop-entry-file
                 (string-append xsessions "/fvwm2.desktop")
                 #:name "FVWM"
                 #:exec (string-append out "/bin/" ,name)
                 #:comment '("FVWM")))
             #t)))))
    (native-inputs
     `(("perl" ,perl)
       ("pkg-config" ,pkg-config)
       ("xsltproc" ,libxslt)))
    (inputs
     (list fribidi
           libpng
           (librsvg-for-system)
           libxcursor
           libxext
           libxft
           libxinerama
           libxpm
           libxt
           readline))
    (synopsis "Virtual window manager for X11")
    (description
     "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
window manager for the X Window system.")
    (home-page "https://www.fvwm.org/")
    (license gpl2+)))
ll-mozilla-locales): Export it. * gnu/packages/tor.scm (%torbrowser-locales, translation-base-browser, translation-tor-browser): New variables. (torbrowser)[arguments]: In ‘setenv’ phase, set MOZ_CHROME_MULTILOCALE. Add ‘copy-firefox-locales’, ‘copy-basebrowser-locales’, ‘copy-torbrowser-locales’ and ‘build-locales’ phases. Change-Id: Ia5b28fa5d885f24140893dc270e57e83b0250c67 Clément Lassieur 2024-01-19gnu: torbrowser: Remove useless inputs....One should never change assets, so no point being an input. * gnu/packages/tor.scm (torbrowser)[arguments]: In the ‘deploy-assets’ phase, directly refer to ‘torbrowser-assets’. [inputs]: Remove ‘torbrowser-assets’ and ‘bash-minimal’. Change-Id: I096f430e8277021462afffa65983ed2a8af08ed2 Clément Lassieur 2024-01-12gnu: torbrowser: Add bridges....* gnu/packages/tor.scm (torbrowser)[arguments]: Add an 'add-bridges' phase, update the 'deploy-assets' phase so to fix the lyrebird path. [inputs]: Add go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-lyrebird. Change-Id: I17c85486ab44178be9eab31a078f6392857a044f Clément Lassieur 2023-12-28gnu: torbrowser: Change version to 13.0.8....* gnu/packages/tor.scm (%torbrowser-version): New variable. (%torbrowser-firefox-version): New variable. (torbrowser-assets)[version]: Use %torbrowser-version. (torbrowser)[version]: Use %torbrowser-version. [source]: Use %torbrowser-firefox-version. [arguments]: Use the package version. Change-Id: I4d262e0a9528ff515da89c31589d88201dcdf941 Clément Lassieur 2023-12-27gnu: Add torbrowser....* gnu/packages/tor.scm (torbrowser): New variable. (torbrowser-assets): New variable. * gnu/packages/browser-extensions.scm (noscript): New variable. (noscript/icecat): New variable. Co-authored-by: André Batista <nandre@riseup.net> Change-Id: I73dc53905e4a028108bb34aae07e44256cf16c85 Clément Lassieur 2023-12-10gnu: tor: Update to 0.4.8.10....* gnu/packages/tor.scm (tor): Update to 0.4.8.10. Change-Id: Ibc11c83c3fea920c6b876a22cb4c96d5c927beb5 Efraim Flashner 2023-11-15gnu: tor: Update to 0.4.8.9 [security fixes]....* gnu/packages/tor.scm (tor): Update to 0.4.8.9. This release fixes two high severity security vulnerabilities. The first one affects client connections to Guard relays and the other one affects Onion Services (TROVE-2023-006). See https://gitlab.torproject.org/tpo/core/tor/-/issues/40876 and https://gitlab.torproject.org/tpo/core/tor/-/issues/40883 Signed-off-by: Ludovic Courtès <ludo@gnu.org> André Batista 2023-11-09gnu: tor: Update to 0.4.8.8 [fixes TROVE-2023-004]....* gnu/packages/tor.scm (tor): Update to 0.4.8.8. Fixes TROVE-2023-004 which affects tor relays. See https://gitlab.torproject.org/tpo/core/tor/-/issues/40880 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> André Batista 2023-10-24gnu: tor: Update to 0.4.8.7....* gnu/packages/tor.scm (tor): Update to 0.4.8.7. Signed-off-by: Ludovic Courtès <ludo@gnu.org> André Batista 2023-09-18gnu: tor: Update to 0.4.8.6....* gnu/packages/tor.scm (tor): Update to 0.4.8.6. [source]: Remove patch. * gnu/packages/patches/tor-remove-defensive-assert.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Efraim Flashner 2023-09-14gnu: tor: Update to 0.4.8.5....* gnu/packages/tor.scm (tor): Update to 0.4.8.5. * gnu/packages/tor.scm (tor)[arguments]<#:configure-flags>: Add "--enable-gpl". * gnu/packages/patches/tor-remove-defensive-assert.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/tor.scm (tor)[source]: Add patch to remove defensive assert. Signed-off-by: Ludovic Courtès <ludo@gnu.org> fanquake 2023-08-16gnu: tor: Update to 0.4.7.14....* gnu/packages/tor.scm (tor): Update to 0.4.7.14. Signed-off-by: Ludovic Courtès <ludo@gnu.org> fanquake