aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages fvwm)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages fribidi)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages image)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))

(define-public fvwm
  (package
    (name "fvwm")
    (version "2.7.0")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/fvwmorg/fvwm/releases/download/"
                    version "/fvwm-" version ".tar.gz"))
              (sha256
               (base32
                "12s1wgkvrvl8m62gpb2918izfx9ysj7hgn9p00blfi3p1gb6v0k6"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-after 'install 'install-xsession
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (xsessions (string-append out "/share/xsessions")))
               (mkdir-p xsessions)
               (make-desktop-entry-file
                 (string-append xsessions "/fvwm2.desktop")
                 #:name "FVWM"
                 #:exec (string-append out "/bin/" ,name)
                 #:comment '("FVWM")))
             #t)))))
    (native-inputs
     `(("perl" ,perl)
       ("pkg-config" ,pkg-config)
       ("xsltproc" ,libxslt)))
    (inputs
     (list fribidi
           libpng
           (librsvg-for-system)
           libxcursor
           libxext
           libxft
           libxinerama
           libxpm
           libxt
           readline))
    (synopsis "Virtual window manager for X11")
    (description
     "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
window manager for the X Window system.")
    (home-page "https://www.fvwm.org/")
    (license gpl2+)))
ing 2019-09-12gnu: openconnect: Update to 8.05 [fixes CVE-2019-16239]....* gnu/packages/vpn.scm (openconnect): Update to 8.05. Tobias Geerinckx-Rice 2019-09-07gnu: wireguard: Update to 0.0.20190905....* gnu/packages/vpn.scm (wireguard): Update to 0.0.20190905. Rutger Helling 2019-08-11gnu: openconnect: Update to 8.04....* gnu/packages/vpn.scm (openconnect): Update to 8.04. Tobias Geerinckx-Rice 2019-08-07gnu: ocproxy: Remove extra build phase....* gnu/packages/vpn.scm (ocproxy)[arguments]: Remove unneeded 'autogen phase. Efraim Flashner 2019-08-07gnu: openconnect: Fix propagated-inputs....* gnu/packages/vpn.scm (openconnect)[inputs]: Move libxml2, gnutls, zlib ... [propagated-inputs]: ... to here. Efraim Flashner 2019-07-03gnu: wireguard: Update to 0.0.20190702....* gnu/packages/vpn.scm (wireguard): Update to 0.0.20190702. Rutger Helling 2019-06-02gnu: WireGuard: Update to 0.0.20190601....* gnu/packages/vpn.scm (wireguard): Update to 0.0.20190601. Leo Famulari 2019-05-20gnu: openconnect: Update to 8.03....* gnu/packages/vpn.scm (openconnect): Update to 8.03. Tobias Geerinckx-Rice 2019-04-24gnu: xl2tpd: Don't use NAME in source URI....* gnu/packages/vpn.scm (xl2tpd)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-04-24gnu: xl2tpd: Update to 1.3.14....* gnu/packages/vpn.scm (xl2tpd): Update to 1.3.14. Tobias Geerinckx-Rice 2019-04-08gnu: wireguard: Update to 0.0.20190406....* gnu/packages/vpn.scm (wireguard): Update to 0.0.20190406. Rutger Helling 2019-04-04gnu: Move nss & co. to nss.scm....* gnu/packages/gnuzilla.scm (nspr, nss): Move to... * gnu/packages/nss.scm: ... here. New file. * gnu/packages/chromium.scm, gnu/packages/disk.scm, gnu/packages/freedesktop.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/java.scm, gnu/packages/libreoffice.scm, gnu/packages/linux.scm, gnu/packages/mate.scm, gnu/packages/openldap.scm, gnu/packages/package-management.scm, gnu/packages/password-utils.scm, gnu/packages/polkit.scm, gnu/packages/qt.scm, gnu/packages/sssd.scm, gnu/packages/storage.scm, gnu/packages/vpn.scm, gnu/packages/web.scm, gnu/packages/xml.scm: Adjust accordingly. * gnu/local.mk (GNU_SYSTEM_MODULES): Add nss.scm. Ludovic Courtès 2019-03-23gnu: vpnc-scripts: Update to 20190116.1000e0f....* gnu/packages/vpn.scm (vpnc-scripts): Update to 20190116.1000e0f. Tobias Geerinckx-Rice 2019-03-22gnu: Add xl2tpd....* gnu/packages/vpn.scm (xl2tpd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomáš Čech