aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages fvwm)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages fribidi)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages image)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))

(define-public fvwm
  (package
    (name "fvwm")
    (version "2.7.0")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/fvwmorg/fvwm/releases/download/"
                    version "/fvwm-" version ".tar.gz"))
              (sha256
               (base32
                "12s1wgkvrvl8m62gpb2918izfx9ysj7hgn9p00blfi3p1gb6v0k6"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-after 'install 'install-xsession
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (xsessions (string-append out "/share/xsessions")))
               (mkdir-p xsessions)
               (make-desktop-entry-file
                 (string-append xsessions "/fvwm2.desktop")
                 #:name "FVWM"
                 #:exec (string-append out "/bin/" ,name)
                 #:comment '("FVWM")))
             #t)))))
    (native-inputs
     `(("perl" ,perl)
       ("pkg-config" ,pkg-config)
       ("xsltproc" ,libxslt)))
    (inputs
     (list fribidi
           libpng
           (librsvg-for-system)
           libxcursor
           libxext
           libxft
           libxinerama
           libxpm
           libxt
           readline))
    (synopsis "Virtual window manager for X11")
    (description
     "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
window manager for the X Window system.")
    (home-page "https://www.fvwm.org/")
    (license gpl2+)))
p'>* gnu/packages/chromium.scm (ungoogled-chromium)[configure-flags]: Change “rtc_use_h264=false” to “rtc_use_h264=true”. Liliana Marie Prikler 2023-04-30gnu: ungoogled-chromium: Update to 112.0.5615.165-1....* gnu/packages/chromium.scm (%chromium-version): Set to 112.0.5615.165. (%ungoogled-origin, ungoogled-chromium): Update hashes. Marius Bakke 2023-04-30gnu: ungoogled-chromium: Update to 111.0.5563.146-1....* gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for M111. (%chromium-version): Set to 111.0.5563.146. (%ungoogled-origin): Update hash. (%chromium-gcc-patchset, gcc-patch, %gcc-patches): Remove variables. (%arch-patches): Remove obsolete. (ungoogled-chromium)[source](sha256): Update hash. Marius Bakke 2023-04-30gnu: ungoogled-chromium: Update to 110.0.5481.177-1....* gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for M110. (%chromium-version): Set to 110.0.5481.177. (%debian-revision): Bump. (%ungoogled-origin, %debian-origin): Update hashes. (%debian-patches): Remove obsolete patch. (ungoogled-chromium-snippet): Use upstream jsoncpp unbundle script. (ungoogled-chromium)[source](sha256): Update hash. [arguments]: Remove obsolete configure flags and substitution. Use system libffi. Marius Bakke 2023-04-30gnu: ungoogled-chromium: Don't add absolute references to libGL and libvulkan....Keeping track of the uses of these libraries is a lot of work and ultimately not worth the trouble -- especially since Chromium supports multiple libGL's with different ABIs. Instead we take the easy route and rely on a search path. * gnu/packages/chromium.scm (ungoogled-chromium)[arguments]: Remove patching of libGL.so and libvulkan.so. Instead wrap with LD_LIBRARY_PATH. Marius Bakke 2023-03-31gnu: Replace all uses of atk by at-spi2-core....* gnu/packages/animation.scm (gnash) * gnu/packages/chromium.scm (ungoogled-chromium) * gnu/packages/crates-gtk.scm (rust-atk-sys-0.14, rust-atk-sys-0.10, rust-atk-0.14, rust-gtk-0.14) * gnu/packages/gimp.scm (gimp) * gnu/packages/gnome.scm (evince, glade3, clutter, totem, rhythmbox, mutter, ghex): * gnu/packages/graphviz.scm (xdot) * gnu/packages/gtk.scm (gtk+-2, gtk+, guile-gnome, atkmm) * gnu/packages/mate.scm (mate-applets, atril, mate-control-center, mate-calc, mate-utils, eom, pluma) * gnu/packages/messaging.scm (dino) * gnu/packages/qt.scm (qtwebengine-5) * gnu/packages/rust-apps.scm (alfis) * gnu/packages/vim.scm (vim-full) * gnu/packages/vnc.scm (remmina) * gnu/packages/web.scm (castor): Replace atk by at-spi2-core. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Josselin Poiret 2023-02-25gnu: ungoogled-chromium: Adapt patches....* gnu/packages/chromium.scm (%debian-revision): Move to a later release for Debian patches. (%ungoogled-origin): Update hash accordingly. (%debian-patches): Enable "fixes/clang-and-gcc11.patch". Andreas Enge 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2023-01-26gnu: ungoogled-chromium: Update to 109.0.5414.119-1....* gnu/packages/chromium.scm (%chromium-version): Set to 109.0.5414.119. (%ungoogled-origin): Update hash. (ungoogled-chromium)[source]: Likewise. [arguments]: Use delete-file-recursively instead of rmdir for compatibility with downstream versions. Remove unused binding. Marius Bakke 2023-01-13gnu: ungoogled-chromium: Update to 109.0.5414.74-1....* gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for M109. (%chromium-version): Set to 109.0.5414.74. (%arch-revision): Bump to latest. (%arch-patches): Add one patch. (%ungoogled-origin): Update hash. (ungoogled-chromium)[source]: Likewise. [arguments]: Disable H264 for WebRTC. Delete one directory. Remove obsolete substitution. [native-inputs]: Add PYTHON-PYYAML. Marius Bakke