aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2023 宋文武 <iyzsong@envs.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages fsf)
  #:use-module (gnu packages tex)
  #:use-module (guix build-system copy)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:prefix license:))

(define-public book-faif
  (package
    (name "book-faif")
    (version "2.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.fsf.org/faif/faif-" version
                                  ".tar.bz2"))
              (sha256
               (base32
                "0qf14d0n6k1dn9z0fdnx9qkhn4iq685xd443w7l7w54bm931p7dw"))))
    (build-system copy-build-system)
    (native-inputs
     (list (texlive-updmap.cfg
            (list texlive-caption
                  texlive-endnotes
                  texlive-etoolbox
                  texlive-fncychap
                  texlive-helvetic
                  texlive-times
                  texlive-ucs))))
    (arguments
     (list
      #:install-plan #~'(("faif-2.0.pdf" "share/doc/faif/"))
      #:phases
      #~(modify-phases %standard-phases
          (add-before 'install 'build
            (lambda _
              (invoke "pdflatex" "faif-2.0.tex"))))))
    (home-page "https://www.fsf.org/faif")
    (synopsis "Free as in Freedom (2.0)")
    (description
     "In 2002, Sam Williams wrote Free as in Freedom, a biography of Richard
M. Stallman.  In its epilogue, Williams expressed hope that choosing to
distribute his book under the GNU Free Documentation License would enable and
encourage others to share corrections and their own perspectives through
modifications to his work.  Free as in Freedom (2.0) is Stallman's revision of
the original biography.  While preserving Williams's viewpoint, it includes
factual corrections and extensive new commentary by Stallman, as well as new
prefaces by both authors written for the occasion.  It is a rare kind of
biography, where the reader has the benefit of both the biographer's original
words and the subject's response.")
    (license license:fdl1.3+)))
?id=a2894745a5feaf9adb20c3f7a8f1e5ba78d41f16'>gnu: python-blosc: Simplify package....* gnu/packages/python-compression.scm (python-blosc) [arguments] <#:phases>: Swap to simple lambda in 'find-blosc phase as it already uses this-package-input procedure. Change-Id: I4d3219d9575b9573b0c384b067855fa927f122da Sharlatan Hellseher 2024-03-29gnu: python-blosc: Move to python-compression....* gnu/packages/python-xyz.scm (python-blosc): Move from here ... * gnu/packages/python-compression.scm: ... to here. Change-Id: Ieed1b399602d0ba64b065d1c03ef0855ac52f71e Sharlatan Hellseher 2024-03-03gnu: Add python-cramjam....* gnu/packages/python-compression.scm (python-cramjam): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Troy Figiel 2024-01-09gnu: Add python-python-snappy....* gnu/packages/python-compression.scm (python-python-snappy): New variable. Troy Figiel 2023-09-22gnu: Add python-pylsqpack....* gnu/packages/python-compression.scm (python-pylsqpack): New variable. Marius Bakke 2023-07-16gnu: python-pyzstd: Unbundle and dynamically link Zstd....* gnu/packages/python-compression.scm (python-pyzstd)[source]: Delete bundled Zstd. [arguments]: Add "--dynamic-link-zstd" configure flag, and honour it. [inputs]: Add zstd. Tobias Geerinckx-Rice 2023-07-16gnu: python-pyzstd: Update to 0.15.9....* gnu/packages/python-compression.scm (python-pyzstd): Update to 0.15.9. Tobias Geerinckx-Rice 2023-07-03gnu: python-isal: Update to 1.1.0....* gnu/packages/python-compression.scm (python-isal): Update to 1.1.0. [build-system]: Use pyproject-build-system. Ricardo Wurmus 2023-04-12gnu: python-zopfli: Update to 0.2.2....* gnu/packages/python-compression.scm (python-zopfli): Update to 0.2.2. Maxim Cournoyer 2023-04-12gnu: python-lz4: Update to 4.3.2....* gnu/packages/python-compression.scm (python-lz4): Update to 4.3.2. Maxim Cournoyer 2022-11-24gnu: python-brotlicffi: Unbundle brotli....* gnu/packages/python-compression.scm (python-brotlicffi)[source]: Add snippet to delete bundled libbrotli. [arguments]: Add phase to configure using shared libbrotli. [inputs]: Add brotli. Efraim Flashner 2022-11-23gnu: python-py7zr: Update to 0.20.2....* gnu/packages/python-compression.scm (python-py7zr): Update to 0.20.2. [build-system]: Use pyproject-build-system. [propagated-inputs]: Add python-brotli, python-brotlicffi, python-importlib-metadata, python-inflate64, python-psutil, python-pybcj, python-pycryptodomex, and python-pyppmd; remove python-bcj-cffi, python-ppmd-cffi, python-pycryptodome, and python-zstandard. Ricardo Wurmus 2022-11-23gnu: Add python-pybcj....* gnu/packages/python-compression.scm (python-pybcj): New variable. Ricardo Wurmus 2022-11-23gnu: Add python-inflate64....* gnu/packages/python-compression.scm (python-inflate64): New variable. Ricardo Wurmus 2022-11-23gnu: python-multivolumefile: Update to 0.2.3....* gnu/packages/python-compression.scm (python-multivolumefile): Update to 0.2.3. [build-system]: Use pyproject-build-system. [native-inputs]: Remove python-pep517 and python-setuptools; add python-hypothesis. Ricardo Wurmus 2022-11-23gnu: Add python-brotlicffi....* gnu/packages/python-compression.scm (python-brotlicffi): New variable. Ricardo Wurmus 2022-11-23gnu: Add python-pyppmd....* gnu/packages/python-compression.scm (python-pyppmd): New variable. Ricardo Wurmus 2022-11-23gnu: python-zstandard: Update to 0.19.0....* gnu/packages/python-compression.scm (python-zstandard): Update to 0.19.0. [propagated-inputs]: Add python-cffi. Ricardo Wurmus 2022-11-23gnu: python-pyzstd: Update to 0.15.3....* gnu/packages/python-compression.scm (python-pyzstd): Update to 0.15.3. Ricardo Wurmus 2022-11-23gnu: python-ppmd-cffi: Update to 0.5.0....* gnu/packages/python-compression.scm (python-ppmd-cffi): Update to 0.5.0. [native-inputs]: Remove python-setuptools and python-pep517; add python-hypothesis. Ricardo Wurmus 2022-09-07gnu: python-zopfli: Update to 0.2.1....* gnu/packages/python-compression.scm (python-zopfli): Update to 0.2.1. [arguments]: Use pytest in check phase. [native-inputs]: Add PYTHON-PYTEST. Marius Bakke