aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2016, 2019, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages fribidi)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages))

(define-public fribidi
  (package
    (name "fribidi")
    (version "1.0.12")
    (source
      (origin
        (method url-fetch)
        (uri
         (string-append "https://github.com/fribidi/fribidi/releases"
                        "/download/v" version "/fribidi-" version
                         ".tar.xz"))
        (sha256
         (base32 "159l56c48rfcqa8mnxhnynngzlzmvr089ki7mjrppin8gzwk7lhc"))))
    (build-system gnu-build-system)
    (synopsis "Implementation of the Unicode bidirectional algorithm")
    (description
     "GNU FriBidi is an implementation of the Unicode Bidirectional
Algorithm.  This algorithm is used to properly display text in left-to-right
or right-to-left ordering as necessary.")
    (home-page "https://github.com/fribidi/fribidi")
    (license lgpl2.1+)))

(define-public bidiv
  (package
    (name "bidiv")
    (version "1.5")
    (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://debian/pool/main/b/bidiv/bidiv_"
                            version ".orig.tar.gz"))
        (sha256
         (base32
          "05p5m2ihxbmc1qsgs8rjlww08fy9859fhl7xf196p8g5qygqd7cv"))
        (patches (search-patches "bidiv-update-fribidi.patch"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (delete 'configure) ; no configure
         (add-after 'unpack 'misc-fixes
           (lambda _
             (substitute* "bidiv.c"
               (("FriBidiCharType") "FriBidiParType")
               (("&c") "(char *)&c"))
             #t))
         ;; We don't want to use the handwritten makefile
         (replace 'build
           (lambda* (#:key inputs #:allow-other-keys)
             (let ((fribidi (assoc-ref inputs "fribidi")))
               (invoke "gcc" "-o" "bidiv" "bidiv.c"
                       ;; pkg-config --cflags fribidi
                       (string-append "-I" fribidi "/include/fribidi")
                       ;; pkg-config --libs fribidi
                       (string-append "-L" fribidi "/lib") "-lfribidi"))))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin"))
                    (man (string-append out "/share/man/man1")))
               (install-file "bidiv" bin)
               (install-file "bidiv.1" man))
             #t)))
       #:tests? #f)) ; no tests
    (inputs
     (list fribidi))
    (home-page "https://tracker.debian.org/pkg/bidiv")
    (synopsis "BiDi viewer - command-line tool displaying logical Hebrew/Arabic")
    (description "bidiv is a simple utility for converting logical-Hebrew input
to visual-Hebrew output.  This is useful for reading Hebrew mail messages,
viewing Hebrew texts, etc.  It was written for Hebrew but Arabic (or other BiDi
languages) should work equally well.")
    (properties
     '((release-monitoring-url . "https://deb.debian.org/debian/pool/main/b/bidiv")))
    (license gpl2+)))
..* gnu/packages/xfce.scm (xfce4-whiskermenu-plugin): Update to 2.8.3. [inputs]: Add accountsservice and gtk-layer-shell. [arguments]: Remove 'fix-shell-script phase. Change-Id: I87fc277c5e32674a505a532ad129c75d24d854a5 宋文武 2024-09-06gnu: elementary-xfce-icon-theme: Update to 0.19....* gnu/packages/xfce.scm (elementary-xfce-icon-theme): Update to 0.19. Change-Id: I4cfd6b480806b7e9ec090f5dd1ebe2e1b1ed0f7f 宋文武 2024-09-06gnu: libxfce4ui: Update to 4.18.6....* gnu/packages/xfce.scm (libxfce4ui): Update to 4.18.6. Change-Id: If392f88d81f406a3022e1d445b6339922dc0b9fe 宋文武 2024-09-06gnu: libxfce4util: Update to 4.18.2....* gnu/packages/xfce.scm (libxfce4util): Update to 4.18.2. Change-Id: Idbc7bdef940ddc6feff4b60832326ebe779192ba 宋文武 2024-08-31gnu: xfce: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/xfce.scm (catfish)[inputs]: Add 'bash-minimal'. (mousepad)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I2d3294f0141d20061faf62b06c11f1c78df05c18 Maxime Devos 2024-04-29gnu: thunar: Use glib-or-gtk-build-system....This wraps 'thunar' with GIO_EXTRA_MODULES to enable support for "Trash" and remote file systems via GVFS. Fixes <https://issues.guix.gnu.org/55781> and <https://issues.guix.gnu.org/40885>. * gnu/packages/xfce.scm (thunar)[build-system]: Switch to glib-or-gtk-build-system. Change-Id: Ifa4bc931272380e7c98dea40edb683da523bbaea 宋文武 2024-03-31gnu: xfce: Add support for volume keyboard buttons....* gnu/packages/xfce.scm (xfce) [inputs]: Add xfce4-volumed-pulse. Change-Id: Iac0f76e6aa43d3687ac6c1a25769859e72f840c7 Maxim Cournoyer 2024-03-20gnu: xfce4-dev-tools: Add libxslt as a native-input....As the configure script is looking for it. * gnu/packages/xfce.scm (xfce4-dev-tools)[native-inputs]: Add libxslt. Change-Id: Ia7ab573bbdf7461fc68053667a5962717afd0015 Christopher Baines 2024-03-19gnu: xfce4-cpugraph-plugin: Update to 1.2.10....* gnu/packages/xfce.scm (xfce4-cpugraph-plugin): Update to 1.2.10. Change-Id: I1c68847916b4075c24baa80578ff2f5b167a9bd3 宋文武 2024-03-19gnu: xfce4-weather-plugin: Update to 0.11.2....* gnu/packages/xfce.scm (xfce4-weather-plugin): Update to 0.11.2. [inputs]: Add json-c. Change-Id: I45f70797ac7c3d29abae69afc65e6c37c5c434b7 宋文武 2024-03-19gnu: xfce4-genmon-plugin: Update to 4.2.0....* gnu/packages/xfce.scm (xfce4-genmon-plugin): Update to 4.2.0. Change-Id: Iec9dd94ac046cd944861483726f95efd008750d4 宋文武 2024-03-19gnu: xfce4-screensaver: Update to 4.18.3....* gnu/packages/xfce.scm (xfce4-screensaver): Update to 4.18.3. Change-Id: I20d8de0cc24aacf50ba9e6f174f0de083718cd48 宋文武 2024-03-19gnu: xfce4-screenshooter: Update to 1.10.5....* gnu/packages/xfce.scm (xfce4-screenshooter): Update to 1.10.5. Change-Id: Id4dcbc6a9761486450cc062df6a14a15a1ed0546 宋文武 2024-03-19gnu: mousepad: Update to 0.6.2....* gnu/packages/xfce.scm (mousepad): Update to 0.6.2. Change-Id: I2d8cba922872e6d563a0a14467828d8f65993e6d 宋文武 2024-03-19gnu: xfce4-notifyd: Update to 0.9.4....* gnu/packages/xfce.scm (xfce4-notifyd): Update to 0.9.4. [arguments]: Patch "configure" script for "glib-mkenums". Change-Id: I67a455b620f60ad0419c1071fbf8672a619528da 宋文武 2024-03-19gnu: xfce4-taskmanager: Update to 1.5.7....* gnu/packages/xfce.scm (xfce4-taskmanager): Update to 1.5.7. Change-Id: I196ac35c768d1d2983d59ad0ea7595669912559b 宋文武 2024-03-19gnu: xfce4-dict: Update to 0.8.6....* gnu/packages/xfce.scm (xfce4-dict): Update to 0.8.6. Change-Id: Ib8a818393a50a3059d4b2fd984fea1e8bfe5457f 宋文武 2024-03-19gnu: ristretto: Update to 0.13.2....* gnu/packages/xfce.scm (ristretto): Update to 0.13.2. Change-Id: Ia4adb63b5a21a7cdaf085da5a40f4f13d3cd6a04 宋文武 2024-03-19gnu: gigolo: Update to 0.5.3....* gnu/packages/xfce.scm (gigolo): Update to 0.5.3. Change-Id: I24ef7d48fce687d3da32bfa9e13fb18557e680c6 宋文武 2024-03-19gnu: thunar-media-tags-plugin: Update to 0.4.0....* gnu/packages/xfce.scm (thunar-media-tags-plugin): Update to 0.4.0. Change-Id: If28479841e800d89226544c586c8d557ce0b3472 宋文武 2024-03-19gnu: thunar-archive-plugin: Update to 0.5.2....* gnu/packages/xfce.scm (thunar-archive-plugin): Update to 0.5.2. Change-Id: I7a4983605ecfbd5d450ac1914a312a90c959ff82 宋文武 2024-03-19gnu: xfce4-pulseaudio-plugin: Update to 0.4.8....* gnu/packages/xfce.scm (xfce4-pulseaudio-plugin): Update to 0.4.8. Change-Id: Id99dcd7d692651c81e68d94bd73e862d808440aa 宋文武 2024-03-19gnu: xfce4-clipman-plugin: Update to 1.6.6....* gnu/packages/xfce.scm (xfce4-clipman-plugin): Update to 1.6.6. Change-Id: If6af26b29ece57da258805431947abd6a30f5cee 宋文武 2024-03-12gnu: xfce: Add xfwm4-themes....* gnu/packages/xfce.scm (xfce)[inputs]: Add xfwm4-themes. Change-Id: If68db115691bdb0dc324ca502f1853d51e9d52b8 宋文武 2024-03-12gnu: Add xfwm4-themes....* gnu/packages/xfce.scm (xfwm4-themes): New package. Change-Id: I01f7c7e095234c408c40cf344f6332753289d55f 宋文武 2024-03-12gnu: xfce4-dev-tools: Update to 4.18.1....* gnu/packages/xfce.scm (xfce4-dev-tools): Update to 4.18.1. Change-Id: I4e5b30d2dc70ba50b560d777a8b10ecb421dcbd9 宋文武 2024-03-12gnu: xfce4-power-manager: Update to 4.18.3....* gnu/packages/xfce.scm (xfce4-power-manager): Update to 4.18.3. Change-Id: I64cb289730b4fea2af5e3cbffef5500e1bfe1382 宋文武 2024-03-12gnu: xfce4-terminal: Update to 1.1.3....* gnu/packages/xfce.scm (xfce4-terminal): Update to 1.1.3. Change-Id: Ic6589ee48f8e406f4d6b7b12ead165119b904e7f 宋文武 2024-03-12gnu: thunar: Update to 4.18.10....* gnu/packages/xfce.scm (thunar): Update to 4.18.10. Change-Id: I170cfa24d0086d6c1d2707d4c5693f28678adf3e 宋文武 2024-03-12gnu: xfce4-settings: Update to 4.18.4....* gnu/packages/xfce.scm (xfce4-settings): Update to 4.18.4. Change-Id: If945317a90a0e0325bac352024c98920b8c6c86c 宋文武 2024-03-12gnu: xfce4-appfinder: Update to 4.18.1....* gnu/packages/xfce.scm (xfce4-appfinder): Update to 4.18.1. Change-Id: Ice902179d6991d9e887aeb2d9dfe144530c5dcf7 宋文武 2024-03-12gnu: xfce4-panel: Update to 4.18.6....* gnu/packages/xfce.scm (xfce4-panel): Update to 4.18.6. Change-Id: I29a0372692fc9896cdfa083e07c0e4a0255108c5 宋文武 2024-03-12gnu: tumbler: Update to 4.18.2....* gnu/packages/xfce.scm (tumbler): Update to 4.18.2. Change-Id: I99c65a09b5fe4b02e4d678f64721a713cde09b87 宋文武 2024-03-12gnu: garcon: Update to 4.18.2....* gnu/packages/xfce.scm (garcon): Update to 4.18.2. Change-Id: I45cfb8bca3556849cc08c00053696b077553f4f6 宋文武 2024-03-12gnu: xfconf: Update to 4.18.3....* gnu/packages/xfce.scm (xfconf): Update to 4.18.3. Change-Id: I938fa3a1d8770c62a1456a814144b24ed1b4a025 宋文武 2024-01-07gnu: elementary-xfce-icon-theme: Update to 0.18....* gnu/packages/xfce.scm (elementary-xfce-icon-theme): Update to 0.18. Change-Id: Ibcb595e20553c18893db3cad5d95bd85ef1c04fc 宋文武 2024-01-07gnu: catfish: Update to 4.18.0....* gnu/packages/xfce.scm (catfish): Update to 4.18.0. Change-Id: Ibc9a9774b20d918ea7aa17404d093d2043ce6855 宋文武