aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2016, 2019, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages fribidi)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages))

(define-public fribidi
  (package
    (name "fribidi")
    (version "1.0.12")
    (source
      (origin
        (method url-fetch)
        (uri
         (string-append "https://github.com/fribidi/fribidi/releases"
                        "/download/v" version "/fribidi-" version
                         ".tar.xz"))
        (sha256
         (base32 "159l56c48rfcqa8mnxhnynngzlzmvr089ki7mjrppin8gzwk7lhc"))))
    (build-system gnu-build-system)
    (synopsis "Implementation of the Unicode bidirectional algorithm")
    (description
     "GNU FriBidi is an implementation of the Unicode Bidirectional
Algorithm.  This algorithm is used to properly display text in left-to-right
or right-to-left ordering as necessary.")
    (home-page "https://github.com/fribidi/fribidi")
    (license lgpl2.1+)))

(define-public bidiv
  (package
    (name "bidiv")
    (version "1.5")
    (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://debian/pool/main/b/bidiv/bidiv_"
                            version ".orig.tar.gz"))
        (sha256
         (base32
          "05p5m2ihxbmc1qsgs8rjlww08fy9859fhl7xf196p8g5qygqd7cv"))
        (patches (search-patches "bidiv-update-fribidi.patch"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (delete 'configure) ; no configure
         (add-after 'unpack 'misc-fixes
           (lambda _
             (substitute* "bidiv.c"
               (("FriBidiCharType") "FriBidiParType")
               (("&c") "(char *)&c"))
             #t))
         ;; We don't want to use the handwritten makefile
         (replace 'build
           (lambda* (#:key inputs #:allow-other-keys)
             (let ((fribidi (assoc-ref inputs "fribidi")))
               (invoke "gcc" "-o" "bidiv" "bidiv.c"
                       ;; pkg-config --cflags fribidi
                       (string-append "-I" fribidi "/include/fribidi")
                       ;; pkg-config --libs fribidi
                       (string-append "-L" fribidi "/lib") "-lfribidi"))))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin"))
                    (man (string-append out "/share/man/man1")))
               (install-file "bidiv" bin)
               (install-file "bidiv.1" man))
             #t)))
       #:tests? #f)) ; no tests
    (inputs
     (list fribidi))
    (home-page "https://tracker.debian.org/pkg/bidiv")
    (synopsis "BiDi viewer - command-line tool displaying logical Hebrew/Arabic")
    (description "bidiv is a simple utility for converting logical-Hebrew input
to visual-Hebrew output.  This is useful for reading Hebrew mail messages,
viewing Hebrew texts, etc.  It was written for Hebrew but Arabic (or other BiDi
languages) should work equally well.")
    (properties
     '((release-monitoring-url . "https://deb.debian.org/debian/pool/main/b/bidiv")))
    (license gpl2+)))
>Merge branch 'master' into core-updatesMark H Weaver 2018-05-07gnu: webkitgtk: Update to 2.20.2 [fixes CVE-2018-4200]....* gnu/packages/webkit.scm (webkitgtk): Update to 2.20.2. Marius Bakke 2018-04-21Merge branch 'master' into core-updatesMark H Weaver 2018-04-17gnu: Remove webkitgtk-2.4 and webkitgtk/gtk+-2....These were old, unmaintained versions of webkitgtk with many known remote code execution vulnerabilities. With the recent GnuCash 3.0 update in commit 53e66fbceb275262184ad44f60a5a8d4e7061fcb, they are no longer needed. * gnu/packages/webkit.scm (webkitgtk-2.4, webkitgtk/gtk+-2): Remove variables. Mark H Weaver 2018-04-16gnu: webkitgtk: Update to 2.20.1....* gnu/packages/webkit.scm (webkitgtk): Update to 2.20.1. Tobias Geerinckx-Rice 2018-03-20gnu: webkitgtk: Return #t from all phases....* gnu/packages/webkit.scm (webkitgtk)[arguments]: Return #t from the 'add-gst-plugins-base-include-path' phase. Mark H Weaver 2018-03-14gnu: webkitgtk: Use HTTPS for home page....* gnu/packages/webkitgtk.scm (webkitgtk)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2018-03-14gnu: webkitgtk: Update to 2.20.0....* gnu/packages/webkit.scm (webkitgtk): Update to 2.20.0. [arguments]: (Re-)disable WOFF2 web font support. Tobias Geerinckx-Rice 2018-01-24gnu: webkitgtk: Update to 2.18.6 [security fixes]....Fixes CVE-2017-{7153,7160,7161,7165,13884,13885,} and CVE-2018-{4088,4096}. * gnu/packages/webkit.scm (webkitgtk): Update to 2.18.6. Leo Famulari 2018-01-18gnu: webkitgtk: Update to 2.18.5....* gnu/packages/webkit.scm (webkitgtk): Update to 2.18.5. [source]: Remove patch. * gnu/packages/patches/webkitgtk-mitigate-spectre.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Mark H Weaver 2018-01-07gnu: webkitgtk: Disable SharedArrayBuffers to mitigate Spectre....* gnu/packages/patches/webkitgtk-mitigate-spectre.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/webkit.scm (webkitgtk)[source]: Add patch. Mark H Weaver 2017-12-19gnu: webkitgtk: Update to 2.18.4 [fixes CVE-2017-{7156,13856,13866,13870}]....* gnu/packages/webkit.scm (webkitgtk): Update to 2.18.4. Leo Famulari 2017-11-10gnu: webkitgtk: Update to 2.18.3 [fixes CVE-2017-{13788,13798,13803}]....* gnu/packages/webkit.scm (webkitgtk): Update to 2.18.3. Leo Famulari 2017-10-30gnu: webkitgtk: Update to 2.18.2....* gnu/packages/webkit.scm (webkitgtk): Update to 2.18.2. Mark H Weaver 2017-10-20gnu: webkitgtk: Update to 2.18.1....* gnu/packages/webkit.scm (webkitgtk): Update to 2.18.1. Leo Famulari 2017-09-15gnu: webkitgtk: Update to 2.18.0....* gnu/packages/webkit.scm (webkitgtk): Update to 2.18.0. [arguments]: Add -DUSE_GSTREAMER_GL=OFF to configure-flags. [inputs]: Add libtasn1. Mark H Weaver 2017-07-25gnu: webkitgtk: Update to 2.16.6 [security fixes]....Includes fixes for CVE-2017-7039, CVE-2017-7018, CVE-2017-7030, CVE-2017-7037, CVE-2017-7034, CVE-2017-7055, CVE-2017-7056, CVE-2017-7064, CVE-2017-7061, CVE-2017-7048, and CVE-2017-7046. * gnu/packages/webkit.scm (webkitgtk): Update to 2.16.6. Mark H Weaver 2017-07-07gnu: webkitgtk: Update to 2.16.5....* gnu/packages/webkit.scm (webkitgtk): Update to 2.16.5. Mark H Weaver 2017-06-22gnu: webkitgtk: Update to 2.16.4 [fixes CVE-2017-2538]....* gnu/packages/webkit.scm (webkitgtk): Update to 2.16.4. Leo Famulari 2017-05-25gnu: webkitgtk: Update to 2.16.3 [fixes CVE-2017-{2496,2510,2539}]....* gnu/packages/webkit.scm (webkitgtk): Update to 2.16.3. Marius Bakke 2017-05-10gnu: webkitgtk: Update to 2.16.2....* gnu/packages/webkit.scm (webkitgtk): Update to 2.16.2. Mark H Weaver 2017-04-06gnu: webkitgtk: Update to 2.16.1....* gnu/packages/webkit.scm (webkitgtk): Update to 2.16.1. Leo Famulari 2017-03-27gnu: webkitgtk: Update to 2.16.0....WebKitGTK+ 2.16.0 is the first stable release of WebKitGTK+ that uses libgcrypt instead of GnuTLS for some cryptographic functions: <https://bugs.webkit.org/show_bug.cgi?id=163125> <http://trac.webkit.org/changeset/208297/webkit> * gnu/packages/webkit.scm (webkitgtk): Update to 2.16.0. [inputs]: Replace gnutls with libgcrypt. Leo Famulari 2017-02-18gnu: webkitgtk: Update to 2.14.5....* gnu/packages/webkit.scm (webkitgtk): Update to 2.14.5. Mark H Weaver 2017-02-10gnu: webkitgtk: Update to 2.14.4 [security fixes]....Fixes CVE-2017-{2350,2354,2355,2356,2362,2363,2364,2365,2366,2369,2371,2373}. * gnu/packages/webkit.scm (webkitgtk): Update to 2.14.4. Marius Bakke 2017-01-17gnu: webkitgtk: Update to 2.14.3 [security fixes]....Fixes CVE-2016-{7586,7589,7592,7599,7623,7632,7635,7639,7641,7645,7652,7654,7656}. * gnu/packages/webkit.scm (webkitgtk): Update to 2.14.3. Leo Famulari