aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages freeipmi)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages gnupg))

(define-public freeipmi
  (package
    (name "freeipmi")
    (version "1.6.14")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/freeipmi/freeipmi-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1dgd2izbp6mqk7l0bgw9fkpvl4mjz672p8baz3ac9k5pfrfaqg8s"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags '("--disable-static"
                           ,@(if (%current-target-system)
                               ;; We cannot check for these devices
                               ;; when cross compiling.
                               `("ac_cv_file__dev_random=yes"
                                 "ac_cv_file__dev_urandom=yes")
                               '()))))
    (inputs
     (list libgcrypt))
    (home-page "https://www.gnu.org/software/freeipmi/")
    (synopsis "Platform management, including sensor and power monitoring")
    (description
     "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software
in accordance with the IPMI v1.5/2.0 specification.  These programs provide a
set of interfaces for platform management.  Common functionality includes
sensor monitoring, system event monitoring, power control and
serial-over-LAN.")
    (license gpl3+)))
: at-spi2-atk: Update to 2.32.0....Marius Bakke 2019-03-14gnu: at-spi2-core: Update to 2.32.0....Marius Bakke 2019-03-14gnu: atk: Update to 2.32.0....Marius Bakke 2019-03-14gnu: gtk+: Update to 3.24.7....Marius Bakke 2019-03-07gnu: at-spi2-core: Update to 2.28.0....Ricardo Wurmus 2019-03-07gnu: gtk-doc: Update to 1.28....Ricardo Wurmus 2019-03-07gnu: Add gtksourceview-3....Ricardo Wurmus 2019-03-07gnu: gtksourceview: Update to 4.0.2....Ricardo Wurmus 2019-03-01gnu: gdk-pixbuf: Update to 2.38.1....Marius Bakke 2019-02-20Merge branch 'master' into stagingMarius Bakke 2019-02-17gnu: clipit: Update to 1.4.4....Tobias Geerinckx-Rice 2019-02-17gnu: yad: Update to 0.41.0....Tobias Geerinckx-Rice 2019-02-10gnu: gtk+: Update to 3.24.5....Marius Bakke 2019-01-31Merge branch 'master' into stagingMarius Bakke 2019-01-28gnu: Move most packages from guile.scm to new module....Ricardo Wurmus 2019-01-20Merge branch 'master' into stagingLudovic Courtès 2019-01-18gnu: graphene: Remove custom autogen phase....Ricardo Wurmus 2019-01-15gnu: Separate Python core packages from the rest....Ricardo Wurmus 2018-12-23gnu: girara: Update to 0.3.2....Marius Bakke 2018-12-12gnu: gtk+: Update to 3.24.2....Marius Bakke 2018-12-12gnu: cairo: Update to 1.16.0....Marius Bakke 2018-12-12gnu: harfbuzz: Update to 2.2.0....Marius Bakke 2018-12-12gnu: gdk-pixbuf: Only extend the test timeout on some architectures....Efraim Flashner 2018-12-12gnu: gdk-pixbuf: Fix typo....Efraim Flashner 2018-12-04gnu: gtk+: Update to 3.24.1....Marius Bakke 2018-11-14Merge branch 'master' into core-updatesMarius Bakke 2018-11-11gnu: gtk-doc: Use local docbook-xsl....Pierre Neidhardt 2018-11-09Merge branch 'master' into core-updatesMarius Bakke 2018-11-07gnu: Add spread-sheet-widget....Kei Kebreau 2018-10-23gnu: ganv: Use python2 for building....Marius Bakke 2018-10-14gnu: gdk-pixbuf: Increase test timeout....Efraim Flashner 2018-10-05Merge branch 'master' into core-updatesMarius Bakke 2018-10-02gnu: guile-cairo: Update to 1.10.0....Ludovic Courtès 2018-09-26Merge branch 'master' into core-updatesMarius Bakke 2018-09-26gnu: enchant: Update to 2.2.3....Marius Bakke 2018-09-13Merge branch 'master' into core-updatesLeo Famulari 2018-09-10gnu: Add yad....Mădălin Ionel Patrașcu 2018-09-09gnu: gdk-pixbuf: Update to 2.38.0....Marius Bakke 2018-09-09gnu: gtk+: Update to 3.24.0....Marius Bakke 2018-09-09Merge branch 'master' into core-updatesMarius Bakke 2018-09-06gnu: guile-present: Install .go files to libdir....Ludovic Courtès 2018-08-30gnu: pango: Replace with 1.42.4....Marius Bakke