aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages freeipmi)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix gexp)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages gnupg))

(define-public freeipmi
  (package
    (name "freeipmi")
    (version "1.6.14")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/freeipmi/freeipmi-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1dgd2izbp6mqk7l0bgw9fkpvl4mjz672p8baz3ac9k5pfrfaqg8s"))))
    (build-system gnu-build-system)
    (arguments
     (append (if (and (%current-target-system)
                      (target-riscv64?))
                 (list #:phases
                       #~(modify-phases %standard-phases
                           (add-after 'unpack 'update-config-scripts
                             (lambda* (#:key inputs native-inputs #:allow-other-keys)
                               ;; Replace outdated config.guess and config.sub.
                               (for-each (lambda (file)
                                           (install-file
                                            (search-input-file
                                             (or native-inputs inputs)
                                             (string-append "/bin/" file)) "config"))
                                         '("config.guess" "config.sub"))))))
                 '())
             (list #:configure-flags #~'("--disable-static"
                                         #$@(if (%current-target-system)
                                                ;; We cannot check for these devices
                                                ;; when cross compiling.
                                                `("ac_cv_file__dev_random=yes"
                                                  "ac_cv_file__dev_urandom=yes")
                                                '())))))
    (native-inputs
     (if (and (%current-target-system)
              (target-riscv64?))
         (list config)
         '()))
    (inputs
     (list libgcrypt))
    (home-page "https://www.gnu.org/software/freeipmi/")
    (synopsis "Platform management, including sensor and power monitoring")
    (description
     "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software
in accordance with the IPMI v1.5/2.0 specification.  These programs provide a
set of interfaces for platform management.  Common functionality includes
sensor monitoring, system event monitoring, power control and
serial-over-LAN.")
    (license gpl3+)))
.6.6....* gnu/packages/bittorrent.scm (qbittorrent): Update to 4.6.6. Change-Id: I494f5f9e531aabdb6ba60ff418f6ba0cf45b46f4 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Hilton Chain via Guix-patches via 2024-09-02gnu: Transmission: Update to 4.0.6....* gnu/packages/bittorrent.scm (transmission): Update to 4.0.6. [source]: Use the new patch. [arguments]: Adjust the custom build phase 'remove-kernel-version' for 4.0.6. * gnu/packages/patches/transmission-4.0.5-fix-build.patch: Delete file. * gnu/packages/patches/transmission-4.0.6-fix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Change-Id: Id546b8537f48afd50bb00183abf7821ad7601fe9 Leo Famulari 2024-08-31gnu: qbittorrent: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/bittorrent.scm (qbittorrent)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I854fdcfe7e0cbfd2a99d4b80677caefb9e966ea6 Maxime Devos 2024-05-10gnu: qbittorrent-enhanced: Update to 4.6.4.10....* gnu/packages/bittorrent.scm (qbittorrent-enhanced): Update to 4.6.4.10. Change-Id: I85f1dfaa8cd7eda752778c0d67e311d3ba26a21d Zheng Junjie 2024-05-10gnu: qbittorrent: Update to 4.6.4....* gnu/packages/bittorrent.scm (qbittorrent): Update to 4.6.4. Change-Id: Iad1fdc9100c4b01e4cab04d101d068e91c5591c4 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Timotej Lazar 2024-03-09gnu: qbittorrent-enhanced-nox: Rename to qbittorrent-enhanced-no-x....* gnu/packages/bittorrent.scm (qbittorrent-enhanced-no-x): New variable, renamed from… (qbittorrent-enhanced-nox): …this package, now redefined as a DEPRECATED-PACKAGE. Change-Id: I4d1f9da937df6d6145ffbf9e9f2dd544365b9872 Hilton Chain 2024-03-09gnu: qbittorrent-no-x: Actually remove qtsvg from inputs....* gnu/packages/bittorrent.scm (qbittorrent-no-x)[inputs]: Correct "qtsvg-5" to "qtsvg". Change-Id: I77bae8ccf3de7a1be51a74228e135176dc72425d Hilton Chain 2024-03-09gnu: qbittorrent-enhanced: Update to 4.6.3.10....* gnu/packages/bittorrent.scm (qbittorrent-enhanced): Update to 4.6.3.10. Change-Id: I415d228dbbff2f4d5abf9bda2ca84ac81c0d0602 Hilton Chain 2024-02-28gnu: qbittorrent: Update to 4.6.3....* gnu/packages/bittorrent.scm (qbittorrent)[version]: Update to 4.6.3. [inputs]: Use libtorrent-rasterbar 2.0.9. Oleg Pykhalov 2023-12-29gnu: Transmission: Update to 4.0.5....* gnu/packages/bittorrent.scm (transmission): Update to 4.0.5. [source]: Use 'transmission-4.0.5-fix-build.patch'. * gnu/packages/patches/transmission-4.0.5-fix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Change-Id: I8e9486dca07f01628e7886e7ac5757d511056cb7 Leo Famulari 2023-12-29gnu: tremc: Update to 0.9.3-1.d8deaa5....* gnu/packages/bittorrent.scm (tremc): Update to 0.9.3-1.d8deaa5. Change-Id: Ib138825770172c02eaa91ced5f226fd87c7cfb1c Leo Famulari