aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages freeipmi)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix gexp)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages gnupg))

(define-public freeipmi
  (package
    (name "freeipmi")
    (version "1.6.14")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/freeipmi/freeipmi-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1dgd2izbp6mqk7l0bgw9fkpvl4mjz672p8baz3ac9k5pfrfaqg8s"))))
    (build-system gnu-build-system)
    (arguments
     (append (if (and (%current-target-system)
                      (target-riscv64?))
                 (list #:phases
                       #~(modify-phases %standard-phases
                           (add-after 'unpack 'update-config-scripts
                             (lambda* (#:key inputs native-inputs #:allow-other-keys)
                               ;; Replace outdated config.guess and config.sub.
                               (for-each (lambda (file)
                                           (install-file
                                            (search-input-file
                                             (or native-inputs inputs)
                                             (string-append "/bin/" file)) "config"))
                                         '("config.guess" "config.sub"))))))
                 '())
             (list #:configure-flags #~'("--disable-static"
                                         #$@(if (%current-target-system)
                                                ;; We cannot check for these devices
                                                ;; when cross compiling.
                                                `("ac_cv_file__dev_random=yes"
                                                  "ac_cv_file__dev_urandom=yes")
                                                '())))))
    (native-inputs
     (if (and (%current-target-system)
              (target-riscv64?))
         (list config)
         '()))
    (inputs
     (list libgcrypt))
    (home-page "https://www.gnu.org/software/freeipmi/")
    (synopsis "Platform management, including sensor and power monitoring")
    (description
     "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software
in accordance with the IPMI v1.5/2.0 specification.  These programs provide a
set of interfaces for platform management.  Common functionality includes
sensor monitoring, system event monitoring, power control and
serial-over-LAN.")
    (license gpl3+)))
ab6ba497f68'>gnu: Add keybinder....* gnu/packages/wm.scm (keybinder): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> ng0 2017-03-21gnu: Adjust asciidoc-related build options....Commits 9099a45792306fade2d9ca55138e49ef4f01f1ea and 3078821d1380c26c738be6b5d430c595327d401f make many package inputs and build configurations related to asciidoc obsolete. * gnu/packages/compton.scm (compton)[inputs]: Remove docbook-xml, libxml2 and libxslt. * gnu/packages/mail.scm (offlinemap)[native-inputs]: Remove libxslt. * gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Remove docbook-xml. (perf)[inputs]: Remove docbook-xml and libxslt. * gnu/packages/text-editors.scm (kakoune)[native-inputs]: Remove libxslt. * gnu/packages/version-control.scm (cgit)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and libxslt. (cvs-fast-export)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and libxslt. * gnu/packages/web.scm (qutebrowser)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2, and libxslt. (tinyproxy)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and libxslt. * gnu/packages/wm.scm (awesome)[make-flags]: Remove XML_CATALOG_FILES flag. (i3-wm)[inputs]: Remove docbook-xml. [native-inputs]: Add libxml2. Kei Kebreau 2017-03-02gnu: Add perl-anyevent-i3....* gnu/packages/wm.scm (perl-anyevent-i3): New variable. Marius Bakke 2017-02-12gnu: i3status: Update to 2.11....* gnu/packages/wm.scm (i3status): Update to 2.11. Marius Bakke 2017-01-23gnu: xmonad: Update to 0.12....* gnu/packages/wm.scm (xmonad): Update to 0.12. [source](snippet, modules): Remove. [inputs]: Add GHC-SETLOCALE and GHC-QUICKCHECK. (ghc-xmonad-contrib): Update to 0.12. Mekeor Melire 2017-01-18gnu: Add menumaker....* gnu/packages/wm.scm (menumaker): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com> ng0 2016-12-26gnu: awesome: Update to 4.0....* gnu/packages/wm.scm (awesome): Update to 4.0. [source]: Adjust URL. [inputs]: Add xcb-util-xrm and libxkbcommon. * gnu/packages/patches/awesome-reproducible-png.patch: Adjust patch. Signed-off-by: Leo Famulari <leo@famulari.name> ng0 2016-12-05gnu: i3-wm: Update to 4.13....* gnu/packages/wm.scm (i3-wm): Update to 4.13. [arguments]: Pass '-std=c11' to #:make-flags. Provide path to XML_CATALOG_FILES. Pass '--disable-builddir' to #:configure-flags. Re-enable the 'configure' phase to adjust to new Autotools build system. [inputs]: Add xcb-util-xrm. [native-inputs]: Add docbook-xsl. Leo Famulari 2016-11-19gnu: Use 'mirror://' URLs in several places....* gnu/packages/emacs.scm (m17n-lib)[source]: Use 'mirror://'. * gnu/packages/games.scm (extremetuxracer)[source]: Likewise. * gnu/packages/gcc.scm (%gcc-infrastructure): Likewise. * gnu/packages/gtk.scm (python2-pygtk)[source]: Likewise. * gnu/packages/perl.scm (perl)[source]: Likewise. * gnu/packages/telephony.scm (exosip)[source]: Likewise. * gnu/packages/wm.scm (xmonad)[source]: Likewise. (ghc-xmonad-contrib)[source]: Likewise. Ludovic Courtès 2016-10-01gnu: Add quickswitch-i3....* gnu/packages/wm.scm (quickswitch-i3): New variable. * gnu/packages/patches/quickswitch-fix-dmenu-check.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: 宋文武 <iyzsong@gmail.com> Ivan Vilata i Balaguer 2016-10-01gnu: Add python-i3-py....* gnu/packages/wm.scm (python-i3-py, python2-i3-py): New variables. Signed-off-by: 宋文武 <iyzsong@gmail.com> Ivan Vilata i Balaguer 2016-09-20gnu: awesome: Update to 3.5.9....* gnu/packages/wm.scm (awesome): Update to 3.5.9. [inputs]: Add gobject-introspection, lua-lgi, cairo. Use latest available lua. [arguments]: Set lua search paths. Add cairo to LD_LIBRARY_PATH. Wrap binary in respect to those paths plus GI_TYPELIB_PATH. doncatnip 2016-09-04gnu: awesome: Shorten the description....* gnu/packages/wm.scm (awesome)[description]: Shorten. Signed-off-by: Alex Kost <alezost@gmail.com> ng0 2016-07-21gnu: Update URLs for sourceforge.net....* gnu/packages/admin.scm: Update URLs pointing to sourceforge.net. * gnu/packages/audacity.scm: Likewise. * gnu/packages/audio.scm: Likewise. * gnu/packages/bioinformatics.scm: Likewise. * gnu/packages/boost.scm: Likewise. * gnu/packages/cdrom.scm: Likewise. * gnu/packages/code.scm: Likewise. * gnu/packages/compression.scm: Likewise. * gnu/packages/cups.scm: Likewise. * gnu/packages/djvu.scm: Likewise. * gnu/packages/docbook.scm: Likewise. * gnu/packages/documentation.scm: Likewise. * gnu/packages/flashing-tools.scm: Likewise. * gnu/packages/fonts.scm: Likewise. * gnu/packages/fontutils.scm: Likewise. * gnu/packages/games.scm: Likewise. * gnu/packages/ghostscript.scm: Likewise. * gnu/packages/gl.scm: Likewise. * gnu/packages/gnucash.scm: Likewise. * gnu/packages/graphviz.scm: Likewise. * gnu/packages/image.scm: Likewise. * gnu/packages/libreoffice.scm: Likewise. * gnu/packages/libusb.scm: Likewise. * gnu/packages/linux.scm: Likewise. * gnu/packages/lirc.scm: Likewise. * gnu/packages/maths.scm: Likewise. * gnu/packages/mcrypt.scm: Likewise. * gnu/packages/mp3.scm: Likewise. * gnu/packages/music.scm: Likewise. * gnu/packages/networking.scm: Likewise. * gnu/packages/onc-rpc.scm: Likewise. * gnu/packages/password-utils.scm: Likewise. * gnu/packages/pdf.scm: Likewise. * gnu/packages/perl.scm: Likewise. * gnu/packages/photo.scm: Likewise. * gnu/packages/popt.scm: Likewise. * gnu/packages/python.scm: Likewise. * gnu/packages/rdesktop.scm: Likewise. * gnu/packages/screen.scm: Likewise. * gnu/packages/swig.scm: Likewise. * gnu/packages/tcl.scm: Likewise. * gnu/packages/version-control.scm: Likewise. * gnu/packages/video.scm: Likewise. * gnu/packages/w3m.scm: Likewise. * gnu/packages/web.scm: Likewise. * gnu/packages/wm.scm: Likewise. * gnu/packages/xdisorg.scm: Likewise. * gnu/packages/xml.scm: Likewise. Leo Famulari 2016-07-12gnu: Remove unneeded 'imported-modules' fields for 'origin'....* gnu/packages/engineering.scm (fastcap)[source](modules, imported-modules): Remove. * gnu/packages/wm.scm (awesome)[source](imported-modules): Remove. * tests/packages.scm ("package-source-derivation, snippet"): Remove 'imported-modules' field. Ludovic Courtès 2016-06-16gnu: Add awesome....* gnu/packages/wm.scm (awesome): New variable. * gnu/packages/patches/awesome-reproducible-png.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Carlo Zancanaro